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How to Use this 
Documentation 

This chapter introduces the organization of the documentation. 

You can read about these topics in: 

 Documentation Overview 

 Important Product Documentation 

 Getting Started 

Documentation Overview 
The Rhapsody Gateway documentation is organized as shown in the following figure: 

 
 

There is one Coupling Note per tool interfaced with Rhapsody Gateway. These notes 

describe how Rhapsody Gateway brings to the engine the information to be analyzed, 

using either the third party tool API, or dedicated converter, or any other convenient 

solution. This part is dedicated to administrators or users in charge of Rhapsody Gateway 

customization, in relation with the Customization Guide. The Coupling Notes also explain 

to users how Rhapsody Gateway interacts with their authoring and verification tool. 
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The Customization Guide explains how you indicate to Rhapsody Gateway the relevant 

information that should be picked up in the intermediate files. Such information can 

include: what are the requirements, attributes, coverage links, and so on. In other words, 

the Customization Guide explains how to implement your requirement standards in 

Rhapsody Gateway. 

The User Manual explains how to use Rhapsody Gateway on your projects, such as how 

to describe your project's process, how to understand the analysis results, how to filter 

them, how to generate reports. Aspects directly linked to the use of authoring and 

verification tools are detailed in the Coupling Note for the concerned tool. 

Important Product Documentation 
Users need to read the User Manual and the Users part of the Coupling Notes for the tools 

they use (for example Coupling Word, Coupling DOORS, etc.). 

Administrators or Users who need to implement their requirements standards and to 

customize Rhapsody Gateway need to: 

 Read the Coupling Notes for the tool used in the project or process. This will 

enable you to understand how the source information is converted and analyzed 

by the engine. 

 Read the Customization Guide and play the Tutorial (direct links included in the 

Customization Guide, step by step). 

 Read the User Manual for more information about requirements management 

aspects and displays of analysis results by Rhapsody Gateway. This will enable 

you to understand users concerns and to properly support them. 

Getting Started 
The best way to familiarize yourself with Rhapsody Gateway is to complete the following 

tasks: 

 Read the Getting Started guide to familiarize you with the main windows, 

concepts and features. 

 Read and complete the tutorial example in that Getting Started. 

 Review the other sections in the User Manual, and familiarize yourself with all 

the windows, features and analysis results calculation.
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Capture and Analysis 
Process 

This chapter explains how the source information is captured and analyzed. 

You can read about these topics in: 

 Capture and Analysis Process—Related Documentation 

 Traceability Elements 

 Compliance with Quality Standards 

Capture and Analysis Process—Related 
Documentation 

In order for proper customization to take place, there needs to be a clear understanding of 

the analysis process. 

As depicted below, several steps have to be considered: 

 The source information is brought to the engine by converters. These converters 

transform the information natively stored in the interfaced tool to an intermediate 

file containing the information in a format that the engine can analyze. 

 The engine uses the definition of your requirements standards (what is the 

expected format for requirements, attributes, etc.) to identify elements compliant 

with this definition in the intermediate file. 

 The engine also uses the project definition, indicating how the intermediate files 

are supposed to be linked together. This allows the engine to calculate coverage 

ratios, check consistency rules, etc. The information is stored as ―analysis 

results‖. 

 The results can be filtered to allow more oriented analysis. 

 The results are displayed, produced in reports, or can be exported in tools to 

automate parts of the requirements management process. 
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The relationship between this process and Rhapsody Gateway windows usage can be 

described as follows: 

 The Project Editor is used to define the relationship between individual inputs 

and the Types applied to each document for their analysis. As explained in the 

Getting Started document, the Project Editor is the entry point for all new 

projects. 

 The types are customized using the Types Editor. This customization is 

described in the Customization Guide and not in that User Manual. Once the 

customization is performed by the Administrator, the internal Support team or 

Rhapsody Gateway Application Engineers, Project users will find the types 

available and ready to use from the Types of Analysis drop-down list box in the 

Project Editor. 

 The analysis results are displayed in the main window, containing several tabs 

and information areas. The main windows are introduced in the Getting Started 

document and detailed in this User Manual. 

 The filters are defined using the Filters Editor, described in this User Manual. 

 The report templates are defined in the Reports Editor for the content, and files 

created directly in the generation format are used as style sheets for the ―look and 

feel‖. 

 Exports to interfaced tools are activated from the Tools menu and can activate 

additional windows and buttons. These cases are described in the Coupling 

Notes. 

Traceability Elements 
Rhapsody Gateway defines the following traceability elements. 
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Section  

A section is a hierarchical file description element. The following are examples of 

sections:  

 Heading levels in a Microsoft Word file 

 Tabs in a Microsoft Excel spreadsheet 

 UML packages, diagrams 

 Modules, sub-modules and components of design models 

The tree is composed by Rhapsody Gateway‘s sections and gives you a hierarchical view 

of the analyzed input. 

Macro-requirement 

A macro-requirement is a ―super-requirement‖ that includes requirements and passes its 

properties onto those requirements.  

Any new element attached to a macro-requirement (attribute, text, link or coverage link) is 

also attached to the requirements and the derived requirements contained within the 

macro-requirement. 

A macro-requirement is derived if all its requirements are derived and if it is derived itself. 

See the section concerning Using Macro-requirement for more details. 

Requirement 

A requirement expresses either a need or a constraint (technical constraints, costs, 

deadlines, and so on). The requirement is written either in natural language or as an 

expression—which may be mathematical, geometric, computerized, and so on.   

A derived requirement is a requirement which does not refer to any Specifications 

requirement. This requirement is defined in a covering document but it does not cover a 

specification element. Indeed this requirement appears during the process and is 

considered as 'derived'. 

Entity 

By defining an entity, the user defines an element that must cover (contain a reference to) 

a requirement. If a defined entity does not contain any reference, Rhapsody Gateway will 

display a warning message.  

This is quite an advanced concept used only in specific cases, for example to detect a dead 

code. 

An entity cannot reference itself. 
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Reference 

A reference is the information indicating the coverage (implementation or verification) of 

a requirement. A reference points to a macro-requirement, requirement, or derived 

requirement.  

In Rhapsody Gateway, the reference can be defined either in a bottom-up direction, where 

the lower-level element covers the higher-level element, or in a top-down direction, where 

the higher-level element is covered by the lower-level element. 

Attribute 

Attributes complete the requirement. The following are examples of attributes:  

 Type of check—test, observation, and so on. 

 Category—functional, operational. 

 Criticality—low, high, and so on. 

 Flexibility—low, high. 

 Maturity—source, analyzed, approved, and so on. 

Rhapsody Gateway allows you to define attributes to be analyzed in the project files and 

filters the display in accordance with these attributes. 

Reference Attribute 

A reference attribute is added to a reference to define the type of coverage, such as partial 

coverage or provisional coverage.  

Link 

A link is reference information that does not concern coverage. The following are 

examples of links:  

 Supported by 

 Issued by 

 Checked by 

 Valid under 

 Allocated to 

 Result of 
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Text 

A text is the wording of a traceability element. Rhapsody Gateway attaches the text to the 

element (section, requirement) detected immediately above it.  

Traceability Links 
Rhapsody Gateway suggests three kinds of traceability between documents and folders. 

Cover 

All the requirements of the covered document have to be covered by elements of the 

covering documents. 

Mirror 

All the requirements of the upstream document have to be duplicated in the downstream 

document. The downstream document must have the same requirement identifiers than the 

upstream document. 

Dependency 

There are no constraint on the requirements of the linked documents. It is only 

informative. 

Compliance with Quality Standards 
Rhapsody Gateway allows compliance with the traceability objectives defined by quality 

standards: 

 CMMI for companies' processes; 

 DO-178B and DO-254 for civil aviation; 

 ECSS-E40 for space; 

 EN 50128 for railways; 

 IEC61508 for industry; 

 ISO 26262 for Automotive; 

 GAMP / 21 CFR parts 820 & 11 for pharmaceutics and medical devices; 

 etc. 
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Main Window 

This chapter describes the main window of the application. 

You can read about these topics in: 

 Main Window Presentation 

 Menu Bar 

 Toolbar 

 Status Bar 

 Project Workspace 

 Management View 

 Coverage Analysis View 

 Impact Analysis View 

 Graphical View 

 Requirement Details View 

 Link Details View 



Main Window 
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Main Window Presentation 
When you launch Rhapsody Gateway, the main window appears, as shown in the 

following figure: 

 
 

The main window is composed of four main parts: 

 the menu bar 

 the toolbar 

 the project workspace 

 the status bar 
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Menu Bar 
The menu bar contains the following menus: File, Edit, View, Tools, Reports, and Help. 

Browse the menus in the main window to familiarize yourself with their contents. As you 

hover over each menu item, the status bar displays a brief explanation of the menu item. 

File Menu 

The File menu contains the following items: 

Item Description 

New Creates a new project. Two saving formats are available 

Rhapsody Gateway project with File and Rhapsody 

Gateway project with Database. 

Open Opens a new project. 

Save Saves current modifications of the project. 

Save as Saves the current project. Two saving formats are available 

Rhapsody Gateway project with File and Rhapsody 

Gateway project with Database. 

Rename Renames the current project. 

Open Project Directory Opens the directory where the current project is located. 

Reload Refreshes the information displayed by reloading the not 

updated documents which have no intermediate file. 

Reload All Refreshes the information displayed by reloading and 

reanalyzing all project documents. 

Edit Project Opens the configuration editor. 

Edit Types  Opens the types editor. 

Edit Filters Opens the filter editor. 

Edit Snapshots Opens the Snapshot editor. 

<Recent files> A list of the last projects opened is presented in this menu 

section. 

Exit Closes all windows and exits the application. 
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Edit Menu 

The Edit menu contains the following items: 

Item Description 

Undo Cancels actions on element actions (Attributes, Reference 

Attributes or Coverage links creation). 

You can press <Ctrl>+<Z>. 

Redo Re-does actions on element actions that have been cancelled. 

You can press <Ctrl>+<Y>. 

Back Displays the previously displayed ‗page‘ of the main 

window. 

Forward After a ‗Back‘ action, displays the page preceding the ‗Back‘ 

action. 

Copy Copies the identifier of the selected requirement to the 

clipboard or copies the attribute values. 

Copy For Copies the selected element, with options (submenu): ID 

only or customized additional information defined for 

creation of direct traceability links. 

Paste In the Requirement Details View, this function will paste 

added attributes which have been copied in the clipboard. 

Delete Deletes the selected links. Available only for the links 

created from Rhapsody Gateway. 

Find Opens a dialog box to define a search action. 

You can press <Ctrl> + <F>. 

Find Next Searches the next occurrence of the string defined in the 

Find dialog box. 

You can press <F3>. 

Find Previous Searches the previous occurrence of the string defined in the 

Find dialog box. 

You can press <Shift> + <F3> 

Find in the tree Navigates from an element displayed in the Rule check 

section to the element in the analyzed document tree. 

Marks Provides submenus to create and manage Marks. 
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Item Description 

Navigate Displays the source document where the element has been 

detected. 

Create Covering Links Creates coverage links between the selected requirements. 

This is only available from the Graphical View and the 

Coverage Analysis View. 

Create Links Creates links (other than coverage) between the selected 

elements. Available only in the Graphical View and if links 

have been defined in a Type for Added Elements. 

Reverse Links Changes the direction of a link created from Rhapsody 

Gateway. 

View Menu 

The View menu contains the following items: 

Item Description 

Requirements Displays or hides requirements. 

Derived requirements Displays or hides derived requirements. 

Undefined requirements Displays or hides undefined requirements. 

Uncovered requirements Displays or hides uncovered requirements. 

Entities Displays or hides entities. 

Non Covering Entities Displays or hides entities covering nothing. 

Attributes Displays or hides attributes. 

Links Displays or hides links. 

Empty Sections Displays or hides empty sections. 

Added Information Displays or hides elements added from Rhapsody Gateway 

such as attributes, text or reference attributes. 
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Tools Menu 

The Tools menu contains items depending on: 

 The advanced interfaces available for your Rhapsody Gateway and project 

configuration. 

 The advanced interfaces, among the available ones, effectively used for your 

current project. 

The Tools menu contains the items for dialog with Third Party tools. Each item is fully 

described in the Coupling Notes for the interfaced tool.  

 

For example, the Tools menu can contain the following items: 

Item Description 

Options Opens the Options editor. 

Export Document to 

DOORS  

Creates DOORS formal modules containing project 

information, and Link modules for traceability between 

DOORS requirements and Rhapsody Gateway analysis 

results. 

Export document to 

RequisitePro  

Creates RequisitePro packages containing project 

information, and Traceability views for traceability between 

RequisitePro requirements and Rhapsody Gateway analysis 

results. 

Add High Level 

Requirements  

Makes available a requirements list in an authoring or 

verification tool. 

All trademarks are property of their respective owner. 

Reports Menu 

The Reports menu contains the following items: 

Item Description 

Edit Reports  Opens the report editor to create reports and edit report 

contents. 

Library Reports (installed by default). 

Traceability matrix Generates a traceability matrix between selected documents. 

Analysis results Generates a report containing the synthesis of analyzed 

elements. 
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Item Description 

Project description Generates a report with the project description. 

Upstream impact analysis Generates a report for upstream impact analysis from an 

element selected at a low level. 

Downstream impact 

analysis 

Generates a report for downstream impact analysis from an 

element selected at a high level. 

Synthesis of added 

information 

Generates a report containing the list of information added 

from Rhapsody Gateway. 

Rules Checking Generates a report containing the list of rule violations. 

Project Reports (defined by the user and/or by the Support Team). 

Subdirectories can be added to the Reports menu and contain reports defined by the user. 

Toolbar 
The toolbar contains shortcuts to commonly used selections of the menu bar. As shown 

below, the toolbar contains the following sections: Standard, Configuration, 

Navigation, View Options, Filtering, and Third Party Tools. 

 
 

 Standard and Access Control (1)—Contains buttons for creating, loading and 

saving project files. Save is locked by user during modifications 

 Configuration (2)—Contains buttons for configuring projects, types, snapshots 

and options. Plug-ins can be added there. 

 Navigation (3)–Contains buttons for applying navigation commands previously 

performed within the coverage information of the Coverage Analysis, Impact 

Analysis views, Graphical View and Requirement Details. It is only available 

for these views. 

 View Options (4)—Contains buttons to control which requirement elements are 

visible in the Coverage Analysis, and Impact Analysis views. 

 Filtering (5)—Contains the Filter drop-down list box to configure and apply 

filters. These filters specify the conditions by which to include requirements in 

analysis or views. 

 Third Party Tools and Plug-ins (6)—Contains additional buttons that apply to 

specific third party products, such as DOORS, and/or plug-ins. 
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Button Description 

 Creates a new project. 

 Opens an existing project. 

  Saves the modified files of the project. 

 Opens the configuration editor. 

 Opens the types editor. 

 Opens the snapshots editor. 

 Opens the Options dialog box. 

 Displays the previous view. 

 Displays the next view. 

 Displays or hides requirements. 

 Displays or hides derived requirements. 

 Displays or hides undefined requirements. 

 Displays or hides uncovered requirements. 

 Displays or hides entities. 

 Displays or hides non covering entities. 

 Displays or hides attributes. 

 Displays or hides links. 

 Displays or hides ―empty‖ sections (sections not containing any 

traceability information). 

 Displays or hides information added from Rhapsody Gateway. 

 
Selects a filter. 

 Opens the filter editor. 
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Status Bar 
The status bar displays common information in the application, such as descriptions of the 

menus or status while performing analysis. 

Project Workspace 
The project workspace is the main area of the application. This area displays the project 

information and analysis for the loaded project. The project workspace contains multiple 

view tabs for displaying the contents of the project. Each view may contain one or more 

panes. 

The project workspace contains the following views: 

 Management View—Displays the project documents, the elements of each 

document, and a summary of coverage information for the project. 

 Coverage Analysis View—Displays for a selected element of a document, one 

level of covering elements, N-1, and one level of covered elements, N+1, from 

other documents as defined by the project.  

 Impact Analysis View—Displays for a selected element of a document, all 

levels of covering elements, N-m, and all levels of covered elements, N+p, from 

other documents as defined by the project.  

 Graphical View—Displays each document graphically using a tree view with 

lines connecting requirement elements in documents and covering elements in 

other documents.  

 Requirement Details—Displays each requirement and its attributes for a 

document in a table. 

 Link Details—Displays covering information between a covering document and 

its covered documents. 

Management View 

Description 

To activate the Management View, click the Management View tab in the project 

workspace of the main window.  
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The Management View contains four panes: 

 The Overall Quality area displays the analysis results according to requirements. 

A status bar shows the ratios of errors and warnings in relation to the total 

requirements number. The red fragment represents the errors. The orange 

fragment represents the warnings. The green fragment represents the ratio without 

trouble. For each fragment, the number of requirements is displayed in white.  

This analysis is presented for the complete project then for each specific analysis 

category. Categories are assigned from the Project Editor and a status bar is added 

for each category in the Overall Quality area. See the section on Assigning 

document category to understand the categories behavior. 

This area also summaries general information on the project such as the project 

saving format, the number of documents, the requirements, etc. 

 The Project Overview area displays the covering analysis results by showing the 

project documents representation and their coverage ratio. 

Depending on the coverage ratios, links are displayed in green, orange or red: 

 from 0% to 70% links are red displayed 

 from 70% to 90% links are orange displayed 

 exactly 100% links are green displayed 

See the section concerning Understanding the Coverage Ratios for more details. 

 The Rule Check pane displays the list of violated rules, if any, and for each rule 

the list of elements violating the rule. The selection of an element in these lists 

selects the same element in the Coverage Analysis View. 

 The Information pane displays some additional details and messages concerning 

the element selected in the Project Overview. 
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Contextual Menu 

A contextual menu appears when you select a document in the Project Overview area and 

right click. This menu shows the Navigate item: 

Menu Comments 

Navigate Navigates to the source file corresponding to the selected 

document in the third party tool. 

Coverage Analysis View 

Description 

To activate the Coverage Analysis View, click the Coverage Analysis View tab in the 

project workspace of the main window.  

The Coverage Analysis View allows you to select elements from a project document and 

displays requirement coverage one level upstream and one level downstream from the 

selected document. 
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The columns in the upper half of the view contain the following three view panes: 

 Upstream Coverage Information—Displays one level of covered requirements, 

N-1, for a selected document element in the Selection column. 

 Selection—Displays the contents of the documents in the project.  

 Downstream Coverage Information—Displays one level of covering 

requirement reference elements, N+1, for a selected document element in the 

Selection column. 

 
 

The lower half of the Coverage Analysis View contains three tabs. Each tab is divided into 

three columns that display details about the selected element in the tree view pane in the 

upper half of the view. 

The three tabs are: 

 Texts and References Attributes—Displays the text for the selected item and 

any reference attributes. These references link the selection in the Selection 

column to the corresponding element in the Upstream Coverage Information or 

Downstream Coverage Information column. 

 Attributes—Displays the attributes for the selected item. 

 Messages—Displays helpful information, including rule violation details, for the 

selected item in the Selection column. 

Note 

The attributes are always displayed in these lists, regardless of the status of the 

button to hide or display "Attributes‖ in the Toolbar. 
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Contextual Menu 

A contextual menu appears when you right click an element or the project workspace 

background in the main window. The contextual menu depends on the activated view and 

on the selected element. 

These items are available in the Coverage Analysis View of Selection column: 

Menu Comments 

Copy Copies the identifier of the selected requirement to the 

clipboard or copies the attribute values. 

Copy For Copies the selected element, with options (submenu): ID only 

or with additional information defined in the type. This 

feature allows direct creation of traceability information in 

project documents 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Find Opens a window to define a search string, with options 

Find in the Tree Used to find an element selected in a Rule check section in the 

project tree. It is also used to navigate between linked 

elements (with relations through Links and not References) 

Marks Marks are used to highlight manually or automatically 

elements that have specific properties. Marks can be added 

automatically for modified elements and for the results of a 

Search action. 

See the sections on Marks to learn more. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party 

tool interface. 

Hide Selected Documents The selected document is no longer displayed. To display it 

again, use the Show Hidden Documents item. 

Show Hidden Documents Displays a dialog box with the list of the hidden elements, 

allowing the selection of documents to be shown again. 

Add an attribute Allows the addition of an attribute for the selected element. 

Opens two submenu items: Define a Boolean Attribute and 

Define a Value Attribute. 

See the section on the addition of elements to learn more. 

Edit Text or Add Text Allows the edition of text added to the selected element. See 

the section on the addition of elements to learn more. 
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Menu Comments 

Evaluate Opens the OTScript Evaluator 

Force Reload Reloads and reanalyzes the selected document(s) in order to 

update analysis results. 

 

These items are available in the Coverage Analysis View of Upstream/Downstream 

Coverage Information columns: 

Menu Comments 

Select Open the selected element in the central area. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party 

tool interface. 

Navigate to cover Opens the covering document in which the covering 

element is highlighted. 

Marks Marks are used to highlight manually or automatically 

elements that have specific properties. Marks can be added 

automatically for modified elements and for the results of a 

Search action. 

See the sections on Marks to learn more. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Add a reference attribute Allows the addition of an attribute for the selected element. 

Opens two submenu items: Define a Boolean Reference 

Attribute and Define a Value Reference Attribute. 

See the section on the addition of elements to learn more. 

Delete selected attributes Deletes the selected reference attributes. 

 

Context menus are also available in the lower half of the Coverage Analysis view. 
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In the Text and References Attributes pane, the following context menu is available if 

you click in the Reference Attributes area and if an element is selected either in the 

Upstream Coverage Information or Downstream Coverage Information column: 

Menu Comments 

Add a reference 

attribute 

Adds a Reference attribute to the coverage link between the 

element selected in the Selection column and the one selected in 

the Coverage column. Opens two submenu items: Define a 

Boolean reference attribute and Define a value reference 

attribute. 

See the section on the addition of elements to learn more. 

Delete selected 

attributes 

Deletes the selected reference attribute. You can only delete a 

reference attribute added from Rhapsody Gateway. 

 

In the Attributes pane, the following context menu is available if you click on the 

Attributes area and if an element is selected in the Selection column: 

Menu Comments 

Add an attribute Adds an attribute to the element selected in the Selection column. 

Opens two submenu items: Define a Boolean Attribute and 

Define a Value Attribute. 

See the section on the addition of elements to learn more. 

Delete Delete the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Impact Analysis View 

Description 

To activate the Impact Analysis View, click the Impact Analysis View tab in the project 

workspace of the main window.  

The Impact Analysis view displays for a selected element of a document, for all levels of 

covering elements, N-m, and for all levels of covered elements, N+p, from other 

documents as defined by the project. 

The columns in the upper half of the view contain the following three view panes: 

 Upstream Impact Information—Displays all levels of covered requirements, 

N-m, for a selected document element in the Selection column. 
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 Selection—Displays the contents of the documents in the project.  

 Downstream Impact Information—Displays all levels of covering requirement 

reference elements, N+p, for a selected document element in the Selection 

column. 

 
 

The lower half of the Impact Analysis View contains three tabs. Each tab is divided into 

three columns that display details about the selected element in the tree view pane in the 

upper half of the view. The three tabs are as follows: 

 Texts and References Attributes—Displays the text for the selected item and 

any reference attributes for references linking the selection in the Selection 

column to the corresponding element in the Upstream Impact Information or 

Downstream Impact Information column. 

 Attributes—Displays the attributes for the selected item. 

 Messages—Displays helpful information, including rule violation details, for the 

selected item in the Selection column. 

Contextual Menu 

A contextual menu appears when you right click an element or the project workspace 

background in the main window. The contextual menu depends on the activated view and 

on the selected element. 

These items are available in the Impact Analysis View: 

Menu Comments 

Copy Copies the identifier of the selected requirement to the 

clipboard or copies the attribute values. 
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Menu Comments 

Copy For Copies the selected element, with options (submenu): ID only 

or with additional information defined in the type. This feature 

allows direct creation of traceability information in project 

documents. See the Adding information… sections for more 

information. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Find Opens a window to define a search string, with options 

Find in the Tree Used to find an element selected in a Rule check section in the 

project tree. It is also used to navigate between linked elements 

(with relations through Links and not References) 

Marks Marks are used to highlight manually or automatically elements 

that have specific properties. Marks can be added automatically 

for modified elements and for results of a Search action. 

See the section on Marks to learn more. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party tool 

interface. 

Hide Selected 

Documents 

The selected document is no longer displayed. To display it 

again, use the Show hidden documents item. 

Show Hidden 

Documents 

Displays a dialog box with the list of the hidden elements, 

allowing the selection of documents to be shown again. 

Add an Attribute Allows the addition of an attribute for the selected element. 

Opens two submenu items: Define a Value Attribute and 

Define a Boolean Attribute. 

See the section on the addition of elements to learn more. 

Edit Text (or Add Text) Allows the edition of text added to the selected element. See the 

sections on the addition of elements to learn more. 

Evaluate Opens the OTScript Evaluator 

Force Reload Reloads and reanalyzes the selected document(s) in order to 

update analysis results. 
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These items are available in the Impact Analysis View of Upstream/Downstream Impact 

Information columns: 

Menu Comments 

Select Open the selected element in the central area. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party 

tool interface. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Marks Marks are used to highlight manually or automatically 

elements that have specific properties. Marks can be added 

automatically for modified elements and for the results of a 

Search action. 

See the sections on Marks to learn more. 

 

Context menus are also available in the lower half of the Impact Analysis view. 

In the Text and References Attributes pane, the following context menu is available if 

you click in the Reference Attributes area and if an element is selected either in the 

Upstream Coverage Information or Downstream Coverage Information column: 

Menu Comments 

Add a reference attribute Adds a Reference attribute to the coverage link between the 

element selected in the Selection column and the one 

selected in the Coverage column. Opens two submenu 

items: Define a Boolean reference attribute and Define a 

value reference attribute. 

See the section on the addition of elements to learn more. 

Delete selected attributes Deletes the selected reference attribute. You can only delete 

a reference attribute added from Rhapsody Gateway. 
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In the Attributes pane, the following context menu is available if you click on the 

Attributes area and if an element is selected in the Selection column: 

Menu Comments 

Add an Attribute Adds an attribute to the element selected in the Selection 

column. Opens two submenu items: Define a Boolean 

Attribute and Define a Value Attribute. 

See the section on the addition of elements to learn more. 

Delete Delete the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Graphical View 

Description 

The Graphical View displays each document as an object with its traceability elements 

displayed in a tree view within the object. You can move documents, adjust the width of 

the documents, zoom, and resize the containing page. 

Lines represent covering references between requirement elements of a document and 

elements in another document. Dotted lines represent links that are not coverage links.   

The color codes for the Coverage Links (references) displayed in the Graphical View are: 

Link Color Description 

 
 (Black) Standard link 

 
 (Red) Traceability violation 

 
 (Green) Link created from Rhapsody Gateway 

 
 (Blue) Link with a reference attribute attached 

Flying over a link, the following information is displayed: Reference to 

'<requirement>' Type: <reference_type_name> in a balloon. 

 

The lower half of the Graphical View contains three panes: 

 Attributes (or Reference Attributes if a reference is selected)—Displays the 

attributes attached to the item selected in the graphical view. 

 Text—Displays the text for the item selected item in the graphical view. 
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 Messages—Displays helpful information, including rule violation details, for the 

item selected in the graphical view. 

 

The Graphical view can display the full traceability graph. When you select an element, 

the view highlights the selected element, the covering elements and the lines between the 

elements, as shown below. 

 
 

Click the header of a document. When you make this selection the entire document is 

selected. 

 

The graphical view can also display a partial graph by focusing on some documents 

elements or by hiding some documents. 
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Focusing on a sub-graph 

Select an element in a document and right-click on the view to select View Graph for 

Selection from the context menu, the view will only display the highlighted elements from 

the three documents, as shown in the following figure.  

 
 

 

Right-click on the view and select Show All Elements from the context menu to show all 

the elements of the documents again.  

Hiding documents of a graph 

Right-click the document and select Hide Selected Documents from the context menu. 

When you make this selection, the view hides the selected document and displays the 

traceability information for the remaining two documents. 

Right-click on the view and select Show Hidden Documents in the context menu to 

access a dialog box selected documents to be visible again. 

Managing the documents in the graphical view 

As your document gets larger or more complex, you can perform the following actions to 

control the Graphical View: 

 Move documents within the Graphical View by selecting the document header 

and dragging the header to a new location. 

 Resize the width of a document by selecting the document header and dragging 

the resize handles that appear on the right side of the document. 

 Expand and collapse the sections by clicking the plus sign. You can also right-

click the header of a document and select Collapse Root Sections or Expand All 

Sections from the context menu. 
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 Zoom in and out by pressing <Ctrl> while scrolling your mouse wheel up or 

down, or by selecting either Zoom»100% or Fit in page from the context menu. 

Context Menus 

A context menu appears when you right click an element or the project workspace 

background in the main window. The context menu depends on the activated view and on 

the selected element. 

 

These menus and items are available in the Graphical View: 

Menu Comments 

Copy  Copies the identifier of the selected requirement to the 

clipboard or copies the attribute values. 

Copy For Copies the selected element, with options (submenu): ID only 

or with additional information defined in the type. This 

feature allows direct creation of traceability information in 

project documents. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway 

Marks Marks are used to highlight manually or automatically 

elements that have specific properties. Marks can be added 

automatically for modified elements and for results of a 

Search action. 

See the section on Marks to learn more. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party 

tool interface. 

Evaluate Opens the OTScript Evaluator 

Automatically Position 

Documents 

If this option is checked when some documents are hidden, 

the documents that are still visible are automatically 

repositioned. 

If this option is unchecked, when some documents are hidden, 

the still visible documents stay at their position. 

View Graph for Selection Displays the sub-graph for the selected elements, including 

the covering elements and the lines between the elements. 

Show all Elements Displays all the elements previously hidden thanks to View 

Graph for Selection option. 
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Menu Comments 

Hide Selected Documents The selected document is no longer displayed. To display it 

again, use the Show Hidden Documents or Show all 

elements item. 

Show Hidden Documents Displays a dialog box with the list of the hidden elements, 

allowing the selection of documents to be shown again. 

Collapse root sections  Minimizes the selected document by only displaying the 

sections of this document. 

Expand all sections  Expands the selected document, which has previously been 

minimized, thanks to the Collapse root sections option. 

Zoom Select Zoom>100% or Fit in page to zoom in and out. You 

can also press <Ctrl> while scrolling your mouse wheel up or 

down. 

Create Covering Links Allows you to create covering links between several elements. 

See the section on the addition of elements to learn more. 

Create Links Allows you to create links (other than covering links). If 

several links to create have the same name, the document's 

name is shown between parentheses. See the section on the 

addition of elements to learn more. 

Reverse Links Changes the direction of a link created from Rhapsody 

Gateway 

Force Reload Reloads and reanalyzes the selected document(s) in order to 

update analysis results. 

 

In the Attributes pane, the following context menu is available when an element is 

selected in the Graphical view: 

Menu Comments 

Add an attribute Adds an attribute to the element selected in the Graphical 

view. Opens two submenu items: Define a Boolean Attribute 

and Define a Value Attribute. 

See the section on the addition of elements to learn more. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 
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In the Reference Attributes pane available when a reference is selected in the Graphical 

view, the following context menu is available: 

Menu Comments 

Add a reference attribute Adds an attribute to the reference selected in the Graphical 

view. Opens two submenu items: Define a Boolean 

Reference Attribute and Define a Value Reference 

Attribute. 

See the section on the addition of elements to learn more. 

Delete selected attributes  Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

Requirement Details View 

Description 

The Requirement Details view displays each requirement and its attributes for a document 

in a table. 
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The document displayed is selected from the drop-down list box in the upper left. For this 

document, all the requirements, derived requirements, macro-requirements and entities are 

presented in the first column. The other column headers are the attributes and the cells 

contain values of these attributes. 

 
 

The lower half of the Requirement Details view contains two panes: 

 Text—Displays the text for the item selected in the first column. 

 Messages—Displays helpful information, including rule violation details, for the 

item selected in the first column. 

You can sort the elements: 

 Click one of the requirements in the first column and select Sort by Identifier in 

the context menu. 

 Click the header of an attribute column to sort elements using the value of the 

selected attribute. 
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Contextual Menus 

If you right click the header of an attribute created from Rhapsody Gateway, you get the 

following context menu: 

Menu Comments 

Rename Opens a dialog box allowing you to rename the selected 

attribute. 

Delete Deletes the selected attribute. You can only delete an attribute 

added from Rhapsody Gateway. 

 

If you right click a cell corresponding to an attribute created from Rhapsody Gateway, you 

get the following context menu: 

Menu Comments 

Copy Copies the value of the attribute. 

Paste Pastes the copied value. 

Delete Deletes the selected value. 

 

If you right click a cell corresponding to a requirement element in the requirements 

column, you get the following context menu: 

Menu Comments 

Sort by identifier Sort alphabetically the requirements column list. 

Sort by default Sort requirements according to their definition order in the 

document. 

Copy requirement ID Copies the requirement ID into the clipboard. 

Navigate Navigate to the selected requirement in the corresponding 

document. 
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Link Details View 

Description 

The Link Details pane displays covering information between a covering document and 

its covered documents. It also enables you to create suspicious links. See Suspicious links 

management section. 

This view enables you to easily create links. A covering link creation or a reference 

attribute assignment can be performed when the following conditions are met: 

 the covering document has a modification file with a type for added elements 

associated 

 this modification file has one or more references type defined 

Refer to the Customization Guide for more information about the added type creation. 

The Link Details view is shown in the following figure: 

 
 

The covering document area of the Link Details view corresponds to the covering 

document. It contains the following areas: 

 Document (1)—Allows the selection of the covering document. 

 Document content view (2)—Displays the content of the covering document 

with its elements. 

 Link type (3)—Shows the reference types defined in the added types of 

modification for the selected document in a combo-box. 

 Attributes (4)—Shows all the attributes of the selected element. 
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 Messages (5)—Displays the message associated to the selected element. 

 History (6)—Displays the links creation and the links removal history for the 

selected element. This tab is optional. 

 Text (7)—Displays the text of the selected element. 

 

The covered documents area of the Link Details view corresponds to the covered 

documents. It contains the following areas: 

 Requirements (1)—Displays the requirements of the covered documents and 

their hierarchy. Covering links are marked by a check or a green square. 

 Filter (2)—Allows you to filter the requirements of the covered documents to 

only visualize some of them. This field is case-sensitive and supports regular 

expressions. See next section for filters details.  

 Attributes (3)—Displays the attributes of the selected requirement. 

 Reference Attributes (4)—When it is possible, allows you to assign values to 

reference attributes defined in the added type of modification. There are listed in 

a multi-lines box. To learn more see the reference attribute definition.  

 Messages (5)—Displays the message relative to a reference, its contents will be 

displayed only if the selected requirement has a checkmark. 

 Information (6)—Displays the links creation and the value assignments to 

reference attributes history for the selected requirement. This tab is optional. 

 Text (7)—Displays the text of the selected requirement. 

Filter field usage 

Requirements of the covered documents can be filtered out in the Requirements area to 

make it easy to visualize. 

Type few characters of the requirements, for instance ‗REQ1‘, to create a simple filter. All 

requirements containing the string ‗REQ1‘ are now listed in the Requirements area. 

Regular expressions can be used to create more complex filters. Type for instance 

‗^PS_.*2$‘. All requirements beginning by ‗PS_‘ and ending by ‗2‘ are now listed in the 

Requirements area. Because this field is case-sensitive, use for instance (?i) to start your 

filter avoiding the case-sensitive mode.  
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Coverage Display 

When you select a covering document the whole view is updated with corresponding 

information. 

 
 

If the selected element covers high-level requirements with the selected link type, a check 

is placed next to the covered requirements. 

If the selected element covers high-level requirements with another link type, a green 

square is placed next to the covered requirements. If we fly over the green square 

information concerning the reference type is displayed. 

 
 

For more information on the covering links creation, see the chapter concerning addition 

of information. 

Keeping a History 

If the option Keep a history of cover link creation and deletion in Link Details view is 

selected in the Options > General window, you can keep comments in the History and 

Information areas of the Link Details view, otherwise these tabs are hidden and no history 

is saved. 

Commenting Link Creation and Deletion 

The option Comment cover link creation and deletion in Link Details view is available 

if the previous Keep a history of cover link creation and deletion in Link Details view 

is selected in the Options > General window. If you select this option, you can insert a 

comment when you click to create a cover link. This comment is added in the History and 

Information areas. 
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By the same way, when you click to delete a cover link, you can add a comment. 

 
 

This comment becomes visible in the History area. 
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Menus 

Contextual menus and Edit menu contain the following options: 

Menu Comments 

Display only requirements This option the ability to show only the requirements or to 

show requirements with hierarchy. 

Sort requirements When the option Display only requirements is activated, this 

option alphabetically sorts the requirements display. 

Show the covered 

requirements 

When the option Display only requirements is deactivated, 

Rhapsody Gateway displays only the covered requirements 

by the requirement selected in the covering document area. 

Navigate Runs the third party tool and selects the element in this tool. 

The accuracy of the selection can depend on the third party 

tool interface. 

Add link Creates a link if it is possible. 

Delete link Deletes a link if it is possible. 
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Configuration Dialog 
Box 

This chapter introduces the configuration dialog box for the topics concerning the 

operational use in project contexts. The topics concerning customization are described in 

the Customization Guide. 

You can read about these topics in: 

 Overview 

 Restricted Access to the Configuration Dialog Box 

 Management of Concurrent Access 

Overview 
Rhapsody Gateway launches the Configuration dialog box when you select a menu item 

or toolbar button to configure one of the following parts of your project: Project, Types, 

Snapshots, Filters, Reports, Expressions, XML or Options. 

 
 



Configuration Dialog Box 
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The Configuration dialog box contains the following panes: 

 Project—Allows you to configure the project by specifying the documents to 

include, the type of each document, and the covering relationship between 

documents. Refer to the Project Configuration chapter later in this User Manual 

for more information about configuring projects. 

 Types—Allows you to create new types or customize existing types for your 

project. Refer to the Customization Guide for more information about 

customizing types. 

 Snapshots—Allows you to create, manage and compare snapshots of your 

project. Refer to the Detection of Requirement Changes chapter in this User 

Manual for more information about using snapshots. 

 Filters—Allows you to define custom filters to analyze requirements and only 

display requirements from documents that meet specific criteria. You can enable 

filters using the Filter drop-down list box on the toolbar of the Rhapsody Gateway 

main window. Refer to the Filters Usage and advanced Analysis section of this 

User Manual for more information about using filters. 

 Reports—Allows you to define new custom reports. You can generate a default 

report or a custom report using the Reports > Library Reports submenu on the 

main window. Refer to the Generating Reports chapter in this User Manual for 

more information about generating documents. 

 Expressions—Allows you to test regular expressions used by Types to analyze 

the intermediate files. Refer to the Customization Guide for more information 

about customizing types. 

 XML—Allows you to test XML syntaxes used by Types to analyze the 

intermediate files. Refer to the Customization Guide for more information about 

customizing types. 

 Options—Allows you to set the default font for text in the application, set the 

password on the project, define environment variables, and other miscellaneous 

settings for the application. 

Restricted Access to the Configuration Dialog Box 
The access to the Configuration Dialog Box can be restricted. 

Select Tools > Options to open the Configuration Dialog Box. 

In the Project pane you can enter a password: 
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Once a password is defined for the project, you will see the dialog box shown in the 

following figure each time you try to open the Configuration dialog box: 

 
 

Access to the Configuration dialog box is granted only if the Password is correct. 

To change the password, select Tools > Options, enter the correct password to open the 

Configuration Dialog Box, and then type a new password in the Password field of the 

Project pane. 

Management of Concurrent Access 
Concurrent modification of the project is not allowed. 

Control Access on Rhapsody Gateway Activities 

While one user can modify some elements of a project, another user can modify different 

elements of the same project. The control access on a project is handled separately 

according to different activities. 

Activities which can be handled separately are: 

 Project Configuration Edition 

 Types of Analysis Customization 

 Filters Edition 

 Marks Creation 

 Modification Files Edition 
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User Changes Management 

When you want to add information from Rhapsody Gateway, you must have the 

appropriate access rights: 

 The first user who attempts to modify the project becomes the owner of the files 

in which he is making changes. Once he modifies a Rhapsody Gateway element, 

the appropriate file becomes locked. 

If another user has already locked the same file before, a dialog box like the 

following opens:  

 
 

 As long as a file is locked, the owner can undo or redo modifications. Once he 

terminates his modifications, he presses  to save them. The files associated with 

his modifications become unlocked again and undo and redo actions are no longer 

accessible. 
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Project Configuration 

This chapter explains how you can configure your project in order to describe to 

Rhapsody Gateway what your project lifecycle and your requirement standards are.  

You can read about these topics in: 

 Objectives 

 Description 

 Adding a Document 

 Adding Coverage Links between Documents 

 Adding a Folder 

 Folders and Coverage Links 

 Documents Covered by Combination of several Others 

 Modification Documents 

 Importing an Existing Project 

 Assigning a Document Category 

 Assigning a Cover Category 

Objectives 
A project specifies the documents that Rhapsody Gateway analyzes and displays, as well 

as the type of each document. A type defines how to select external files that represent a 

document, how to read the contents of the external files, how to interpret the contents as 

elements for managing requirements, and how to display the elements of the document. 
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A project also defines the relationship between these documents. 

 
 

Description 
The configuration window is composed of several areas such as the document details area 

and some creation buttons. 

Document Details Area 

If Details or Modification Files pane is selected, the lower part of the Project editor 

window contains the following fields: 

Field Description 

Name Used to name a document. It is a logical name that does depend 

on the name of the input element (file, directory, database 

module, etc.) 

Type of Analysis This drop-down list box displays the list of generic and 

customized types that can be used to analyze the document. 
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Field Description 

File or Directory 
Click on the button  to activate the browse, and click this 

button to select your source information. The dialog box that 

will be used for selection depends on the type selected for the 

document. Once the selection procedure is completed, the field 

is filled automatically. 

Ignore structure When this option is activated, Rhapsody Gateway will ignore 

structure errors in the analyzed documents (for example, a 

heading 3 section underneath a heading 1 section without any 

intermediate heading 2 section). 

Intermediate File When this option is activated, the intermediate file 

corresponding to the analysis of the source document is stored in 

directory named intermediate in the project directory. For some 

types, the default option is set by Rhapsody Gateway and cannot 

be modified. 

This option is helpful for the different types of customization 

activities. See the Customization Guide to learn more about the 

intermediate files. 

Block reloading When this option is activated, Rhapsody Gateway will avoid the 

reloading of the corresponding document. 

Variable This drop-down list box is filled automatically by Rhapsody 

Gateway and depends on the Type applied to the document. It is 

used in relation with the Value field to define additional 

parameters for the Type. 

Variables and expected Values are described in the Coupling 

Notes for the interfaced third party tool. 

Value See the explanation above for Variables. The Value field is used 

to define Variable values. Depending on the selected variable, 

this element can be a drop-down list box, a text field, or an 

option box. 

Access This field is used to define the access mode to the input file. 

Access can be local, HTTP, need dialog with a Configuration 

Management tool, a Document Management tool, etc. 

Right click on the Access field provides access to 'Intermediate 

access file' option that enables you to access a directory outside 

the project directory for the Access types. For instance the SVN 

working directory can be located out off the Rhapsody Gateway 

project directory. 
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If Covers pane is selected, the lower part of the Project editor window contains the 

following fields: 

Field Description 

Sources->Target All the connections between documents are listed as source 

document followed by target document. 

Kind Three kinds of covering links are available: cover, dependency 

and mirror. For further details on these traceability elements, refer 

Traceability Links section. 

 Cover is depicted as . 

 Dependency  is depicted as . 

 Mirror is depicted as . 

Cover is the default value for Kind. Covers contribute to the 

coverage ratio (coverage ratio is displayed in the management 

view on the arrows), dependencies do not. Mirror only indicates a 

reflexive link between documents. 

Category A category can be associated to the different cover link. This 

category name is displayed next to the link in the Project view.  

Creating Tools 

The following action buttons are available: 

Button Description 

 Used to add a folder. See the Using Folders chapter later in this 

document to learn more about the usage of folders.   

 Used to insert a new document for the project.  

 Used to add a Modification document.   

 Used to create coverage link between two documents.   

 Deletes the selected element (document, link or folder).  

  
Used to collapse (hide) / expand (show) the Documents Detail 

Area to maximize the size of the Traceability Description Area.   
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Edit Menu 

The configuration editor allows you to undo operations, and redo the previous operation. 

The edit fields for undo and redo are contained in the Edit menu: 

 Undo—Cancels actions on element editions or creations. 

 Redo—Reverses the undo field. 

Adding a Document 
To insert a new document into the Traceability Description Area, follow these steps:   

1. Click the Add a document  button. When you make this selection, the cursor 

automatically moves to the Traceability Description Area and the cursor outlines 

a document object. Click within this area to place the document. When you place 

the document, the document is added to the Project Tree pane. The Document 

Details pane displays the settings for the selected document in the Project Tree 

pane. 

1. In the document Details pane, click in the Name column to rename the document. 

The name in the document object now displays the new name. 

2. Click on the Type of Analysis column. Select from the drop-down list box the 

Type you want to apply. 

3. Click on the File or Directory column. The File Browse button appears on the 

right side of the field. Click the File Browse button and select the input 

information you want to consider. The selection procedure depends on the 

selected type of analysis (file, directory, database based type of analysis), and on 

the Access defined for the document (local, HTTP, configuration management 

tool, etc.) 

4. Check if Variables have to be defined. Variables are described in the Coupling 

Notes for the tool on which type of analysis is based (Word, Excel, etc.) 

5. If you need to define variables, define Values for each of them. 

Adding Coverage Links between Documents 
You define your traceability links directly in the Traceability Description Area, which is 

the graphical part of the project editor.   

To add a coverage link between documents, follow these steps. 

1. Click the Add a cover  button. The cursor moves to the Traceability 

Description Area. 



Project Configuration 

 

 

IBM
®
 Rational

®
 Rhapsody

®
 Gateway Add On 

60 

2. Click the covering (low level) document object first and then click the covered 

(higher level) document object. An arrow appears between the two documents. 

This arrow indicates that the low level document covers the high level document. 

You can also click the covering document by keeping the mouse button pressed and 

hovering over the covered document and then releasing your mouse button. This creates a 

link. 

For instance, your traceability graph could be created as shown in the following figure. 

 
 

Note 

The link arrow means "Covers". Links between documents are in two parts: by 

clicking and dragging on the circle you can alter the angle of the link. This is useful 

if there are several documents to be configured. 

You can select multiple documents in this graphical area, or in the project tree, by keeping 

[Ctrl] pressed during multiple click actions. You can also draw a selection area by clicking 

and dragging the mouse button. 

The following context menu appears if you right click in the Traceability description area: 

Item Description 

Copy Copies the selected document. The copied document can be 

pasted into the current project, or into another project along 

with its type and an updated path to the file to be analyzed. 

Paste Pastes the copied document. You can Paste documents 

copied from the Project Editor for the current project or for 

another project. 

Delete Deletes the document or link selected. 

Cleanup Link Activated only if you select a link. Re-draws the selected 

link. 

Navigate Navigates to the source file corresponding to the selected 

document. 

Note 

By pressing <Ctrl> while scrolling your mouse wheel up or down you will zoom in 

and out in the Traceability Description Area of the Project Configuration View. 
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Adding a Folder 
Folders can be used to group documents considered at a given step in your process, and/or 

in order to have a cleaner project configuration displayed for a large project. See the 

section about Using Folders to learn more about traceability management when a project 

contains folders.   

Concerning folders, note the following point: 

 Only one hierarchical level is allowed. You cannot create a folder inside a folder. 

 

To add a folder in your project configuration, follow these steps: 

1. Click the Add a folder  button. When you make this selection, the cursor 

automatically moves to the Traceability Description Area and the cursor outlines 

a folder object. 

2. Click within this area to place the folder. You can resize it. When you place the 

folder, the folder is added to the Project Tree pane. The Details pane displays the 

settings for the selected folders in the Project Tree pane. 

3. In the Details pane, click on the Name column to rename the folder. The name in 

the folder object now displays the new name. 

 
 

To navigate into the folder, double click the folder. To go out of the folder, double click 

on the background of the Traceability Description Area. 

 



Project Configuration 

 

 

IBM
®
 Rational

®
 Rhapsody

®
 Gateway Add On 

62 

To add a document in the folder, you can either:  

1. Open the folder and create your document as described in the previous sections. 

2. Select a document already created in the traceability description area, then drag 

and drop the document into the folder object. 

Folders and Coverage Links 
To add a coverage link between folders, or between a document and a folder, follow these 

steps. 

1. Click the Add a cover  button. The cursor moves to the Traceability 

Description Area. 

2. Click the covering (low level) document or folder object first and then click the 

covered (higher level) document or folder object. An arrow appears between the 

two objects. 

3. You can also click the covering document or folder by keeping the mouse button 

pressed and hovering over the covered document or folder and then releasing your 

mouse button. This creates a link. 

You may need to create more precise links between a document out of the folder and a 

specific document located in the folder. For this you will use the folder Ports such as 

. 

1. Create a traceability graph with links between a folder and document(s), or 

between folders containing document(s). 

2. Double click to enter the folder. As shown in the following figure, the 

Traceability Description Area now contains some Ports, one for each document 

linked to the folder. Hover over the port to display the name of the document 

represented by the port. 

3. To link a document contained in a folder directly with an external document, 

create a link between the document and the port using the Add a Cover button to 

create of a link between documents. The created link has no arrow; the direction 

is defined by the arrow icon of the port. 
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Note 

Individual links between documents through folder ports is not the typical use of 

folders, and has consequences on the traceability management. See the section 

concerning Using Folders to learn more about traceability management in cases 

involving folders and documents. 

 

The table below gives you additional information about Ports: 

Ports Description 

 
This port represents a document available for a traceability link TO this 

document: the document in the folder is covering the external document. 

To create a link, click on the document first, then on the port. 

 
This port represents a document available for a traceability link FROM 

this document: the document in the folder is covered by the external 

document. To create a link, click on the port first then on the document.  

 

It is better to consider a folder as a package of requirements that belong to the same 

project hierarchy level. But in some cases it is useful to add coverage links inside a folder. 

Use the Add a cover option to create links between internal documents. 

 
 

Document Covered by Combination of Several 
Others 

In a lot of cases, a high level document is not fully covered by only one lower level 

document, but by the combination of several documents. This is typically the case when 

you consider a system specification that will be refined into two sub-systems 

specifications. The sub-systems specifications together are supposed to cover the system 

specifications. 

In that case each high-level requirement is supposed to be covered by at least one of the 

lower level documents. Two configurations are also possible, as shown below. 
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In this configuration Rhapsody Gateway expects the Specifications requirements to be 

implemented AND tested. 

The requirement will be considered as uncovered until at least one reference is found in 

the Design Document AND in the Test Plan as well. 

 
 

In this configuration Rhapsody Gateway expects the Specifications requirements to be 

developed in the Software specifications OR in the Hardware specifications (or in both). 

The requirement will be considered as covered as soon as there is a reference found in the 

Software Document OR in the Hardware document (or in both). 

 

To create a combined link, follow these steps: 

1. First create the documents. As shown in the Figure above, a Specifications 

document can be covered by the combination of a Software document and a 

Hardware document. 

2. Next create a link between the Software document (covering) and the 

Specifications document (covered). 

3. Click the Add a cover  button, then click the second covering document (in 

our example the Hardware document). 

4. Instead of clicking the covered document object, click the circle in the middle of 

the coverage link that already groups the other two documents together. 

Note 

To delete a combined link, click one of the two halves of a link then click the 

Delete  button. 
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Modification Documents 
The Modification Documents are used to capture additional information that applies at 

the same level as a standard Document and to complete or modify it. 

 

Modification Documents are typically used in the following cases: 

 The version 1 of a document can be modified, completed, and reviewed during 

the project. Before getting a version 2 of the document, the project teams usually 

need to consider the version 1. They also need to consider additional review 

forms or modification sheets which contain information that completes, modifies 

or replaces the information contained in the original document. These additional 

elements can be managed as Modification Documents applied to the original 

document that was defined in the Project configuration. 

 A Specifications document can contain generic requirements. Some additional 

documents (typically worksheets) can create additional information to make 

generic requirements specific for the project. Additional worksheets can add 

attributes for allocation, priority, etc. and they are also managed as Modification 

Documents. 

 A Test plan contains the test definitions. These tests are performed and a test 

report is automatically generated by the verification tool. Instead of manually 

copying the test results into the Test Plan to produce a Test Report document, 

you can capture the results automatically by defining a Modification Document. 

 

To add a modification document, follow these steps:   

1. Select a document object in the Traceability description area of the project editor. 

2. Click the Modification Files tab of the document details pane. 

3. Click the Add a Modification Document  button. 

4. In the Document Details pane, click in the Name column to rename the 

document. The name in the document object now displays the new name. 

5. Click in the Type of Analysis column. Select from the drop-down list box the 

Type you want to apply. 

6. Click in the File or Directory column. The File Browse button appears on the 

right side of the field. Click the File Browse button and select the input 

information you want to consider. The selection procedure depends on the 

selected type of analysis (file, directory, database based type of analysis), and on 

the Access defined for the document (local, HTTP, configuration management 

tool, etc.). 

7. Check if Variables have to be defined. Variables are described in the Coupling 

Notes for the tool on which is based the type of analysis (Word, Excel, etc.). 

8. If you need to define variables, define Values for each of them. 
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When a document has modification files, an additional icon representing a yellow book is 

added to the icon of the modified document, in the Project editor, as shown in the 

following figure. 

The modification document appears underneath the document it modifies in the project 

tree pane. 

 

The Accumulate information option indicates to Rhapsody Gateway if the information 

captured in the Modification Document completes or replaces the information captured in 

the project document. 

Note 

Modification files do not remove elements coming from other modification files. 

The position of the modification files in the list is important. The analysis is 

performed in list order. 

Information contained in a file overwrites information contained in a file higher up 

the list if the box Accumulate information box is not checked. Otherwise 

information accumulates in list order.  
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In the main window of Rhapsody Gateway, the yellow icon indicating the modification of 

the project document is displayed as well, as shown in the following figure. The Messages 

tab in the lower half of the window gives you more information concerning the 

modification file. 

 
 

The Modification Documents are also used when you want to add information created 

from Rhapsody Gateway: 

 Default additions create an ―Internal Type‖ that you cannot edit or manipulate. 

To forbid the use of Internal Type see Types Definition section at the end of this 

document. 

 Advanced additions are based on the integration of modification documents using 

a ―Type for added elements‖.  

See the Adding information… sections to learn more. 

Additional information can be defined in a special modification file which is specified by 

the Type for Added Elements. (see the Customization Guide). 

Importing an Existing Project 
An existing project, or part of it, can be imported into your current project.   

 If you want to import the whole project, select File > Import and select the 

Rhapsody Gateway project file you want to import. 

 If you want to import only some documents of an existing project, open this 

project. In the Project Editor, select the documents you want to import, right click 

and select Copy in the context menu. Open your current project. In the project 

editor, right click in the traceability description area and select Paste in the 

context menu. 
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In both cases, the imported documents are added to the project configuration.  

The types of these documents are also duplicated if they are not available in the new 

project; i.e. neither in the Config directory nor in the project directory.  

The input files to be analyzed are not moved; the paths to these files are automatically 

updated in the File or Directory field of the Document Details Area. 

Assigning Document Categories 
A document category type can be assigned to a document or to a folder from the Project 

Editor. This information appears in the Management View to present a detailed analysis 

of documents. 

To assign a category to a document or to a folder, follow these steps: 

1. Select a document in the Project Editor. 

2. In the document Details area, a Category field, which is not a parameter of the 

document type, can be selected from the drop-down list of Variable. Select 

Category. 

3. Click Value to know the category values. The available category list appears in 

the drop-down list. Choose the desired value. 

 
 

See the Categories creation section from the Customization Guide to know how to create 

or modify categories. 

The principles of the categories association are the following: 

 Associating a category to a document: 

 once a category has been selected for a document, this category is 

associated to the document. 

 some categories can be associated by default according to the types folder of 

the document type. For example, if a document has a type of the ―uml‖ 

folder associated, the ―design‖ category is automatically associated to this 

document. 
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In this case, the category can be overloaded but not removed. See the 

Categories creation section in the Customization Guide to know how to set 

or unset this behavior. 

 Associating a category to a folder: 

 if the documents inside this folder do not have any associated category or 

have a default associated category (types folder association), the category 

associated to the folder is propagated to these documents. 

 if the documents inside this folder have already an associated category, they 

keep their category. 

 Dissociating a category: 

 a category association to a document can be removed if the association is 

not a default association. In order to, select the blank value in the Value 

field. The document will have no more associated category. 

 a category association to a folder can be removed by selecting the blank 

value for the Value field. Consequently, this category association is also 

removed for all documents inside this folder and having this category. If the 

documents had a category associated by default, they recover this category 

again. Other documents, which had a category different from the folder 

category, keep their category. 

Assigning Cover Categories 
A cover category type can be assigned to a cover from the Project Editor.  

To assign a category to a cover, follow these steps: 

1. Select a cover in the Project Editor. 

2. In the document Covers tab, select a cover. The available category list appears in 

the drop-down list of Category. Select a category. 
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See the Categories creation section from the Customization Guide to know how to create 

or modify categories. 
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Project Options 

This chapter introduces the options you can define for your project. 

The Options dialog box allows you to configure some options for your project. It contains 

three panes.  

 
 

You can read about these topics in: 

 Overview of the General Option pane 

 Overview of the Environment Option pane 

 Overview of the Project Option pane 

 Overview of the Connections Option pane 
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Overview of the General Option pane 
This window contains the general following fields: 

Field Description 

Font Changes the font of the trees displayed in the project 

workspace. This option does not change the fonts of the 

menus, menu items and pane names. 

Display document name in 

impact mode 

When this option is activated, Rhapsody Gateway displays 

the name of the document beside each element in the 

Upstream Impact Analysis and Downstream Impact 

Analysis panes of the Impact Analysis View 

Application stay on top When this option is activated, Rhapsody Gateway displays 

the Application on top of all the other applications on your 

desktop. 

Number of recent files in 

the File menu 

Defines the number of recent files listed in the File menu for 

direct opening. 

Update period (in hours) for 

non automatic updated 

document 

Some tools interfaced with Rhapsody Gateway are database-

based (i.e. DOORS), or more generally ―non file based‖, and 

it is not possible to automatically detect that information has 

changed. This option allows you to define a periodic update 

for these tools. 

Default type for directory 

drag and drop 

This combo provides all the directory types. Selecting one 

type allows you to define the kind of directory type to create 

during a drag and drop of a directory from the outside into 

the Project configuration window. 

Ask for reloadings When this option is activated, Rhapsody Gateway displays 

the reload dialog box. As a result a dedicated icon will 

inform you if a document is up to date or not. 

Enable debugging  Enables you to produce a log file in the project directory 

Launch supervisor when 

opening Windows session 

Enables to launch supervisor when opening Windows 

session. 

Open document after 

generation 

Indicates to Rhapsody Gateway that the reports must be 

opened automatically at the end of the generation process. 

Keep a history about cover 

link creation and deletion in 

Link Details view 

Gives you the possibility to keep the cover link notifications 

in the History and Information tabs. . Refer the Link Details 

chapter. 
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Field Description 

Comment cover link 

creation and deletion in 

Link Details view 

Gives you the possibility to access a wizard to insert 

comments when creating and deleting cover links. Refer the 

Link Details chapter. 

Overview of the Environment Option pane 
The Environment pane looks like the following: 

 
 

This window contains the following fields: 

Field Description 

Environment variables Environment variables can be necessary to give specific 

information concerning your tools and workbench 

environment. When they are necessary, these environment 

variables are described in the Coupling Note for the 

concerned tool. 

Name Name of selected environment variable  

Value Value of selected environment variable 
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Overview of the Project Option pane 
The Project pane presents the following project options: 

 
 

This window contains the following fields: 

Field Description 

View log file Opens the file containing the list of actions performed by 

Rhapsody Gateway. This file can help for your discussions 

with the Support Team. 

Password This field is used to define a password for access to the 

Configuration dialog box. See the chapter about restricted 

access to project configuration to learn more. 

Automatically check 

document dates 

This option indicates whether or not you want Rhapsody 

Gateway to check if the dates of project files have changed 

since the previous analysis. You can have Rhapsody 

Gateway performs the update automatically when you 

switch from an external application to the Rhapsody 

Gateway main window. In some cases and network 

configurations such an analysis it can take some time, 

therefore you will have the opportunity to deactivate it if 

you want. 
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Field Description 

Compare project after 

loading 

Avoid comparing calculations between two loadings of a 

project. This is useful for big projects. 

Activate suspicious link 

management 

Activates or not the suspicious links management for the 

current project. 

Handling Rules 

The Rules part allows you to choose the rules to be analyzed in the analysis process. 

The top of the Rules area lists Rhapsody Gateway rules and users rules by categories 

Internal Rules, OTScript Rules and Project Rules. Project Rules contains rules from 

files located in the project directory. All Project Rules are editable. 

For each rule from the three categories, you can choose if you want a rule to be analyzed 

or not by checking this rule. If the selected rule is OTScript written, its content is 

displayed in the code area. 

 
 

Corresponding analyzed rules appears following a color code in the Rule check in the 

project workspace of Rhapsody Gateway. 

 

A contextual menu is available on rules: 

Item Description 

Delete Delete the selected user rule. This option is only available 

on user rules. 

Select all Select all rules of the rules area. 

Deselect all Deselect all rules of the rules area. 
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An editing area is used to visualize rules code and to enter user own rules. When a new 

rule is validated, it is added to the rules list. 

 New rule—This button allows a new rule creation. It gives access to the rule typing 

area. Users rules are written in OTScript. New rules are saved in the rules.br file of the 

project. 

 Save—This button validates and accepts the new rule. The rule has been added in 

italics in the rules list. 

Creating a rule 

To create a new rule, follows these steps: 

1. Click the New rule button. An input area is accessible filled out with a rule 

template: 

 
 

Object class is the name of the class to insert the method within. 

Method name is the name of the rule. 

Alert degree corresponds to the alert level for a rule, it is described by a code, as 

follows: 

Alert degree 

code 

Type of rule Displaying color of concerned 

elements 

e1 error red 

e2 warning orange 

e3 information green 

e4 information no color 

LABEL corresponds to displaying names of the rule. Here, English and French 

labels are requested, but only one label can be defined. It is also possible to add 

Japanese and Chinese labels translations. 

2. Complete this syntax to define your rule. Type for instance: 

 
 

3. Click the Save button to validate your rule. The rule is added checked and in 

italics in the rules list.  
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This rule can be modified afterwards. 

 

During the creation phase, errors can appear:  

 If the rule in creation contains syntax errors a dialog message appears. 

 If a rule has already the same label and function name an error is raised. If only 

one of these names is the same the rule will be only modified. 

Overview of the Connections Option Pane 
This option enables you to define connection parameters. Indeed, creating a profile 

enables you to configure the servers you often connect to. 

For instance, the Connections pane looks like the following: 

 
 

 

This window contains the following fields: 

Field Description 

Profiles A profiles area which lists created profiles according to tools 

to connect to. 
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Field Description 

Add new profile This button allows you to access the form to define a new 

profile. 

Delete selected profile This option allows you to delete the selected profile. 
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Managing the Analysis 
Results 

This section explains how to understand and manage the analysis results displayed in the 

project workspace of Rhapsody Gateway. 

When Rhapsody Gateway analyzes your project information (documents, database 

modules, etc.) it provides you with: 

 A list of elements violating default rules and customized rules in the Rule check 

section. The first action to perform once results analyses are available in the 

project workspace is to analyze the reported errors. 

 Coverage ratios. 

 Navigation in the traceability graph. 

 Filter capabilities, for more targeted display and results, and for oriented reports 

generation. 

 Features allowing you to create additional information within the Rhapsody 

Gateway environment, such as attributes, links, texts. 

 Features allowing the transfer of items captured in a given tool into another 

interfaced tool. This is typically done to make requirements captured at a high 

level available in an authoring tool environment. 

 Navigation features between Rhapsody Gateway and interfaced tools. 

 

This section focuses on analysis of the information captured by Rhapsody Gateway. For 

detailed description of the views, menu items, toolbar and panes, see the sections 

concerning the Main window and the Configuration dialog box. 

You can also refer to the Getting Started document for a first overview of Rhapsody 

Gateway's main capabilities. 

You can read about these topics in: 

 Rules Checking 

 Using Views 

 Displaying Requirement and Reference Types 

 Displaying Reducing Filters 

 Filter Usage and Advanced Analysis 

 Understanding the Coverage Ratios 
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 Folders 

 Macro-Requirements 

Rules Checking 
 When Rhapsody Gateway analyzes the project artefacts, it checks the compliance of 

analysis results with rules defined in your configuration. The rules set is composed of the 

default rules installed with Rhapsody Gateway, and the customized rules that can be 

created by trained users, the Support Team or our experts. Customized rules allow a more 

advanced and a more dedicated support of your requirements management process. 

The first step of your analysis process should be to review the rules activated in the Rule 

Check section of the Selection column in the project workspace. 

An effective way to navigate between the Rule Check section and the project analysis 

results is: 

 Expand the Rule Check tree and select an element violating the rule. 

 Double click the element to navigate to the selected element in the project 

workspace, and analyze it. You can also navigate to the source document. 

 Click the Back  button on the toolbar to go back to the previous display, with 

the element selected in the Rule Check section. 

 Select the following element to analyze it. 

 

In addition to the Rule Check section, some icons are displayed on the right side of the 

Selection column for specific information. 

Icon Description 

 Derived requirement 

 Uncovered requirement 

 Undefined requirement 

 Non-covering entity 

 

If you hover over one of these icons, additional information is displayed. 

The icons are brought up to the document level, giving you the information even if the 

document tree is collapsed. 

Click on the icon to quickly navigate to the first element concerned by the warning 

message. 
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Using Views 

Using the Management View 

See the section describing the Management View to learn more about details and context 

menus. 

The Management View contains project information, the only possible change in this view 

is the refresh of the coverage ratio displaying for each document. 

Using the Coverage Analysis View 

See the section describing the Coverage Analysis View to learn more about details and 

context menus. 

This section describes the behavior of Upstream Coverage Information and 

Downstream Coverage Information according to the done actions on the Section tab. 

 

When you click an element in the Selection column, the Downstream Coverage 

Information column automatically displays the elements covering the one you selected, 

and the coverage ratio between documents.  

The following figure shows the coverage of the PS_USB_REQ1 requirement. The 

Downstream Coverage Information column displays the ―1.1 USB 1.0 Speeds‖ section 

as a covering element because this section of the document contains a reference to the 

requirement. You can also see that the Product Specification document is covered at 83% 

by the Design Specification document. 
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In the following figure, the Downstream Coverage Information column does not display 

any covering elements because the covering document does not contain a reference to the 

requirement. 

 
 

An added rule violation and the exclamation icon at the right side of the PS_USB_REQ2 

highlight the requirement as an ―Uncovered Requirement‖. 

 

The following figure shows the selection of a parent element. The child elements of the 

―Analog Channels‖ section contain two requirements: PS_AI_REQ1, and PS_AO_REQ1. 

The Downstream Coverage Information column displays both the ―2.1 Analog Input‖ 

and the ―2.2 Analog Output‖ sections as covering elements. In the covering document, the 

―2.1 Analog Input‖ section contains reference to the PS_AI_REQ1 requirement and the 

―2.2 Analog Output‖ section contains reference to the PS_AO_REQ1 requirement. 

 
 

Double-click an element in the Downstream Coverage Information column. Rhapsody 

Gateway navigates to this element in the Selection column. 

When you select an element in the Selection column, the Upstream Coverage 

Information column automatically displays the elements covered by your selection, and 

the coverage ratio between documents. 
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In the following figure, the Upstream Coverage Information column displays that 83% 

of the requirements in the ―Product Specification‖ document are covered by the ―Design 

Specification‖ document. It also displays that the PS_AI_REQ1 requirement is 

specifically covered by references from the ―2.1 Analog Input‖ section in the Selection 

column. 

 
 

 

To summarize, the Coverage Analysis View allows you to select elements from a project 

document and displays requirement coverage one level upstream and one level 

downstream from the selected document. For analysis of requirements coverage for 

several levels both upstream and downstream, use the Impact Analysis View. 

Using the Impact Analysis View 

The Impact Analysis View displays traceability information from all downstream and 

upstream documents instead of just displaying the immediate downstream and upstream 

document. 

All the features related to the navigation, selection, coverage ratio calculation, etc. are the 

same as the ones available in the Coverage analysis view. 

The following figure shows the Downstream Impact Information for the PS_USB_REQ1 

requirement. The Downstream Impact Information column displays the covering ―1.1 

USB 1.0 Speeds‖ section from the ―Design Specification‖ document. 

 
 

Note 

Document names are displayed between brackets in the Downstream and Upstream 

information columns only if you activated the option ―Display document name in 

impact mode‖ in the Options dialog box.  
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As the covering of the ―1.1 USB 1.0 Speeds‖ section from the ―Design Specification‖ is 

not a requirement, it cannot be covered downstream. Therefore the displayed information 

is equivalent to the one displayed in the Coverage analysis view. 

The following figure shows the Downstream Impact Information for the PS_USB_REQ2 

requirement. The Downstream Impact Information column displays the requirements 

from the covering ―Design Specification‖ document, but it also displays the sections from 

the ―Test Specification‖ document that covers these requirements. 

 
 

 

This is the main difference with the Coverage Analysis View, because in this case the 

Coverage Analysis View displays only the coverage of the PS_USB_REQ2 requirement 

by the requirements contained in the ―Design Specification‖ document, at the immediate 

downstream level, but not the lower level information contained in the ―Test 

Specification‖ document. 

Displaying Requirement and Reference Types 
Your types of analysis can be defined to support several kinds of requirements, attributes, 

sections, references, etc. 

Information concerning the requirement or the reference is displayed in the Management, 

Coverage analysis and Impact analysis views when you hover over an element. 

The following figure shows that the name of the requirement defined in the Types editor, 

is displayed in the Selection column: 
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The following figure shows that the name of the reference (coverage link) defined in the 

Types editor, is displayed in the Downstream Coverage Information column (and in the 

Upstream Information Column as well) when you click an element in the Selection 

column and hover over covering elements. This feature is helpful to quickly see all the 

link types involved in coverage of a requirement. 

 
 

Filters Usage and Advanced Analysis 
Some reducing filters are provided by Rhapsody Gateway to get a more targeted display in 

the project workspace. 

You can also build advanced filters by creating your conditions and creating targeted 

displays, analysis results and reports generation. 

For example, if a system specification contains requirements allocated to hardware and 

software, the software development teams may want to filter the analysis result in order to 

have only the software requirements displayed. 

Display Reducing Filters 

The toolbar of Rhapsody Gateway contains several buttons used to show or hide specific 

elements. 

Button Description 

 Displays or hides requirements 

 Displays or hides derived requirements 

 Displays or hides undefined requirements 

 Displays or hides uncovered requirements 

 Displays or hides entities 

 Displays or hides non-covering entities 

 Displays or hides attributes 
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Button Description 

 Displays or hides links 

 Displays or hides ―empty‖ sections (sections not containing any 

traceability information) 

 Displays or hides information added from Rhapsody Gateway 

 

To display or hide ALL attributes, you can select View > Attributes or the Attributes  

in the toolbar. 

You can also apply a more selective display reduction, as shown in the following figure. 

In order to do so, follow these steps: 

1. Right click the attribute button  in the toolbar. 

2. A context menu appears, containing the list of the types used in the project, with 

the attributes defined for each type. Select the attributes you want to display or 

hide. 

 
 

Note 

In the Requirement Details view, display reduction filters can be used to hide or 

show the attribute columns. 
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Defining Filters 

Filters are defined using the Filters Editor. This editor allows to filter requirements or 

links. To open the Filter Editor, select File > Edit Filters or click the Filters button  in 

the toolbar. 

 
 

Filters list area 

The top left hand side of the dialog box contains a list of filters and options to manage the 

filters list: 

Button Function 

 Creates a new filter.  

 Moves the selected filter up in the list. 

 Moves the selected filter down in the list. 

 Deletes the selected filter.  
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The corresponding contextual menu offers two options: 

 
 

 

The Show in list option is used to indicate whether or not you want the filter to be 

displayed in the filters list of the main window. As filters themselves can be used as 

conditions for defining advanced filters, you may not want to have these intermediate 

filters displayed in the list. In this case, deactivate the Show in list option. 

 

Filters are listed as trees in the filter list area. If several filters files define filters they are 

all shown and used in the filter list area. See Filter Definition File section. 

Some filters can be placed in library to be used for each Rhapsody Gateway project. Refer 

to Sharing filters files section to learn more about this point. 

 

A filter which contains errors is displayed in ref in the filter list area and in the filters list 

of the main window. 

Parameters definition area 

The bottom left area of the dialog box contains an area to define parameters and options to 

manage the parameters: 

Button Function 

 Creates a new named parameter. 

 Deletes the selected parameter. 

If a filter is based on an attribute value, this value can be dynamically input when applying 

the filter. If the attribute is an enumeration, possible values are suggested, otherwise type 

$<parameterName> in the value field of the condition declaration. 
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See below a filter example using a parameter: 

 
 

Using environment variables 

If a filter is based on a variable, this value can be defined when applying the filter. If the 

attribute is an enumeration, possible values are suggested within a list. In this case, enter 

$<variableName> in the value field of the condition declaration. 

Filters definition area 

The Conditions pane contains several areas: 

The Filter out elements unless area is used to combine the conditions in two ways: 

 at least one of the following conditions—in a logical OR 

 all of the following conditions—a logical AND 

 
 

 

The Apply filter to is used to indicate if the filter is a display filter or an analysis filter. 

See Impacts of Filters Definition section to obtain description of these concepts. 
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The Hide children of filtered elements option is used to indicate whether or not you 

want the children of the filtered elements to be displayed. If you do not want to have the 

children of the filtered elements displayed, activate this option. 

 

The Condition area contains options to create a condition: 

Button Function 

 Creates a new condition, which is added to conditions in the 

multi-lines conditions area. 

 Deletes the selected condition. 

Condition on This area contains four fields to let you compose a 

condition: the application class, the receivers, the operators 

and the values. A selection in a field implies the elements 

available in the next fields. 

The application class contains the kind of elements 

concerned by the condition: requirement/macro-

requirement, entity, section or reference. 

Concerning the receivers, the '*.<element type>' is the only 

receiver which is independent of the document type for 

covering links. 

Operators can be unary or binary. 

Values have four possible values: 

 nothing when the operator is unary 

 an input field to type a textual value 

 a list of enumerated values for enumerated attributes 

 a list of rules for a rule operator 

 

See below for a filter creation example. 

Creating a Filter 

A filter is based on conditions. To create a filter, you can create one or several conditions. 

Follow these steps to create a condition: 

1. Click  in the Condition area to add a new condition. Name your filter. 

2. Choose in the Condition on field, if the condition will be applied to 

requirement/macro-requirement, entity or reference. 
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3. Use the drop-down list box to build the condition: 

 The first drop-down list box is filled automatically by Rhapsody Gateway 

according the definition of your type, and displays all the elements you can 

use to filter. Select one of them. 

 The second drop-down list box contains conditions (is present / is absent / is 

equal to /etc.) 

 Depending on the condition, Rhapsody Gateway displays an additional field 

to enter the value. 

For instance, if the condition is ―is equal to‖, enter the target value in this 

additional field. A possible value is the parameter value, so as to fill out this 

field with $<parameterName>.  

 
 

If the element selected in the first drop-down list is an enumerated attribute, 

all values are suggested. 

4. Click  to create additional conditions. 

5. Check the pane Filter out elements unless. 

6. Check the pane Apply filter to. 

Applying Filters to Project Analysis Results 

Once defined, the filters are selected from the drop-down list box in the toolbar: 

 
 

The filters remove the requirements that fit with the conditions defined for the apply filter. 
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To use a filter which contains a parameter, choose the filter to apply to the project. A 

dialog box opens to enter the parameter value: 

 
 

Requirements which correspond to this attribute value are the only displayed. 

Impacts of Filters Definition 

The display filter is the most intuitive one. The filtered elements are removed from the 

display in the project workspace. 

An analysis filter has a stronger action. The filtered elements are more often used by 

Rhapsody Gateway for the coverage analysis.  

The following figure shows an example: LL_REQ1 covers REQ2. For instance, we can 

consider a ―Safety‖ filter defined to consider only the requirements with a ―Safety‖ 

attribute.  

 If ―Safety‖ is a display filter, REQ2 is simply hidden.  

 If ―Safety‖ is an analysis filter, REQ2 is completely ignored. This means 

LL_REQ1 references a requirement considered as no longer existing, which 

raises the warning ―Undefined requirement‖. 

 
 

Note 

Because of this strong action, some features may be deactivated when an analysis 

filter is applied. To get access to these features, deactivate the filter (or make it a 

display filter). 

 

Applying a filter impacts the coverage ratios. See the section about Understanding the 

Coverage Ratios below to learn more. 

Applying a filter can impact the Export actions of analysis results to a third party tool. See 

the Coupling Notes for more information. 
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Applying a filter impacts the Reports generation. Only the non-filtered results will be 

included in the reports. A dialog box informs you that a filter is applied, you can then 

confirm that you want a filter-oriented reports generation, or interrupt the generation 

process to remove the filter. 

Understanding the Coverage Ratios 
The following sections describe the coverage ratio formula. 

General Case 

The coverage ratios presented in the Coverage Analysis view are calculated as follows: 

 Number of requirements for the covered document referenced in covering document 

Number of requirements in the covered document 

 
 

Coverage Ratio for Combined Coverage 

When a document is covered by the combination of several downstream documents, 

Rhapsody Gateway gives you: 

 The coverage ratio between the upstream document and each downstream 

document, as described in the previous chapter. 

 The coverage ratio corresponding to the combined coverage, calculated as 

follows: 

 Number of requirements referenced in at least one covering document 

Number of requirements in the covered document  

 
 

In other words, the combined coverage ratio is  

 Number of requirements not referenced in any of the covering document 

Number of requirements in the covered document  

1 -  

 
 

Coverage Ratio in the Management View 

When a document is covered by several documents with independent coverage links, the 

Coverage Analysis and Impact Analysis views display a coverage ratio calculated as 

described in the General case section. 
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For this project configuration, a requirement is considered to be covered if it is referenced 

in ALL the downstream documents. 

The coverage ratio displayed in the Management view provides you with the information 

concerning these covered requirements compared to the total number of requirements. 

 Number of requirements referenced in ALL the covering documents 

Total number of requirements in the covered document  

 
 

 REQ1 

REQ2 

REQ3 
REQ4 

Covers_REQ1 
Covers_REQ4 

Covers_REQ2 

Covers_REQ3 
Covers_REQ4 

50% 

75% 

Coverage Ratio 

25% 
Only REQ4 is covered 

 
 

Note 

A reflexive coverage link (document covering itself) is not considered in this 

coverage ratio. Adding a reflexive link on the upstream document does not change 

the coverage ratio. 

Impact of Filters on Coverage Ratios 

Defining filters impacts Coverage ratios. 

Filters are applied to a given type of analysis. If your filter condition is based on an 

attribute defined in the type My_Type, only the requirements contained in documents of 

that type are filtered. 

Ratios are updated according to the filter selection. 

When a filter is applied, the coverage ratio displayed is calculated as follows: 

 Number of requirements referenced in the covering document, filtered 

Total number of requirements in the covered document, filtered 

 
 

 

As an example, if you consider: 

 a Specifications document with 10 requirements: 6 with Priority = High and 4 

with Priority = Low 
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 a test report with 10 tests: 8 will result with "Passed" and 2 will result with 

"Failed" 

 the table below summarizes the traceability information: 

Specifications Tests Comments 

REQ_1 (High Priority) Test_1 (Passed)  

Specifications are 

covered by tests at 90% 

 

9 requirements tested /  

10 specification 

requirements 

REQ_2 (Low Priority) Test_2 (Failed) 

REQ_3 (High Priority) Test_3 (Passed) 

REQ_4 (Low Priority) Test_4 (Failed) 

REQ_5 (High Priority) Test_5 (Passed) 

REQ_6 (Low Priority) Test_6 (Passed) 

REQ_7 (High Priority) Test_7 (Passed) 

REQ_8 (Low Priority)  

REQ_9 (High Priority) Test_9 (Passed) 

REQ_10 (High Priority) Test_10 (Passed) 

 

A filter based on the condition ―Priority = High‖ will reduce the traceability graph: 

Specifications (Filtered) Tests Comments 

REQ_1 (High Priority) Test_1 (Passed) Specifications with High 

priority are covered by 

tests at 100 % 

6 requirements tested / 

6 specification 

requirements when the 

filter is applied 

REQ_3 (High Priority) Test_3 (Passed) 

REQ_5 (High Priority) Test_5 (Passed) 

REQ_7 (High Priority) Test_7 (Passed) 

REQ_9 (High Priority) Test_9 (Passed) 

REQ_10 (High Priority) Test_10 (Passed) 

 

A filter based on the condition ―TestResult = Passed‖ will reduce the traceability graph: 

Specifications Tests (Filtered) Comments 

REQ_1 (High Priority) Test_1 (Passed)  
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Specifications Tests (Filtered) Comments 

REQ_2 (Low Priority)  Specifications are 

covered by tests ―passed 

―at 70% 

 

7 requirements tested 

with a result in ―Passed‖ 

/  

10 specification 

requirements 

REQ_3 (High Priority) Test_3 (Passed) 

REQ_4 (Low Priority)  

REQ_5 (High Priority) Test_5 (Passed) 

REQ_6 (Low Priority) Test_6 (Passed) 

REQ_7 (High Priority) Test_7 (Passed) 

REQ_8 (Low Priority)  

REQ_9 (High Priority) Test_9 (Passed) 

REQ_10 (High Priority) Test_10 (Passed) 

Using Folders 
Folders can be used to group some documents considered at a given step in your process 

and/or to have a cleaner project configuration displayed for a large project. 

Note 

Only one hierarchical level is allowed. You cannot create a folder inside a folder. 

 

When a project is defined with coverage links between a folder at a given level and a 

folder at a lower level, the coverage ratio between folders is: 

 Sum of references of high level requirements in the low level folder 

Sum of requirements in documents of the high level folder 

 
 

This calculation is applied whether coverage links are folder-folder, folder-lower level 

document(s), or documents-lower level folders types. 

This coverage ratio is displayed opposite a folder in the Project Workspace. 

Other coverage ratio calculations depend on the configuration graph. 
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Coverage Link between a Low Level Folder and a High Level Folder 

In this case configuration looks like: 

 

 

 

Doc1-1 : N1 Requirements 

Doc1-2 : N2 Requirements 

Doc1-3 : N3 Requirements 

P2 Requirements 
R3 references to Doc1-1 

R4 references to Doc1-3 

Folder 1 

Folder 2 

P1 Requirements 
R1 references to Doc1-1 

R2 references to Doc1-2 

Calculation of % between folders : 
 

Sum of referenced requirements 

N1 + N2 + N3 

 

 

 

For links between a high level folder and a lower level folder, each document in the high 

level folder behaves like if it has combined coverage links with the documents in the 

lower level folder. When a high level document, or an element (section, requirements, 

etc.) of the high level document is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays the combined coverage ratio between the selected 

high level document and the combination of all the documents in the lower level 

folder. 

 Rhapsody Gateway displays the coverage information between elements in the 

high level document and the document at the lower level in the standard way. 

 

 
 

When a high level document or an element (section, requirement, etc.) of the high level 

document is selected, the lower level display behaves as if you have the configuration 

shown at the right. 

In addition, you can expand / collapse the folder and Rhapsody Gateway displays the 

coverage ratio between folders. 
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In the case of a coverage link between the high level folder and the lower level folder, 

each lower level document is considered to cover all the documents in the high level 

folder. When a high level document, or an element (section, requirement, etc.) of the high 

level document is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays, in the standard format, the coverage ratio between 

elements of the low level document and the high level documents. 

 

 
 

When a lower level document, or an element (section, requirement, etc.) of the lower level 

document is selected, the high level display behaves like the configuration shown at the 

right. 

In addition, you can expand / collapse the folder and Rhapsody Gateway displays the 

coverage ratio between folders. 

Coverage Links between Documents in a Folder 

Direct links between documents contained in a folder can be created using folder ports 

(see the section concerning project configuration to learn more). In this case configuration 

looks like: 

 

 

 

Doc1-1 : N1 Requirements 

Doc1-2 : N2 Requirements 

Doc1-3 : N3 Requirements 

P2 Requirements 
R3 references to Doc1-1 

R4 references to Doc1-3 

Folder 1 

Folder 2 

P1 Requirements 
R1 references to Doc1-1 

R2 references to Doc1-2 

Calculation of % between folders : 
 

Sum of referenced requirements 
N1 + N2 + N3 

 

 
 

In the case of direct links between documents folders, coverage information is displayed 

in the same way as when the documents are not in a folder. 
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Coverage Links between a Lower Level Folder and a High Level 
Document 

Direct links between a folder can be created using folder ports (see the section concerning 

project configuration to learn more). In this case configuration looks like: 

 

 

 

Doc1-1 : N1 Requirements 

Doc1-2 : N2 Requirements 

Doc1-3 : N3 Requirements 

P2 Requirements 
R3 references to Doc1-1 

R4 references to Doc1-3 

Folder 1 

Folder 2 

P1 Requirements 
R1 references to Doc1-1 

R2 references to Doc1-2 

Calculation of % between folders : 
 

Sum of referenced requirements 
N1 + N2 + N3 

 

 

 

 

In the case of coverage links between a high level document and a lower level folder, the 

high level document behaves like if it has combined coverage links with the documents in 

the lower level folder. When a high level document, or an element (section, requirement, 

etc.) of the high level document is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays the combined coverage ratio between the high level 

document selected and the combination of all documents in the lower level 

folder. 

 Rhapsody Gateway displays the coverage ratio between elements of the high 

level document and the lower level document in the standard way. 

In the case of coverage links between a high level document and a lower level folder, 

when a lower level document, or an element (section, requirement, etc.) of the lower level 

document is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays the coverage ratio between elements of the lower 

level document and the high level document in the standard way. 
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The information displayed is equivalent to the information displayed in the configuration 

shown at right. 

In addition, you can expand / collapse the folder and Rhapsody Gateway displays the 

coverage ratio between folders. 

Coverage Links between Lower Level Documents and a High Level 
Folder 

Direct links between documents contained in a folder can be created using folder ports 

(see the section concerning project configuration to learn more). In this case configuration 

looks like: 

 

 

 

Doc1-1 : N1 Requirements 

Doc1-2 : N2 Requirements 

Doc1-3 : N3 Requirements 

P2 Requirements 
R3 references to Doc1-1 

R4 references to Doc1-3 

Folder 1 

Folder 2 

P1 Requirements 
R1 references to Doc1-1 

R2 references to Doc1-2 

Calculation of % between folders : 
 

Sum of referenced requirements 
N1 + N2 + N3 

 

 

 

 

In the case of coverage links between a low level document and a high level folder, the 

low level document is considered as covering all the documents contained in the high 

level folder. When a high level document, or an element (section, requirement, etc.) of the 

high level document is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays the coverage information between elements of the 

lower level document and the high level documents in the standard way. 

In the case of coverage links between a low level document and a high level folder, when 

a low level document, or an element (section, requirement, etc.) of the low level document 

is selected: 

 Rhapsody Gateway displays the folder and the coverage ratio between folders. 

 Rhapsody Gateway displays the coverage information between elements of the 

lower level document and the high level documents in the standard way. 
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The information displayed is equivalent to the information displayed in the configuration 

at the right. 

In addition, you can expand / collapse the folder and Rhapsody Gateway displays the 

coverage ratio between folders. 

Using Macro-requirement 
A macro-requirement supports the concept of hierarchy between requirements. A macro-

requirement contains requirements and passes on its properties to them. A macro-

requirement goes along with section break. 

Propagation of Elements Attached to the Macro-requirement 

Elements attached to a macro-requirement (attribute, text, or link other than a coverage 

link) are also attached to requirements and derived requirements contained in the macro-

requirement. 



Managing the Analysis Results 

 

 

IBM
®
 Rational

®
 Rhapsody

®
 Gateway Add On 

102 

 

RR  

DDRR  

MMRR  

A Text… 

Text… 

RR  Text… 

A Text… 

RR  

DDRR  

MMRR  

A Text… 

Text… 

RR  Text… 

A Text… 

A Text… 

A Text… 

A Text… 

Text… 

Text… 

Text… 

MMRR  

RR  

DDRR  

A Text… 

Text… 

Macro-Requirement 

Requirement 

Derived Requirement 

Attribute with its text 

Text 

propagation 

 
 

Coverage of Requirements Contained in a Macro-requirement 

If requirements contained in a macro-requirement are referenced individually, the macro-

requirement is considered as covered. The coverage ratio is equal to the number of 

referenced requirements contained in the macro requirements over the number of 

requirements contained in the macro requirement. 
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RR  

DDRR  

DDRR  

MMRR  

A Text… 

Text… 

RR  Text… 

A Text… 

RR  

RR  

RR  

Downstream 
document 

A Text… 

A Text… 

A Text… 

A Text… 

Text… 

Text… 

Text… 

Text… 

Coverage = ¾ = 75% 

A Text… Attribute with its text 

Text… Text 

MMRR  Macro-Requirement 

RR  Requirement 

DDRR  Derived Requirement Coverage 

 
 

 

If the macro-requirement is referenced directly by a low level element, it is considered to 

be 100% covered, and all requirements and derived requirements are considered to be 

covered by the covering element. 

The macro-requirement is considered uncovered if it is not 100% covered. 

If the macro-requirement references a higher level requirement, all the requirements 

contained in the macro-requirements are also considered as covering the higher level 

requirement. 

A macro-requirement existing in an intermediate document without referencing any high 

level requirement remains a macro-requirement. 
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DDRR  
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RR  

RR  

Downstream 
document 

A Text… 

A Text… 

A Text… 

A Text… 

Text… 

Text… 

Text… 

Text… 

Coverage = 100% 

RR  Requirement 

MMRR  Macro-Requirement A Text… Attribute with its text 

Text… Text 

DDRR  Derived Requirement Coverage 

 
 

 

If a macro-requirement references a higher level requirement, all the requirements 

contained in the macro-requirement are considered as covering the higher level 

requirement as well. 
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RR  

MMRR  

A Text… 
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A Text… 

A Text… 
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A Text… 

Text… 
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Text… 

Coverage = 100% 

RR  

RR  

RR  

Upstream 
document 
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DDRRRR  

RR  Requirement 
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Text… Text 

DDRR  Derived Requirement Coverage 

 
 

 

Note 

The macro-requirements support a real concept of hierarchy, as explained in this 

section. It is also possible to display the requirements with an indentation, or in 

other words, without a concept of hierarchy but with an indented tree. This is 

possible thanks to an advanced customization of the requirement element in the 

type. 

Using Requirements Hierarchy 
A requirements hierarchy  is corresponding to nested requirements. This is authoring-tool 

oriented. It is able to perform this function because of the hierarchical definitions of 

requirements by regular expressions in a redefined type. 

Unlike the macro-hierarchy concept, the requirements hierarchy simply manages a nested 

display of requirements which must follow each other. No rules are propagated to the 

contained requirements and a requirements hierarchy does not pass on its properties to its 

contained requirements. Moreover it does not go along with section break or section 

changes. 
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Derived Requirement 
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The requirements hierarchy allows you to capture information for requirements organized 

like the following: 
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Creating Information 

During the project life cycle, you will have to establish your requirement traceability 

either in the project files or by adding information from Rhapsody Gateway, or possibly 

both. 

In addition to the traceability information inserted in the source documents, models, code 

files, etc. you can use Rhapsody Gateway to create: 

 References (coverage links) 

 Links (non-coverage links) 

 Attributes 

 Reference attributes 

 Texts 

 

This section gives you information about the helpful features you can use to quickly create 

your traceability information and about how you can create additional traceability 

information using Rhapsody Gateway. 

You can read about these topics in: 

 Adding Traceability Information in your Project Documents 

 Adding Information from Rhapsody Gateway—Basic Capabilities 

 Adding information from Rhapsody Gateway—Advanced Capabilities 

 Using Marks 

Adding Traceability Information in your Project 
Documents 

When you create a project, Rhapsody Gateway knows the documents to be analyzed and 

the applied analysis types. Thus Rhapsody Gateway knows when a given document is 

covered by other documents, and knows the definitions of the expected "References" 

(thanks to the type of analysis applied to the covering documents). 

For some of the interfaced tools, you can use Rhapsody Gateway to make requirements 

available directly in the third party tool environment. Afterwards you will use the linkage 

capabilities provided by this tool to create the traceability information. 
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However for text-oriented documents such as Word files, FrameMaker files and code 

files, you need to add coverage information as text strings. You can effectively use 

Rhapsody Gateway project workspace to create coverage links in a source file or a text 

file. These actions are explained in this section. 

Features for Inserting Coverage Information in Project Files 

In the project, right click a high level requirement in the Selection column. As shown in 

the following figure, the context menu contains a Copy item and a Copy For submenu.  

The Copy item allows you to copy the requirement name in order to paste it in the source 

or text files.  

The Copy For submenu contains the reference types defined in the type of analysis for the 

document covering the requirement you selected in the Selection column. 

 
 

To use this feature, carry out as follows: 

1. Select a requirement to reference then select the Coverage Link type you want to 

create from the Copy For submenu. 

2. Use Navigate to open the covering (downstream) document. 

3. Paste the copied information in the covering document, either in the section or 

below the low-level requirement that is covering the selected requirement. 

4. In the same time, Rhapsody Gateway inserts the requirement identifier, it also 

inserts a string compliant with the syntax you defined for the kind of coverage 

link. 
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The coverage information is inserted in the document as shown in the following 

figure: 

 
 

See the Customization Guide to learn more about the customization of this feature. 

Adding Information from Rhapsody Gateway—Basic 
Capabilities 

You can add information from Rhapsody Gateway without modifying the source 

documents of the project: 

 Coverage links (references) 

 Links (only if you defined Types for Added Elements—See the Advanced 

Capabilities section) 

 Attributes 

 Reference Attributes 

 Text 

Adding Covering Links 

You can use the Graphical View to create coverage links. These coverage links are 

displayed in green in the Graphical View with a reference attribute Internal Creation  

To create a covering link, follow these steps: 

1. Make a multiple selection of the requirements you want to link. You can use the 

[Ctrl] key to create a multiple selection / de-selection. 

2. Right click and select Create Covering Links > Coverage (the name 

―InternalType Coverage‖ may depend on your project configuration). 
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New links are displayed in green. 

To delete a covering link first select it, then right click and select Remove in the context 

menu. You can delete the link only if it has been created from Rhapsody Gateway. 

Adding Attributes 

Use Rhapsody Gateway to add attributes to captured requirements. 

To create an attribute, follow these steps: 

1. Select a requirement in the Selection column in the project workspace of the 

Management view, the Coverage Analysis view or the Impact Analysis view. In 

the Graphical view, select a requirement and use the Attributes pane in the lower 

half of the view. 

2. Right click and select Add an Attribute in the contextual menu, then Define a 

Boolean Attribute or Define a Value Attribute in the contextual submenu, as 

shown in the following figure. 
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Note 

If you have already created attributes, they will be directly available in the 

context submenu underneath the Define items. 

3. The dialog box shown in the following figure opens: 

 
 

Enter the attribute name and click OK to validate. 

4. If you selected Define a Value attribute, the additional dialog box shown in the 

following figure opens: 

 
 

Enter the attribute value and click OK to validate. 



Creating Information 

 

 

IBM
®
 Rational

®
 Rhapsody

®
 Gateway Add On 

112 

The attribute is displayed underneath the requirement, as shown in the following figure, 

and in the Attributes panes when the requirement is selected. 

 
 

Modification of the Added Attributes 

Use the Requirement Details view to modify the created attributes. They are displayed in 

columns in the same way as attributes captured in the project documents, as shown in the 

following figure.  

However, these columns can be edited, as follows: 

 
 

1. Double click in the table cell to edit the value of an attribute. 

2. Select a cell containing an attribute value, right click and select Copy from the 

context menu.  

3. Select cells in which you want to insert the value (you can use the [Ctrl] key to 

make multiple selections). Right click and select Paste in the context menu. 

 

To rename the attribute, follow these steps: 

1. Right click the header of the attribute column in the Requirement Details view. 

As shown in the following figure, then select Rename in the context menu. 
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2. The dialog box shown in the following figure opens. Rename the attribute and 

click OK to confirm. 

 
 

Deleting Added Attributes 

To remove an attribute from a given requirement, follow these steps: 

1. Select the attribute in the Selection column in the project workspace of the 

Coverage Analysis view or the Impact Analysis view. In the Graphical view, 

select a requirement and use the Attributes pane in the lower half of the view. 

2. Right click and select Remove in the context menu. 

 

To remove a category of attributes, follow these steps: 

1. Use the Requirement Details view. 

2. Right click the header of the attribute column and select Delete in the context 

menu, as shown in the following figure. 

 
 

Adding Reference Attributes 

Use Rhapsody Gateway to add reference attributes to captured references (coverage links). 

To create a Reference Attribute from the Coverage Analysis View or Impact Analysis 

View, follow these steps: 

1. Select a requirement in the Selection column. 

2. Select a covering element in the Downstream column or a covered element in the 

Upstream column. 
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3. Right click the element selected in the Downstream or Upstream column then 

select Add a reference attribute in the context menu or in the specific down 

area. Next select Define a Boolean Reference Attribute… or Define a Value 

Reference Attribute… in the context submenu, as shown in the following 

figure. 

 
 

Note 

If you have already created reference attributes, they will be directly 

available in the context submenu underneath the Define items. 

4. The dialog box shown in the following figure opens: 

 
 

Enter the reference attribute name and click OK to validate. 

5. If you selected Define a Value Reference Attribute…, the additional dialog box 

shown in the following figure opens: 

 
 

Enter the reference attribute value and click OK to validate. 
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The reference attribute is displayed either underneath the covered requirement in the 

Upstream Coverage Information column, or underneath the covering requirement in the 

Downstream Coverage Information column, as shown in the following figure. In both 

circumstances it will also be shown in the Reference Attributes panes in the lower half of 

each view. 

 
 

Deleting Added Reference Attributes 

To remove a reference attribute, follow these steps: 

1. Select the reference attribute from either the Upstream Coverage Information 

column, or in the Downstream Coverage Information column, or in the 

Reference Attributes panes in the lower half of each view. 

2. Right click and select Remove selected attributes in the context menu. 

Adding Text 

You can add some text to sections and requirements captured by Rhapsody Gateway. 

To add text, follow these steps: 

1. Select a section or a requirement in the Selection column of the Coverage 

Analysis view or the Impact Analysis view. 

2. Right click and select Add Text in the context menu. 
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The dialog box shown in the following figure opens: 

 
 

3. Enter the text you want to add and click OK to validate. The added text is 

displayed in the Text pane of each view when the element is selected. 

 

When a section or a requirement has already some text added, the context menu item is 

Edit Added Text and not Add Text. Select Edit Added Text to edit the text. The dialog 

box shown in the following section opens and already contains the added text. After 

completing these steps you will be able to edit the text. 

Consistency Checking for Added Information 

When you re-analyze a project, Rhapsody Gateway checks to make sure that the 

information created can be related to elements captured in the project documents.  

 

For example, if a text has been added to a requirement but the requirement has been 

deleted from the original document, Rhapsody Gateway opens a dialog box listing the 

information added from Rhapsody Gateway but no longer captured in the project 

documents. 
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The rule Element modified but not found in original document is also activated in the 

Rule Check section. 

If you confirm that the element is removed, and once you have managed the impact of this 

removal on your added information, you can remove the added information. From the 

Rule Check section, double click the element listed as no longer existing, and Rhapsody 

Gateway navigates to the element in the project workspace. Right click and select 

Remove from the context menu. 

Adding Information from Rhapsody Gateway—
Advanced Capabilities 

Basic capabilities allow you to create information, but there are a few limitations: 

 You are supposed to create all the categories of attributes before adding the 

attributes themselves. 

 You can create only one type of coverage link, and only coverage links. 

 You cannot create links. 

All these limits are removed if you use a customized ―Type for added elements‖. A Type 

for added element allows you to define any kind of link, coverage link, attributes, etc. 

Once a ―Type for added elements‖ has been defined to manage additional information, it 

can be re-used for all projects (such as for the other types files). When this type has been 

added in the project document as a Modification Document, you can add information as 

described in the Basic Capabilities. 

 

The Customization Guide gives you all the details concerning creation and customization 

of Types for added elements. However the concepts concerning added elements use for 

projects are considered in this User Manual. 

You can use the Added-Information-Advanced demo example installed with 

Rhapsody Gateway to train yourself on these concepts. 

Including Types for Added Elements in your Project Configuration 

In the project configuration, add Modification Documents to project documents you want 

to modify. See the section about Modification documents to learn more about how to 

insert these documents. 
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As shown below, select the type for the added document from the Type of Analysis. You 

do not need to edit the other fields. 

 
 

Adding Covering Links 

You can use the Link Details View to create coverage links. These coverage links are 

displayed by a check mark in the Link Details view. 

To create a coverage link with a specific reference, follow these steps: 

1. Select an element in the left area. 

2. Select a link type (reference). 

3. Click in the check box near the requirement to cover. 

 
 

A check is added next to the covered requirement. A message is added in the 

Information area. 
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Note 

It is possible to create a coverage link even if a coverage link already exists between 

these requirements with another link type (green square). 

 

You can use the Graphical View to create coverage links. These coverage links are 

displayed in green in the Graphical View. 

To create a covering link, follow these steps: 

1. Make a multiple selection of the requirements you want to link. You can use the 

[Ctrl] key to create a multiple selection / de-selection. 

2. Right click, select Create Covering Links then select a covering link. 

 
 

Adding Links 

You can use the Graphical View to create links. These links are displayed with a green 

dotted arrow in the Graphical View. 

To create a link, follow these steps: 

1. Make a multiple selection of the requirements you want to link. You can use the 

[Ctrl] key to create a multiple selection / de-selection. 

2. Right click, select Create Links then one of the links coming from the 

modification file. 
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Deleting Links 

When a link or covered link is created from Rhapsody Gateway and if this link destination 

disappears, the link becomes invisible, follow this method to delete the link: 

1. Select the link/cover link origin from a Rhapsody Gateway view. 

2. An additional item Delete link on undefined requirement has been added in the 

Edit menu. Click this option to delete the corresponding link. 

 

From the Link Details view, the behavior varies a little. 

If you select the origin of the link, an Undefined Requirements section appears in the 

covered documents tree. In this section are listed the requirements which become 

undefined. Uncheck the requirements to delete the links. 
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Assigning Attributes 

You can use the Requirement Details view to create attributes. Attributes defined in the 

Type for added elements become new columns in the Requirements Details view. 

  
 

Consult the Adding Attributes section in the Basic Capabilities section to learn more about 

this feature. 

Assigning reference attribute 

To assign values to reference attributes from the Link Details view, follow these steps: 

1. Create a covering link or select a covering link with a check mark. 

2. The Reference Attributes area becomes enabled. 
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3. Several kinds of reference attributes can be represented in the Reference 

Attributes area. Depending on the attribute creation in the added type for 

modification, the displaying in the Reference Attributes area changes. 

 If the reference attribute has been defined as a Boolean attribute in the type 

for added element, then the field is displayed as a check box. Check or 

uncheck this check-box to choose the value: 

 
 

 If the reference attribute has been defined without specific values in the type 

for added element, then type a value in the field: 

 
 

 If the reference attribute has been defined with specific values in the type for 

added element, then select an available value in the combo-box which 

shows the choice: 

 
 

 If the reference attribute has been defined with specific values in the type for 

added element and is defined as multi-valued then check the required values 

in the combo-box which shows the choice: 

 
 

The field contains the set of selected values. 
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To assign values to reference attributes from the Graphical View, follow these steps: 

1. Create a covering link or select a covering link in green. 

2. Right click in the Reference Attributes area. Select Add a reference attribute 

submenu, available reference attributes are listed  

3. Select a reference attribute. A dialog box opens to enter the reference attribute 

value. 

Adding Marks 
Use Marks to manage requirements changes and impact analysis, or to quickly analyze 

input documents: 

 Once results analysis are highlighted by orange icons to show the modifications 

detected by Rhapsody Gateway. Rhapsody Gateway can automatically assign a 

―Modification‖ mark to the elements having an orange icon (not to the parents of 

the orange icons, only the elements themselves). Marks are persistent you will 

have to remove them individually or globally according to your change analysis 

process. 

 When you select a modified requirement in the Selection column, you see the 

covered or covering elements in the Coverage Analysis or Impact Analysis 

columns. Marks can be used in these columns as well, to indicate that an element 

is impacted by the initial change and need to be specifically tracked. 

 Marks help you to quickly find elements, through dedicated capabilities of the 

Search feature. For example, you can immediately find elements concerned by 

―Safety‖. 

Automatic and Persistent Highlight of Modifications 

When Rhapsody Gateway re-analyzes the project documents, it automatically detects and 

highlights changes by displaying orange icons on modified elements, as shown in the 

following figure. 

 
 

See the section about Detection of Requirement Changes to learn more. 
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Orange icons display the differences between the previous analysis and the current one, so 

they can disappear if project documents are re-analyzed without being modified. 

You can automatically apply Marks to modified elements. They will be more persistent, 

so you will be able to perform your impact analysis and remove marks when 

corresponding activities are completed. 

 

Select Marks > Modifications in the Edit menu or from the contextual menu or the 

project workspace. 

Marks (orange circles) are automatically added to all modified elements, and are 

displayed even if the project document is re-analyzed, as shown in the following figure. 

 
 

 

To navigate from one mark to the next one, select Marks > Next from the context menu 

or from the Edit menu. The [F2] key is a helpful shortcut. 

To navigate from one mark to the previous one, select Marks > Previous from the 

context menu or from the Edit menu. The [Shift + F2] key is a helpful shortcut. 

 
 

 

Once you reviewed the impact of modifications, you can remove the marks: 

 Individually—select the marked element and select Marks > Remove marks 

from the Edit menu or from the context menu to remove all the marks of the 

element. 

 Globally—all the marks of a given category will be removed if you select Marks 

> Remove all marks from the Edit menu or from the context menu. 

 Recursively—to remove a mark and all its children in one click, select Marks > 

Remove marks recursively from the context menu or from the Edit menu or 

from the context menu.  
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Automatic Highlight of Search Results 

Marks can be used to highlight the results of a search action. In order to the Find dialog 

box contains a button Mark all, as shown in the following figure. 

 
 

If you click Mark all, all the elements found will be automatically highlighted with 

Marks. If you hover over an element, information is displayed to indicate which 

information is found for this element, as shown in the following figure. 

 
 

 

The Find dialog box contains a Marked by field, allowing you to quickly search for the 

elements previously marked. 

 
 

You can navigate to the next or to the previous mark by clicking on the Next or the 

Previous button. 
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Creating your own marks 

Rhapsody Gateway enables you to create your own marks. To create a mark follow these 

steps: 

1. Select Marks > Edit from the Edit menu or from the context menu. 

The dialog box shown in the following figure opens: 

 
 

2. Click  to create a new mark. 

3. Use the Display name tab to name your mark or define a text. Note that this text 

will be displayed in the project workspace if you hover over the mark icon. 

4. Click  to change the color of the mark. 

5. Click  to delete an existing mark. 

6. Click OK to validate your mark definition. 

Use this principle to create few marks. 
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Using Your Own Marks 

Once created, a mark is available in the bottom of the Marks menu, as shown in the 

following figure. 

 
 

Note 

Only ten created marks are accessible from this menu. 

 

Now, you can apply or remove the marks: 

 Individually: select an element in the Selection column and select Marks > 

<your mark> from the Edit menu or from the context menu. 

 Collectively: select several elements in the Selection column, using the [Ctrl] key 

to make a multiple selection, and select Marks > <your mark> from the Edit 

menu or from the context menu. 

 

You can apply few marks on an element, only four marks will be visible. 

The navigation works like for other default marks. 

Shortcuts to Add Marks 

A mark can be put on a requirement using a keyword shortcut. Shortcuts are CTRL+n 

where n is the number ot the mark. Nine marks shortcuts are available using the numeral 

keys of the keyboard. 
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Visualizing Marks on Deleted Elements 

When marked elements are deleted, it is always possible to visualize elements which were 

marked. 

 
 

This information is displayed in the Deleted marks tab when a mark type is selected. 

Click Delete in the contextual menu if you want to erase the mark set on a deleted 

element. 

Using Marks in Filters 

It is possible to filter elements on a condition even if they are marked or not. When you 

create your condition, select an element type and in the second field of the condition, 

select Is Marked By or Is Not Marked By. 

Read the Filters section to learn more about the creation of filters. 

Suspicious Links Management 
A suspicious link is a link that must be verified. A link becomes suspicious when a 

covered requirement or a covering element has changed. A change is for instance a text 

modification. 

To use the suspicious link management, the Activate suspicious link management option 

needs to be checked in the Project pane of Options. 

If the User Management plugin is installed, users can manage rights concerning 

suspicious links on their projects. 

 

When modifications have been done on the Rhapsody Gateway project, whereas the 

suspicious link management is activated, Rhapsody Gateway indicated suspicious links. 

To mark a link as suspicious, Rhapsody Gateway will add a red mark on it. This mark is 

visible in the Graphical View and in the Link Details view. Suspicious marking is 
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possible even if no type for added elements have been associated to types. See Link 

Details chapter to have details on this view. 

In the following case, the text of ―PS_USB_REQ2‖ requirement has changed and it 

became ―New Text of PS_USB_REQ2‖. Rhapsody Gateway shows the modification with 

a red icon in the Graphical View and marks the covering link as suspicious, when the 

project is reloaded. 

 
 

In the Link Details view, covering links with the selected link type and marked as 

suspicious are underlined in red. 

 
 

Covering links with another link type and marked as suspicious are underlined in orange. 
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Unmark a suspicious link 

Once the requirement modification has been validated, the suspicious mark can be 

removed. To remove a mark, right click a link in the Graphical View then select Unmark 

suspicious link in the contextual menu. 

 
 

The corresponding same item is available in the Link Details contextual menu, when 

clicking a suspicious link in the view. 
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Mark a link as suspicious 

Links can manually be marked as suspicious. To mark a link as suspicious, select a link, 

right click and select the Mark as suspicious link item in the contextual menu. This menu 

item is only available on non-suspicious links. 

 
 

The corresponding same item is available in the Link Details contextual menu, when 

clicking a link in the view. 
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Detection of 
Requirement Changes 

Rhapsody Gateway offers features to detect and manage requirement changes and impact 

analysis: 

 An automatic system of ―orange icons‖ displays the changes between two 

consecutive analyses. 

 The marks are used to highlight the modified requirements in order to manage 

individual impact analysis. 

 The snapshots are used to archive project analysis results from time to time and 

to compare the results between saved archives, or the current results with one of 

the saved archives. 

You can read about these topics in: 

 Automatic Detection of Modified Elements 

 Managing Changes using Marks 

 Using Snapshots 

Automatic Detection Modified Elements 
Every time the project is analyzed, Rhapsody Gateway automatically displays the 

differences from results of the previous analysis. 

The detected changes are displayed in the project workspace using orange icons. The 

following figure shows that a modification has been detected for PS_USB_REQ1. The 

orange icons are propagated throughout the document level, so you can get the 

information concerning modifications even if document tree is collapsed. 
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The orange icon displayed depends on the modification: 

Flag Meaning 

 New element 

 Modified element 

 Moved element: the element is not modified but located underneath a different parent 

element. 

Note 

As orange icons automatically display the differences between two consecutive 

analyses, they will disappear after the next analysis if no other changes have been 

detected. If you want a more persistent display of modifications, use the Snapshots 

and/or the Marks. 

Managing Changes using Marks 
Marks can be used to manage requirements changes and impact analysis. 

 Once analysis results are highlighted by orange icons to show the modifications 

detected by Rhapsody Gateway, select Edit > Marks > Modifications. 

Rhapsody Gateway automatically adds a ―Modification‖ mark to the elements 

that have an orange icon (not to their parents as it does for the orange icons, but 

only to the elements themselves). Marks are persistent; you will have to remove 

them individually or globally according to your change analysis process. 

 When you select a modified requirement in the Selection column, you will see 

the covered or covering elements in the Coverage Analysis or Impact Analysis 

columns. Marks can be used in these columns as well, to indicate that an element 

is impacted by the initial change and needs to be specifically tracked. 

Read the Using Marks chapter to learn more about use of Marks. 
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Using Snapshots 
The Snapshots are used to archive the project analysis results from time to time during 

your project lifecycle. Using snapshots process you can compare the current analysis 

results with any of the saved snapshots, or compare one snapshot with another snapshot. 

To open the snapshot editor window, click  in the toolbar or select File > Edit 

Snapshots. 

 
 

The snapshot editor dialog box contains two panes: 

 The Snapshots pane displays the list of previously saved snapshots. 

 The Differences pane can display either the list of differences between the 

current analysis results and the analysis results saved in the snapshot selected in 

the Snapshots list or the list of differences between two snapshots selected in the 

Snapshots list. 

The snapshot editor dialog box also displays the name of the filter applied. 

 

The snapshot editor dialog box contains five menus: 

 File 

 Display 
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 Reports 

 Tool 

 Help 

 

The File menu contains the following items: 

Item Description 

New Snapshot for Current 

Project… 

Saves the current analysis results as a snapshot 

Properties Displays the Information dialog box for the selected 

snapshot 

Delete Deletes the selected snapshot 

Close Quits the snapshot editor dialog box. 

 

The Display menu contains the following items: 

Item Description 

View element history When you select an element from the list of differences, the 

display changes to show you the list of modifications of the 

selected element throughout its history. 

View snapshots Displays the list of snapshots (default display mode of the 

snapshot editor dialog box). 

Selected snapshot view Opens an additional window, equivalent to the main window 

but in read-only mode, displaying the analysis results for the 

selected snapshot. 

Navigate Navigates to the selected element in the file containing it. 

 

The Reports menu offers the following functions: 

Item Description 

Snapshots Comparison Report containing the list of differences between the current 

analysis results and the selected snapshot, or between two 

selected snapshots. 
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Item Description 

Snapshots Impact Analysis Report containing the impact analysis between the current 

analysis results and the selected snapshot, or between two 

selected snapshots. 

 

The Tool menu offers the following functions: 

Item Description 

Evaluate Opens the OTScript Evaluator. 

 

The Help menu offers the following functions: 

Item Description 

Help topics Opens the User Manual and Customization Guide of the 

online help files. 

Creating a Snapshot 

To create a snapshot, follow these steps: 

1. Select File > New Snapshot for Current Project… 

The Snapshot information dialog box opens: 

 
 

2. Enter a Name and a Description for your snapshot. Click OK to validate. 

The created snapshot is now displayed in the Snapshots pane. 



Detection of Requirement Changes 

 

 

IBM
®
 Rational

®
 Rhapsody

®
 Gateway Add On 

138 

Using Snapshots to Compare Results 

If you have at least one snapshot saved for your project, Rhapsody Gateway allows you to 

compare the saved results with other analysis results: either the current results or the one 

saved in another snapshot. 

 If you want to compare the current analysis results with a previously saved 

snapshot, just select a saved snapshot from the Snapshots pane. The Differences 

pane displays the list of differences between the results of the saved snapshots 

and the results for the current analysis of your project document. 

 If you want to compare two snapshots, select them in the Snapshots pane using 

the [Ctrl] key to make a multiple selection. The Differences pane displays the list 

of differences. 

 

You can expand the tree to see what the differences are. The following figure shows a 

modification of the text of the PS_USB_REQ1 requirement. 

The trees in the Differences pane are arranged by categories of modifications, inserted 

underneath the name of the document. 
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Element History 

The snapshot editor proposes a display mode that shows the history of a selected element 

across the saved snapshots. 

Select an element in the Differences list and select Display > View element history or 

View element history in the context menu. 

 
 

The snapshot editor dialog box changes and you see only one pane for the selected 

element, showing the modification that has occurred for each snapshot. 

 
 

To return to the default display mode, select Display > View snapshots or View 

snapshots in the context menu. 

Opening a Snapshot 

You can use Rhapsody Gateway to view the analysis results previously saved as a 

snapshot. 

Double click on a snapshot in the Snapshots list of the Snapshot editor dialog box or 

select a snapshot by selecting Display > Selected snapshot view or Selected snapshot 

view in the context menu. 

A new window opens in which you can navigate the same way as in the Rhapsody 

Gateway main window. Even if this snapshot window is read-only, you can apply filters 

or open the configuration dialog box to see what was the project configuration was when 

the snapshot had been saved. 

Snapshots Troubleshooting 

When the user saves a project from Rhapsody Gateway project with File mode to 

Rhapsody Gateway project with database mode, if snapshots were made in file mode, 

they are also integrated in the database. 
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To avoid conflicts, the snapshots directory is renamed snapshots_old. The snapshots 

files are not requested anymore. 
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Rules Check and Error 
Messages 

The results of checks are grouped together in the Rule check section, at the top of the 

Selection column in the project workspace. 

Rules can be customized by trained users and/or by our experts to provide additional value 

in support of your requirements management process. 

 

Take time to review all rule violations before analyzing the project analysis results. A 

double click on an element in this section navigates directly to this element in its 

document tree. 

In the project workspace, elements violating a defined rule are displayed in red or orange, 

depending on the gravity level. More information is displayed in the Messages pane when 

you select an element violating a rule. 

 

The following chapter describes the errors and warning messages of rules check and some 

recommended corrective actions if a corrective action be identified and suggested. 

One corrective action is to uncheck the rule in trouble in the Rules part of the Project 

General option. 

Critical Error Messages 
Critical errors are not located in the Rule check section. These kinds of errors appear in a 

dialog box which prevents the opening of the corresponding project. 

The following table shows the identified critical errors messages: 

Error Messages Explanation Corrective Action 

Non-existent section or 

key 

A Rhapsody Gateway file such as .type 

file, .ini file or .rqtf file is corrupted 

or is defined with an inconsistent definition 

of a section or a key. 

Users must avoid manual 

modification of 

Rhapsody Gateway files. 

Correct manual 

modifications if this is 

the cause of the problem. 
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Error Messages 
Several error cases have been identified. For most cases corrective actions are proposed. 

Unfortunately, it is impossible to imagine the solutions to all the problems that may 

appear. 

 

Try to solve the errors with the following helpful information. The impact analysis must 

be redone after a corrective action. 

 

The following table shows the identified errors messages: 

Error Messages Explanation Corrective Action 

Analysis error An error has been identified in the 

intermediate file. 

For example, this could happen when: 

 the XML file has invalid format 

 problems occur during conversion 

 there is a file access error to an 

intermediate file 

Try to re-launch the 

loading and the conversion. 

Bad requirement level Bad nesting of requirements according to 

the defined type. 

Change the document 

structure. 

Closing expression 

found without opening 

expression 

The analyzed information contains a 

closing expression without the expected 

opening expression. This error can only 

affect requirements, macro-requirements 

or sections expressions. 

For example, this could happen when: 

 the source file structure or the 

intermediate file contains some 

inconstancies, such as the lack of 

closing expression 

 the analysis type contains an 

incomplete definition of 

parents/children combination for 

sections 

 Modify the document 

to insert the missing 

opening expression. 

 Modify the document 

to delete the additional 

closing expression. 
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Error Messages Explanation Corrective Action 

COM error The COM dialog with an interfaced tool 

fails. 

For example, causes could be: 

 the declaration of an obsolete COM 

library 

 another application is using the same 

COM interface at the same time 

 the tool is not installed or is not 

correctly installed 

 Reinstall the tool. 

 Treat the COM error. 

If this error is persistent, 

contact your IT 

administrator or the 

Support Team. 

Conversion problem The document cannot be analyzed by 

Rhapsody Gateway.  

For example, this could happen when the 

document to be analyzed has: 

 an unknown format 

 an obsolete format such as a Word 

95 file 

No corrective action can be 

proposed. 

Converter not found The project configuration has been 

defined with a type of analysis based on a 

converter not available in the current 

project configuration.  

For example, this could happen when a 

specific converter has been developed for 

a user and the user has upgraded his 

Rhapsody Gateway version. 

A converter is used to analyze the input 

information and to produce an 

intermediate file. See the section about 

Rhapsody Gateway architecture to learn 

more. 

 Add the converter 

from the old version 

into the new one. 

 Rewrite the converter. 

 Load a new converter. 

Cover link source not 

found 

The capture information defined as a 

coverage link source in the analyzed 

document has not been found. 

See Defining References section in the 

Customization Guide to learn more. 

This error may appear when the user 

defines two parentheses groups in his 

reference regular expression. The first 

parentheses group is for the target and 

the second one is assigned to the source 

by default and this source cannot be 

found. 

 Verify the source 

 Verify the regular 

expression definition 
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Error Messages Explanation Corrective Action 

Covered document not 

found 

The .rqtf file corresponding to the 

project configuration has been corrupted. 

In this file a covered document is 

declared but the document itself is not 

defined in the configuration.  

Users must avoid manual 

modification of Rhapsody 

Gateway files. 

In this case the user can 

resave the project from the 

project editor. 

Covering document not 

found 

The .rqtf file corresponding to the 

project configuration has been corrupted. 

In this file a covering document is 

declared but the document itself is not 

defined in the configuration. 

Users must avoid manual 

modification of Rhapsody 

Gateway files. 

In this case the user can 

resave the project from the 

project editor. 

Cyclic graph creation 

not allowed 

This error happens when we define a P 

parent of an E element and if this P 

parent is already a child of E. 

Change the parent/child 

relationship. 

Document not found The capture information from the 

analyzed document defined as a 

document in a coverage link or a link has 

not been found. 

See Defining References and Defining 

Links sections in the Customization 

Guide to learn more. 

 Verify the document 

 Verify the regular 

expression definition 

Document not readable The document is not available for 

analysis.  

For example, this could happen when:  

 the User does not have the proper 

rights in the case of a remote access 

to the file 

 the file may not exist because it has 

been moved 

 the type of analysis does not match 

the file type 

 Check the access rights 

or ask the 

administrator. 

 Move or create the 

missing file. 

 Correct the type of 

analysis. 

Embedded document 

not found 

This happens if a document included in a 

folder is not found. 

The .rqtf file is corrupted. 

Users must avoid manual 

modification of Rhapsody 

Gateway files. 

 Correct manual 

modifications if this is 

probably the cause of 

the problem. 

 Contact the Support 

Team. 
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Error Messages Explanation Corrective Action 

Entity tag found in 

macro-requirement 

An entity has been found between the 

opening and the closing tags of a macro-

requirement definition. 

For process reasons, entities are not 

allowed in macro-requirements. 

Delete the entity. 

File access error This system error corresponds to a file 

access error. 

Look at the parameter error 

to correct the error. 

Impossible to delete An element to delete has been captured, 

but the element itself does not exist. 

For example, this could happen when the 

analysis type has been defined to delete 

requirements marked as ―obsolete‖.  

See ―expression to delete an element‖ 

advanced options creation. 

Remove the deletion of the 

element expression. 

Invalid parent type Unexpected parent in the hierarchy. Modify the type to 

establish a good 

parent/child relationship. 

Inverse reference 

without requirement 

A reference with an ―is covered by‖ 

element has been found in the document 

outside a requirement definition. See the 

inverse regular expression to know more 

about ―is covered by‖. 

 define a requirement 

 delete the reference 

Link source not found The capture information defined as a link 

source in the analyzed document has not 

been found. 

See the section about Defining Links in 

the Customization Guide and more 

specifically information about Fields. 

 verify the source 

 verify the regular 

expression definition 

Link to undefined 

requirement 

The target requirement of a reference has 

not been found anywhere in the project.  

For example, this could happen when: 

 a defined requirement has 

disappeared 

 a typing error has been made on the 

requirement name 

 the downstream element references a 

requirement filtered by an Analysis 

Filter 

 Define the requirement 

in one downstream 

document. 

 Correct the typing 

error. 

 Cancel the filter effect. 

Macro-requirement 

defined several times 

A macro-requirement is defined several 

times in the same document.  

Rename the macro-

requirement. 
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Error Messages Explanation Corrective Action 

Mirror requirement 

without main 

requirement 

A requirement which is error in the 

downstream document should not be 

present there. 

Remove requirement from 

the downstream document. 

Missing mirror 

requirement 

A requirement which exists in the 

upstream document does not exist in the 

downstream document. 

Add a requirement in 

downstream document. 

Non-covering entity An entity is found without a reference to 

a higher level requirement.  

For example, this could happen when 

there are dead codes within a code. 

Delete the non-covering 

entity. 

Opening expression 

found without closing 

expression 

The analyzed information contains an 

opening expression but the closing 

expression expected to close the previous 

analyzed expression is missing. Only 

requirements, macro-requirements or 

sections expressions can be concerned. 

For example, this could happen when: 

 the source file structure, or the 

intermediate file contains some 

inconstancies, such as the lack of a 

closing expression 

 the analysis type contains an 

incomplete definition of 

parents/children combination for 

sections 

Modify the document to 

insert the missing closing 

expression. 

Parent not found The capture information from the 

analyzed document defined as a parent in 

a section has not been found. 

See the section about Defining Sections 

in the Customization Guide and more 

specifically information about Fields. 

 Verify the parent. 

 Verify the regular 

expression definition. 

Post-processing error Error in the post-processing. This error has a parameter. 

Consult this parameter to 

correct. 
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Error Messages Explanation Corrective Action 

Requirement defined 

several times 

A requirement or a derived requirement 

is defined several times in the same 

document.  

For example, a requirement cannot have 

the same name definition as a derived 

requirement. 

Warning: this rule is ignored if the 

Merge homonymous requirement 
option is checked in the type declaration, 

refer to Customization Guide. 

Rename the requirement. 

Requirement defined in 

several documents, and 

the documents are 

covered by a shared 

document 

Two documents are covered by the same 

document and each of them contains a 

requirement, a derived requirement or a 

macro-requirement whose identifier is 

identical to an identifier contained in the 

other document. 

Define the requirements of 

the documents more 

precisely. 

Section with same 

identifier 

Two sections of the same hierarchical 

level have the same identifier. 

For example, this could happen when 

two titles have the same identifier 

number. 

Correct the sections in the 

document to be analyzed. 

Self covering 

requirement 

A requirement reference references itself. Delete or modify the 

coverage. 

Too many results found. 

A capture expression 

may be wrong 

This message appears when the same 

regular expression captures more than 50 

000 results on one analyzed document. It 

avoids a memory consumption that is too 

large (and sometimes a crash) in the case 

of a bad regular expression. 

For instance, such error can appear when 

10 regular expressions are providing 

more than 5000 results. Simple case with 

requirements captured from table rows: 
(7000 requirement rows) x (1 

requirement identifier + 1 

requirement label + 1 requirement 

text + 7 attribute values) = 70000 

results 

If you do need to capture 

more than 50 000 results 

with the same expression it 

would be necessary to 

increase the 

maxFoundResults limit. 

Edit your .ini file and 

define a variable 
maxFoundResults=<your 

number> in the [General] 

section. Create this section 

if it does not exist.  

Do not hesitate to contact 

the Support Team for 

assistance. 
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Error Messages Explanation Corrective Action 

Traceability Graph 

Violation 

In this case, the coverage is made at a 

level too high. This occurs because an 

element references a requirement of a 

document not declared as covered for the 

document containing the reference.  

Double-click on a Traceability graph 

violation error in the Rule check of 

Rhapsody Gateway to reach the source 

object. 

To visualize the target object of a 

Traceability graph violation error, select 

a source object then open the Message 

pane. 

 If the reference is 

appropriate, create a 

coverage link between 

the two documents to 

allow direct 

traceability. 

 Otherwise delete or 

modify the coverage. 

Unauthorized attribute 

value 

The analyzed document contains an 

attribute of an enumerated attribute with 

a value out of the defined list of values. 

 Add the new value to 

the enumerated 

attribute in the types. 

 Modify the value in 

the document with a 

correct one. 

Uncovered requirement A requirement, a derived requirement or 

a macro-requirement is not referenced in 

any covering document.  

No error is raised for requirements of low 

level documents. 

This rule is not applied in a self-covering 

document case. 

Define the coverage of the 

requirement. 

 

Undefined covering 

requirement/entity 

The covering element does not exist 

anymore or contains a typing error. 

For example, the high level requirement 

"is covered by" a low level requirement 

that is captured but undefined. 

 Rename the covering 

element. 

 Define the covering 

element. 
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Error Messages Explanation Corrective Action 

Unknown document 

type 

The project configuration has been 

defined with a type of analysis not 

available in the project configuration. 

For example, this could happen when: 

 a project defined with a local type by 

a User A, has been opened by a User 

B with a Rhapsody Gateway 

configuration that does not include 

the type defined by User A 

 the types file has been lost or the file 

has been moved 

 a type is not available anymore 

Rhapsody Gateway 

automatically replaces the 

initial Type of Analysis by 

the default LostType one. 

 add the document type 

to the configuration 

 recover the file or 

move the file at the 

dedicated place 

 select a type for the 

document 

It is important not to save 

the project without making 

a correction otherwise the 

right type will be lost in the 

project file. 

Unknown element type This situation happens when a reference 

element type does no longer exist in the 

rqtf file. 

Contact the Support Team 

for assistance. 

Unknown parent 

element 

A regular expression or an XML syntax 

has been defined to define the parent 

element. 

Contact the Support Team 

for assistance. 
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Warning Messages 
Several warning cases have been identified. For most of the cases corrective actions are 

proposed. Even if it is only a warning, it is better to avoid warnings in your analysis 

project. 

Try to solve warnings with the helpful information found below. The impact analysis must 

be redone after a corrective action. 

The following table shows the identified warning messages: 

Warning Messages Explanation Corrective Action 

Attribute defined 

several times 

An attribute has been captured several 

times in the same requirement. 

For example, this could happen when a 

requirement capture has failed in the 

document, because it does not comply with 

the analysis type definition. These 

requirement attributes are captured but are 

linked to the previous requirement. 

Remove the redefined 

attribute. 

Bad section level Bad nesting of sections or bad section type 

definition. 

The captured sections from the analyzed 

document are not following the hierarchy 

defined in the type of analysis. 

For example, a Word ―heading 3‖ section 

underneath a ―heading 1‖ section. 

 

 fix the hierarchy 

issue in your source 

document 

 correct the type of 

analysis 

 activate the option 

―Ignore structure‖ in 

the project 

configuration editor 

for the concerned 

document. See this 

option in the Project 

Configuration / 

Description. 

Element modified but 

not found in original 

document 

An element has been captured from a 

modification document, but the same 

element is not found in the original 

document supposed to be modified. 

Delete the element from 

the modification 

document. 

Element with parent 

not found in the 

original document 

 

An attribute had been added to a 

requirement from Rhapsody Gateway but 

now the requirement has been deleted from 

the original document. 

Remove the attribute 

from Rhapsody Gateway. 

Link defined several 

times 

Two links are defined on the same element. Delete one of the links. 
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Warning Messages Explanation Corrective Action 

Reference attribute 

defined several times 

A reference attribute has been captured 

several times in the same requirement  

For example, this could happen when a 

requirement capture has failed in the 

document, because it does not comply with 

the analysis type definition. These 

requirement reference attributes are 

captured but are linked to the previous 

requirement. 

Remove the redefined 

reference attribute. 

Reference attribute 

without reference 

A reference attribute has been captured but 

could not be attached to a reference. 
 add a reference 

 delete the reference 

attribute 

Requirement defined in 

several documents, and 

the documents are 

covered by different 

documents 

A requirement, a derived requirement or a 

macro-requirement of a document is also 

captured in another document. 

Define more precisely 

the requirements of the 

documents. 

Reuse of deleted 

requirement identifier 

A requirement has been deleted using the 

Expression to delete an element field and 

a requirement with the same identifier is 

recreated. 

Rename the new 

requirement. 

Information Messages 
Few information messages are located in the Rule check section. 

The following table shows the identified warning messages: 

Information Messages Explanation 

Derived requirement Derived requirements are listed in Derived requirement part of the Rule 

check. 
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Generating Reports 

This section gives you information about generated reports. 

Rhapsody Gateway supports several generation formats: 

 RTF for Word 

 MIF for FrameMaker 

 Interleaf 

 HTML 

 Text only 

 Excel 

 

Rhapsody Gateway generates the following default reports: 

 Traceability Matrix—Lists the upstream to downstream covered links and the 

downstream to upstream covering links. 

 Analysis Results—Summarizes the coverage analysis for a project. 

 Project Description—Describes the project and its documents. 

 Upstream Impact Analysis—Lists the upstream traceability information for 

selected elements of the project. 

 Downstream Impact Analysis—Lists the downstream traceability information 

for selected elements of the project. 

 Synthesis of Added Information—Summarizes any added attributes, 

references, text and covering links in the project. 

 Rules Checking—Contains a summary of any rules highlighted by the project. 

Note 

The Support Team and our experts can provide report templates corresponding to 

your specific needs concerning requirement management. Do not hesitate to contact 

us. 
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Generating the Traceability Matrix Report 
Select Reports > Library Reports > Traceability Matrix. 

Rhapsody Gateway opens the dialog box shown in the following figure. 

 
 

Select at least two documents (only the root element of the document tree) and click 

Continue. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 
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Rhapsody Gateway generates a bi-directional traceability matrix, such as the example 

shown in the following figure. 
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Generating the Analysis Results Report 
Select Reports > Library Reports > Analysis Results. 

You do not have to select any element before generation as the report is a summary of the 

project information. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Analysis Results report, such as the example shown in 

the following figure. 
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Generating the Project Description Report 
Select Reports > Library Reports > Project Description. 

You do not have to select any element before generation as the report is a summary of the 

project information. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Project Description, such as the example shown in the 

following figure. 
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Generating the Upstream Impact Analysis Report 
This report lists the upstream traceability information for a low level element selected in 

the project. 

Select Reports > Library Reports > Upstream Impact Analysis. 

Rhapsody Gateway opens the dialog box shown in the following figure. 

 
 

Select one or several low level elements and click Continue. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Upstream Impact Analysis report, such as the example 

shown in the following figure. 
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Generating the Downstream Impact Analysis Report 
This report lists the downstream traceability information for a high level requirement 

selected in the project. 

Select Reports > Library Reports > Downstream Impact Analysis. 

Rhapsody Gateway opens the dialog box shown in the following figure. 

 
 

Select one or several high level requirements and click Continue. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Downstream Impact Analysis report, such as the 

example shown in the following figure. 
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Generating the Synthesis of Added Information 
Report 

Select Reports > Library Reports > Synthesis of Added Information. 

You do not have to select any element before generation as the report is a summary of the 

project information. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Synthesis of Added Information report, such as the 

example shown in the following figure. 
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Generating the Rules Checking Report 
Select Reports > Library Reports > Rules Checking. 

You do not have to select any element before generation as the report is a summary of the 

project information. 

Rhapsody Gateway opens a Save As dialog box. Select a style and a format for report 

generation from the Type drop-down list box, the location of your report file, and name 

the report. 

Rhapsody Gateway generates the Rules Checking report, such as the example shown in 

the following figure. 

 
 

Customizing your Report Style 
You can customize the style of your report for each generation format by editing 

templates. 

Default templates are located in the <installation_dir>\Config\Doc_Templates 

directory. See the section about configuration files to learn more about the management of 

the customized templates. 
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Templates are files that use the format (and the extension) corresponding to the report 

generation format: 

 Templates for RTF (Word) generation shall be named <template-name>.rtf 

 Templates for Excel generation shall be named <template-name>.xls 

 Templates for HTML generation shall be named <template-name>.htm 

 etc. 

 

By defining different templates, you can create different styles for the same content, 

depending on your generation format or final usage of the generated report. 

 

All the templates contain two tags: %endheader and %begintrailer, as shown in 

picture of the customized Downstream Impact Analysis report, at the end of next section. 

The text between those tags will be replaced by the analysis results generated from 

Rhapsody Gateway, but the formatting defined will be used for generation. 

Word document generation 

For example, consider the Downstream impact analysis report generated using the default 

Portrait.rtf template. The result looks like the report shown in the following figure 

(the default style shown in the following figure may change depending on your Rhapsody 

Gateway configuration). 
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You can customize the portrait.rtf file, modify the Word styles (take care to modify the 

Word styles themselves, using Format > Styles…) and create a new template my_style.rtf, 

such as the one shown in the following figure. 

 
 

When you generate reports, Rhapsody Gateway opens a Save As dialog box: the 

my_style template is available in the Type drop-down list box. Select it, select the 

location of your report file, name the report and click OK to generate. 
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You get a report with the same content but with the styles you have defined, as the 

example shown in the following figure for our example. 

 
 

OLE and Rich text object can be generated in a word document. 

Excel generation 

Rhapsody Gateway can generate document content in several spreadsheets. User can add a 

simple ―PAGE BREAK‖ tag in their favorites excel templates in order to generate one 

document section per sheet. As a result you can have automatically one matrix/table per 

sheet for instance instead of a very long single sheet. 

 
 

To specify the spreadsheet name in which the report will be generated, the user has to 

specify the START_REPORT tag in the target cell where the report will be generated. 
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Overview of the 
Product Work Files 

This section gives an overview of the files used by Rhapsody Gateway. 

 

Note 1 

Modification of these files may lead to abnormal behavior, or even data losses. 

Users manually editing the files do so at their own risk. In case of any doubt, 

contact the Support Team BEFORE modifying the files. 

 

Note 2 

Most of the files are defined with the objective to support multi-language capability 

of the product, including Chinese and Japanese. For this reason, files are saved 

using the UTF8 format and not a plain text or ANSI format. 

Saving these files in ANSI or other non UTF8 format may break the product 

opening process. If you decide to directly edit a file, please use a text editor 

supporting the UTF8 format and be sure to save the edited file in the same format as 

the original one. 

 

Rhapsody Gateway takes into account configuration files located: 

 In its installation directory: in this case the default or user-defined configuration 

is available for all projects. 

 In the project directory: in this case the configuration (always user-defined) is 

available only for the project. 

 

You can read about these topics in: 

 Main Configuration Files in the Installation Directory 

 Adding Configuration Files in the Project Directory 

 Project Files 
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Main Configuration Files in the Installation Directory 
Several kind of information are defined in the configuration files, such as types, templates, 

etc. 

Types Definition 

The files defining the default types of analysis are located in the <Installation 

directory>\config\types directory. 

This directory contains subdirectories; each subdirectory is displayed as a folder in the 

Rhapsody Gateway types editor: 

 ―Config‖ directory and subdirectories 

 
 

 Types hierarchy in the Types editor 

 
 

 

Each subdirectory contains some files with the .types extension. 
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These files have the following structure: 

[Types] 

Names=<type1>,<type2> 

 

[type1] 

… (type1 definition) 

 

[type2] 

… (type2 definition) 

 

type1, type2,… are the types displayed underneath the folder in the Types Editor. 

If the .types files are read-only, types cannot be modified from the Types Editor. 

Library types are in read-only mode. 

Note 

To forbid the use of Internal Types, you have to edit the internal.types file 

from the <Installation directory>\config\types\internal directory, 

then to remove the InternalType name from the list of type names, such as 

follows: 

[Types] 

Names=InternalType,_ProjectReference,LostType 

If existing projects were using InternalType, these types are changed to 

LostType. 

Report Templates 

Templates for reports generation (structure and contents) are located in the 

<installation_dir>\Config\Doc_models directory. 

The files located in this subdirectory are XML files created from the Reports Editor. 

The Support Team or our Experts can provide you with ready to use reports compliant 

with your requirements management process and needs. They have to be dropped in that 

subdirectory. 

Templates for Report Styles 

Templates defining the ―style‖ of your reports according to the generation format (RTF, 

HTML, Excel,…) are located in the <installation_dir>\Config\Doc_templates 

directory. 
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Templates are files using the format (and the extension) corresponding to the report 

generation format, and that can be edited directly in the editing tool (Word for RTF, 

HTML editor for HTML, etc.): 

 Templates for RTF (Word) generation shall be named <template-name>.rtf 

 Templates for HTML generation shall be named <template-name>.htm 

 etc. 

Once created, these templates can be selected from the ―Type‖ drop-down list box of the 

Save As dialog box, which opens when you select a report generation. 

Adding Configuration Files in the Project Directory 
When you perform an additional customization in your project environment, configuration 

files are located in the project directory, or in subdirectories. 

You can also add configuration files in the project directory, or in its subdirectories, to 

make a configuration available only for the project. 

Note 

Select File > Open Project Directory to quickly open the project directory. 

Types Definition 

The <project_name>.types file contains the information about the different types of 

analysis created for your project from the Types Editor. 

Rhapsody Gateway will also take into account all the files contained in the project 

directory with the .types extension. 

Therefore, if you customize default types: 

 You can make them available for all projects by locating those files in the 

installation directory. See the section about Default configuration files to learn 

more. 

 You can make them available for any other project by copying the types file into 

the new project directory. You do not have to rename it. 

Report Templates 

The doc_models subdirectory contains XML file(s) for reports created from the 

Reports Editor. 

Rhapsody Gateway will also take into account all the files contained in the doc_models 

subdirectory of the project directory. 
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Therefore, if you customized reports: 

 You can make them available for all projects by locating those files in the 

installation directory. See the section about Default configuration files to learn 

more. 

 You can make them available for any other project by copying the file into the 

new project directory; in a doc_models subdirectory (create it if it does not 

already exist). 

Templates for Report Styles  

The doc_templates subdirectory contains file(s) for report styles. 

Rhapsody Gateway will also take into account all the files contained in the 

doc_templates subdirectory of the project directory. 

Therefore, if you customized report styles: 

 You can make them available for all projects by locating those files in the 

installation directory. See the section about Default configuration files to learn 

more. 

 You can make them available for any other project by copying the file into the 

new project directory; in a doc_templates subdirectory (create it if it does not 

already exist). 

As for default ones, these templates can be selected from the ―Type‖ drop-down list box 

of the Save As dialog box opened when you select a report generation. 

Project Files 

Project Configuration File 

The <project_name>.rqtf file contains the definition of the project configuration, 

defined from the project editor window. 

This file is located in the project directory. 

Analysis Results File  

The file <project_name>.rqtfimage is created after the first analysis of project 

information. This file contains the analysis results. 

This file is in a binary and is proprietary, therefore you cannot edit it. If you delete it, 

Rhapsody Gateway will re-analyze all the project documents to re-create this file. 
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Note 

If you want to exchange information between teams or with the Support Team, you 

can send the rqtfimage files and use the product as a viewer: Select File > Open 

and select ―Project snapshot‖ from the File Type drop-down list box of the Open 

dialog box. 

 

The project directory may contain a subdirectory called Snapshots. These files contain 

the analysis results saved as snapshots using the Snapshot editor. 

They are named automatically with the following syntax: 

<project_nameYYMMDDHHNN>.rqtfimage 

The information YYMMDDHHNN specifies the date the file was saved: 

 YY is the year 

 MM is the month 

 DD is the day 

 HHNN is the time in hours and minutes 

Filter Definition File 

The file <project_name>.filters contains the definitions of project filters created 

from the Filters editors, and the status of the current filter activated for the project.  The 

file also contains information concerning display filters such as user‘s selection about 

show/hide requirements, show/hide empty sections, etc. This file may not exist. 

The filter file is located in the project directory. Several filters files can be placed in the 

project directory, they are all taken into account. 

Sharing Filter Files 

Some filter files can be placed in library to be used for each project. Copy the filter file 

into the filters directory of <Installation directory>\config directory to 

place the filter in library.  
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Environment Variables Declaration 
The positioning of some environment variables allows you to parameterize certain data 

such as the redefinition of directories. 

TMP Environment Variable 

The temporary files generated by Rhapsody Gateway are principally intermediate files, 

when these files are not stored.   

By default these temporary files take place into the user temporary directory: 

<User Local Settings>\Temp 

 

It is possible to change the temporary files location by moving the TMP environment 

variable. This is useful when temporary files take a lot of place. 

 

To redefine the temporary files location, follow these steps: 

1. Open the Options dialog box (Tools > Options). 

2. Create a new environment variable named TMP. 

3. In the Value field, assign the new temporary files location. 
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Debugging Directory 

When the tools coupled with Rhapsody Gateway encounter problems, they return 

debugging files placed into the <User Application Data>\TNI\<Rhapsody 

Gateway> directory. 

To modify the location of these files, follow these steps:  

Edit the .ini file. 

In the [General] section (create this section if it does not exist), define the variable: 

ApplicationDataDir. 

Assign the new location to the ApplicationDataDir key. 
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Appendix: Command 
Line Options 

This section presents all other available Rhapsody Gateway command line options. 

-l <eng|fra|jpn> 
This option allows the user to run Rhapsody Gateway in another language than the default 

(computer related) one. 

-l must be followed by: 

    * eng for English 

    * fra for French 

    * jpn for Japanese 

Example: Rhapsody Gateway -l eng 

Config="<ConfigDir1>, <ConfigDir2>, ..." 
This option allows you to run the application loading several configuration directories. 

This is useful when files are shared between several users. 

In this case, a common configuration directory can be created containing its own types, 

otscript, images, doc_models directories. 

Then running Rhapsody Gateway with the Config option allows to use this shared 

configuration directory. 

Example: Rhapsody Gateway Config="C:\Program Files\...\Rhapsody 

Gateway x.x\config,S:\Shared\config_200901" 

Note 

The first configuration directory must be the tool ―config‖ directory. 

Note 

The path to specify for configuration directories must be an absolute path. 
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-regserver 
This option allows you to register COM server adding entries to the operating system 

registry. 

Example: Rhapsody Gateway -regserver 

Note 

This option is Windows-compatible only. 

-unregserver 
This option allows you to remove registry entries added through '-unregserver' command. 

Example: Rhapsody Gateway -unregserver 

Note 

This option is Windows-compatible only. 

-sync 
This option allows you to run the application in X synchronous mode. The synchronous 

mode forces the X server to perform each X client request immediately and not use buffer 

optimization. It makes the program easier to debug and often much slower. 

Note 

This option is Linux-compatible only. 
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