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Rational Insight and Rational System Atchitect Integration Guide 

Rational Insight and Rational System 
Atchitect Integration 

 Introduction 
This guide provides instructions for producing a simple report from Rational Insight 
using Rational System Architect repositories. Although you can generate report from live 
data sources as well, the scope of this document is to provide instructions for generating 
reports from data stored in a data warehouse. 

The figure shown below indicates the phases required to generate a report. 

 
The overall tasks for generating reports from a data warehouse are as follows: 

•  Generate a XDC file using XML Data Configuration. 

•  Model the physical database in the Data Manager by using the XDC file. 

• Extract the data from Rational System Architect through the ETL process. 

•  Model the metadata and publish packages using the framework manager. 

•  Publish the report using the browser. 
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Generating the XDC file using XML Data Configuration 

Generating the XDC file using XML Data Configuration 
Generate the XDC with the XML Data Configuration as follows: 

1. Start XML Data Configuration.  

2. Click File>Create Configuration. The New Configuration dialog is displayed. 

3. Enter a file path in the Location field and a name in the Name field. 

4. Click OK. 

Once the New Connection is created you need to create the following items: 

• Create Resource Group 

• Create Resource under the Resource Group 

• Create Data Mapping Templates 
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Creating Resource Group 

The XML Data Configuration gets loaded with a tree structure.  

1. Right click on Resource and select New> Resource Group. The new Resource 
Group dialog is displayed. 
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Generating the XDC file using XML Data Configuration 

2.  Enter values for the Name and Description fields.  

3.  Chose the Authentication Type as None. Ensure that the client logged in to this 
machine has sufficient access to Rational System Architect encyclopedia repository 
from where the information is fetched. 

4.  Provide the REST URI in the Data Service field. The REST URI should be 
specified till the workspace level. 

5.  Click on Test Connection to validate the connection to the REST URI.  Click 
Finish after testing the connection.  
 
A message box informs you if the connection is successful. If the connection is not 
successful, the message box displays a “Connection Refused” message. This means 
that the Rational System Architect REST Service is not running on the specified 
machine.  

Creating Resource under the Resource Group 

1.  Right click on the above created Resource Group to create Resource under it. 

2.  Enter values for the Name and Description fields.  

3. Select the Locate using data service and click Next.  The encyclopedia tree panel is 
shown.  

4. Select the class node in the right side of the tree.  

5. Check the href and name checkboxes and click Next. 
6.  Select the Definitions URI and click on Next. The Definition tree panel is 

displayed.  

7. In the XML schema pane, select the type node.  

8. In the Element attributes pane check the href and name checkboxes and click 
Next. 

9.  Select the definition type to generate for your report and click Finish. 
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Creating Data Mapping Templates 

1. Right-click on the resource created above,  and select New> Data Mapping 
Table. The New Data Mapping Table dialog is displayed. 

2.  Enter values in the Name and Description field. You should enter suitable values, 
such as the name “SADefinitionMapping,” and description “Retrieval of Rational 
System Architect definitions through the REST API.” 

3. Click Next. 
4.  Under the Definitions node, select definition your are mapping click Next. The  

Create or Select a Data Mapping Table screen is displayed.  

5. Select Create a new template, if you do not have an existing template., and click 
Next. The Create a Data Mapping Template screen is displayed. 

6.  Enter values for the Name and Description fields and click on Next. 
7.  Define the XML data to Relation Table Mapping, as shown below.  
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Model the physical database in the Data Manager by using the XDC file 

 

8. Click Finish when you are done mapping. 

9.  On the newly created Data Mapping Template, right-click and select Open. The 
Data Mapping between the XML and the Relation Table is shown below. If errors 
arise they are displayed at the top of the window. This step completes process of 
generating the XDC files. 
 

 

 Model the physical database in the Data Manager by using the 
XDC file  

Once the XDC file is created, the Data Manger is used to configure the physical 
database from which the information retrieved from Rational System Architect will be 
stored under the data warehouse. The steps for creating the Data Manger are as follows. 

The overall steps you need to take in Data Manager are as follows: 

• Create /Open the Catalog. 

• Import the XDC files created through XML Data Configuration. 

• Import the Data from Rational System Architect into the Data warehouse. 

Create/Open the Catalog 
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The catalog in Data Manager stores all the configuration information. 

1. To run the Data Manager, click the Start> Program Files> IBM Rational 
Insight> IBM Cognos 8> and select Data Manager. 

2. Click the Create a new catalog icon. You can also click Open an existing catalog 
if you have one.  

3. In the New Catalog dialog, enter values for the Name, Business name and 
Description fields.  

4. Click Next. 
5. Choose the database server that you are using, as shown below in the example 

below.  
 

 
 

6. Choose the authentication mechanism,  and enter values for the Server Name and 
Database Name fields.  

7. Click Test Connection. A message box displays test results.  
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If it the test fails, an Error dialog is displayed with error information. 
If the test succeeds, a message box displays “Connection OK.”. 

8. Click Finish when the connection test succeeds. 

9. Click OK to continue. 

Import the XDC files created through XML Data Configuration 

In the Data Manager, proceed as follows: 

1. Click Tools and select ODBC Administrator….  

2. The ODBC Data Source dialog is displayed.  

3. Click the System DSN tab and click Add. The Create New Data Source dialog is 
displayed.  

4. Select IBM Rational Insight XML ODBC Driver and click Finish. 

5. Enter values in Data Source Name and Description fields.  

6. For the Configuration field, click Browse and locate the XDC you created through 
the XML Data Configuration wizard. 

7. Click on OK on all the opened dialogs. 

Import Data from Rational System Architect into the Data warehouse 

In the Data Manager, proceed as follows: 

1. Right-click Builds and JobStreams and select Insert Folder. 
2. Enter values for the Name, Business name, and Description fields and click OK. 

3. Create a folder hive under the folder you created above as necessary. 

4. Right-click on the Connections node to create new connection to the ODBC driver 
you created for the XDC file. 

5. Choose the Data source name which you specified in the IBM Rational Insight 
XML Data ODBC Setup.  

6. Click on Test Connection to check the connection. If the connection succeeds, a 
“Connection OK” message is displayed. 
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7. Click OK once the connection succeeds. 

8. Right-click on the connection node to create a new connection to the Rational 
System Architect Data Source, where the data retrieved from Insight will be stored.  

9. Specify the Data source name, which will be storing the data retrieved from 
Rational System Architect in Rational Insight. As shown below, the data retrieved 
from the Rational System Architect SQL server will be stored in the database name 
RISA.  
 

 
10. Click Test Connection to validate the connection.  

11. In the Data Manger window, expand the Builds and JobStreams folder. 

12. Right-click on the ApplicationDefinition subfolder and select Insert Fact Build 
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to initiate the data transfer from Rational System Architect to Rational Insight.   

Create a Data Source 
In the Data Manager Window, create a Data Source on the above created Fact as 
described below.  

1. Right-click on the DataStream folder and select Insert Data Source. 

2. In the General tab, enter values for the Name and Description fields.  

3. In the Query tab do the following tasks: 

ο Select the data source which was specified in the IBM Rational Insight XML 
Data ODBC Setup. 

ο Expand the nodes and select the Rational System Architect data in which you 
are interested. Right-click on the selected node and click on Add table select 
statement. 
 

4. The Query tab now displays the Query statement, as shown below. 
 

Rational Insight and Rational System Architect Ingetration Guide   11 



Rational Insight and Rational System Atchitect Integration Guide 

 
Optionally, click Test to check the data retrieval from Rational System Architect. 

5. If the data retrieval from Rational System Architect succeeds, click the Result 
Columns tab and click Refresh. The selected data will turn to the output as desired 
columns.  

6. Click OK to close the Data Source Properties panel. 
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AutoMapping to Database  
In the Data Manager Window, create a Data Source on the above created Fact as 
described below.  

1. Right-click on the Data Stream, and select Properties to perform the mapping. 

2. Click Auto Map. 

3. Right-click on Transformation Model, and select Mapping. The Rational System 
Architect data is transformed and mapped to the desired database selection. 

4. Click Auto Map, and select Create New Element as Attribute. 

5. Right-click on the Fact Delivery, and select Insert Relational Table Delivery. 

6. Enter a value in the Name field in the Table Delivery dialog.  

7. Click the Table Properties tab. 

8. Select connection as SADataRetrieved.  

9. Click on the button next to Table Name.  
Note: In Rational Insight , SADataRetrieved is the name of the connection to the 
database that will store the information retrieved from Rational System Architect. 

10. Specify a Table name in the Table Name field.  

11. Click Execute under the context menu displayed on the Fact Build. The data will be 
fetched from Rational System Architect and stored in the data warehouse. 

12. Click OK on the Execute Build dialog. If the data transfer from Rational System 
Architect is successful then amount of data transferred is shown in the console 
window. 
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Framework Manager 
Once the data is the Rational Insight data warehouse, you use Framework Manager to 
model metadata and publish packages.  

Before starting Framework Manger, you need to ensure that the Data Warehouse is 
configured to the correct database and that the sign on user is created. By default 
Rational Insight points to the “SAMPLEDW” data warehouse when it is installed.  

The instructions that follow point you to a “RISA” data warehouse, as an example. 
Therefore, you need change the data warehouse to “RISA.” Please refer to “Data 
Warehouse Change and Signon Creation” section (pg. 23) which describes how to 
change the Data Warehouse and create a sign on user. 

To start Framework Manager proceed as follows: 

1. Click the Start> Program Files> IBM Rational Insight> IBM Cognos 8> and 
select Framework Manager. 

2. Execute each of the following tasks in the Framework Manager (each task is detailed 
in the sections that follow):  

• Create or open a project. 

• Create a new query subject on a project. 

• Create and publish a new package. 

Creating or opening a project 

Rational Insight provides some out-of-the-box (OOB) projects. You can use the existing 
OOB projects and model your data or create a new project. The instructions in this 
section are for creating new project. A project is a set of files that define the metadata in 
one or more models. Models represent data source information. 

3. Click on the Create a new project… hyperlink in the Framework Manager. 

4. Enter values for the Project name field (for example, “SARationalInsight”), for the 
Location field, and click OK. 

5. Select a language in the Select Language field and click OK. 

6. In the Metadata Wizard, select Data Sources, since the data pulled from Rational 
System Architect is stored in the database. This data was pulled from Rational 
System Architect through the Data Manager.  
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7. Click Next to choose the database under the selected data source. 

8. Select RISA from the data source list. This is the database that stores the Rational 
System Architect data pulled through Data Manager.  

9. Click Next. 
10. Select dbo from the object list since the data from Rational System Architect was 

stored in this object which was pulled through Data Manager.  

11. Click Next. The Metadata Wizard dialog shows the following options: 
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12. Click Import. Once the import is done the project will be loaded.  
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Framework Manager 

Creating a new Query Subject on a project 

Once the project is loaded you can insert a new query, through the Query Subject 
context menu, as described below.  

1. Enter a name in the Name field and chose Data Source (Tables and Columns), 
since the data is being retrieved from the tables. 

2. Click OK. The New Query Subject Wizard is displayed. 

3. Select RISA from the data source list. The Run database query subject wizard 
checkbox should be checked. 

4. Click Next. The following options are displayed. 

5. Select the table from the data source list. 

Rational Insight and Rational System Architect Ingetration Guide   17 



Rational Insight and Rational System Atchitect Integration Guide 

 
6. Click Next.  

 
The subsequent dialogs provides an option where you can modify the data through 
some logical expression and filtering. As an example, the dialogs below show how 
modify the data with the relevant information to your requirements.  
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Framework Manager 

 
A Filter Expression is shown below. 
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7. Click Next. The dialog below query subject, with the modifications you made for 

the example. 
 

20   Rational Insight and Rational System Architect Ingetration Guide 



Framework Manager 

 
8. Click Test to validate the query against the Rational System Architect data 

warehouse. 

9. Click Finish to insert a query object in to the project. 

Creating and Publishing a new package 

Once the query object is inserted, you have to create a new package and publish it. 
Create the package as described below.  

1. Right-click on Packages node, and select Create> Package.  
2. Enter values for the Name, Description, and Screen tip fields. 
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3. Ensure that the query object selected below is included in the package in the screen 
displayed below. 

4. Select SQL server as the function sets. If you have stored the database in some 
other data source then select the appropriate data source. 

5. Click Finish. The following dialog is displayed. 
 

 
 
Now that the package has been created, it has to be published though the publishing 
wizard. 

6. Click Yes. In the dialog shown, note the folder location where the package will be 
published. You will need this folder location later when you publish the report.  

7. Click Next. The access control of user on the published package can be controlled 
through the dialog shown.  

8. Add the necessary user and click Next. 
9. Click Publish to publish the packages. 

10. Click Finish. If there are any errors or warnings found during package publishing, a 
Verify checkbox.   

 Publishing Reports 
Once the package is published using the framework manager the report can be generated 
using the published package. The steps for generating the report is mentioned below 
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1. Open the browser window and enter the URI http://localhost:9080/insight/servlet.  

2. The screenshot shown below is displayed 

3. Click on Report studio in the menu shown below to open the report generating UI. 

4. Navigate to your desired folder and select the Package which was published through 
the Framework Manager.  

5. Click on the SARationalInsightProject package which was published in the 
Framework Manager; the package opens in the Reporting UI. 

6. Click on the Create a new report or Template to create new report. Click the 
Existing Template icon if you prefer to open an existing one. 

7. Chose the list item and click OK to produce a sample report with a list of 
definitions.  

8. The reporting UI opens with the list view. The query object is populated in the tree 
view in the explorer window. 

9. Traverse to the SARationalInsightQuery query object in the explorer window. 
This query object was created in the Framework manager. 

10. Switch to the Toolbox pane to drop the relevant controls on the report editing 
window.  

11. Drag and drop the table control on to the editing window.  

12. Drag and drop the necessary fields from the SARationalInsightQuery query object 
in to the table. 

13. Click on the Run Report in the Report UI to generate the report. 

14. The output report is as shown below. You can export it to Microsoft Excel, 
Microsoft Word and other formats. 

 Data Warehouse Change and Signon Creation 
In Rational Insight, you have to change the data warehouse to point to point to the data 
warehouse where the Rational System Architect information is stored. You can do so 
with IBM Cognos Administration, as follows. 

1. Open the browser window and enter the following URI: 
http://localhost:9080/insight/servlet.  
The IBM Cognos Connection screen  is displayed with the Public Folders tab 
selected.  
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2. O the  toolbar, click on query drop-down field and select IBM Cognos 
Administrator. 

3. Click the Configuration tab. 

4. Click RISA in the data source list. It contains the table from where the information 
pulled from Rational System Architect is stored. 

5. Click on the properties icon, (left of the More… link.). 

6. Click the Connection tab. 

7. Click the Edit the connection string icon (right of the Connection string field). 
Ensure that the data warehouse RISA is selected as the Database name value. 
Select RISA if is not the currently selected data warehouse. 

8. After you configure the database, from the Configuration tab, click the New 
Signon icon to create a signon user. 

9. In the New Signon Wizard screen, enter a unique name in the Name field, and 
optionally, enter values in the Description, and Screen tip fields. Ensure this 
signon user is added to the RISA database in the SQL server. 

10. Click Next. 
11. Enter values for the User ID and Password fields, and click Next. The Select the 

users screen is displayed.  

12. To add users and groups that can use the signon, and click Add…. 

13. To choose from listed entries, click the appropriate namespace, and then select the 
check boxes next to the users, groups, or roles. 

14. Click the right-arrow button to add entries from the Available entries column to 
the Selected entries column. 

15.  Click OK. 

16. Click Finish.  The new data source signon now appears in the Type field in the 
Connection tab. 
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Contacting IBM Rational Software Support  

If you cannot resolve a problem with the self-help resources, contact IBM® Rational® 
Software Support.  

Note: If you are a heritage Telelogic customer, you can find a single reference site for all 
support resources at http://www.ibm.com/software/rational/support/telelogic/ 

Prerequisites  
To submit a problem to IBM Rational Software Support, you must have an active 
Passport Advantage® software maintenance agreement. Passport Advantage is the IBM 
comprehensive software licensing and software maintenance (product upgrades and 
technical support) offering. You can enroll online in Passport Advantage at 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html. 

• To learn more about Passport Advantage, visit the Passport Advantage FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quic
kguides.html. 

• For further assistance, contact your IBM representative. 
 
To submit a problem online (from the IBM Web site) to IBM Rational Software 
Support: 

• Register as a user on the IBM Rational Software Support Web site. For details 
about registering, go to http://www.ibm.com/software/support/. 

• Be listed as an authorized caller in the service request tool. 

http://www.ibm.com/software/rational/support/telelogic/
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html
http://www.ibm.com/software/support/


 

Other information  
For Rational software product news, events, and other information, visit the IBM 
Rational Software Web site: http://www.ibm.com/software/rational/.  

Submitting Problems 
To submit a problem to IBM Rational Software Support: 

17. Determine the business impact of the problem. When you report a problem to IBM, 
you are asked to supply a severity level. Therefore, you need to understand and 
assess the business impact of the problem. 

To determine the severity level, use the following table. 

Severity Description 
1 The problem has a critical business impact: 

you are unable to use the program, resulting 
in a critical impact on operations. This 
condition requires an immediate solution. 

2  The problem has a significant business 
impact: the program is usable, but it is 
severely limited. 

3 The problem has some business impact: the 
program is usable, but less significant 
features (not critical to operations) are 
unavailable. 

4 The problem has minimal business impact: 
the problem causes little impact on 
operations or a reasonable circumvention to 
the problem was implemented. 

 
Describe the problem and gather background information. When you describe the 
problem to IBM, be as specific as possible. Include all relevant background information 
so that IBM Rational Software Support specialists can help you solve the problem 
efficiently. To save time, know the answers to these questions: 

• What software versions were you running when the problem occurred? 
• To determine the exact product name and version, use the option 

applicable to you:  
o Start the IBM Installation Manager and click File > View 

Installed Packages. Expand a package group and select a 
package to see the package name and version number.  
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o Start your product, and click Help > About to see the 
offering name and version number.  

• What is your operating system and version number (including any 
service packs or patches)? 

• Do you have logs, traces, and messages that are related to the problem 
symptoms? 

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem?  

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components?  

Are you currently using a workaround for the problem? If so, be prepared to describe 
the workaround when you report the problem. 
Submit the problem to IBM Rational Software Support in one of the following ways: 

• Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/. In the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR) to describe the problem. 

• For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html. 

• You can also open an online service request by using the IBM Support 
Assistant. For more information, go to 
http://www.ibm.com/software/support/isa/faq.html. 

• By phone: For the phone number to call in your country or region, visit 
the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region.  

• Through your IBM Representative: If you cannot access IBM Rational 
Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. For complete contact information for each 
country, visit http://www.ibm.com/planetwide/.  
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Notices 
© Copyright IBM Corporation 1986, 2010. 

This information was developed for products and services offered in the U.S.A. IBM 
may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and 
services currently available in your area. Any reference to an IBM product, program, or 
service is not intended to state or imply that only that IBM product, program, or service 
may be used. Any functionally equivalent product, program, or service that does not 
infringe any IBM intellectual property right may be used instead. However, it is the user's 
responsibility to evaluate and verify the operation of any non-IBM product, program, or 
service. 

IBM may have patents or pending patent applications covering subject matter described 
in this document. The furnishing of this document does not grant you any license to 
these patents. You can send written license inquiries to: 

IBM Director of Licensing  
IBM Corporation  
North Castle Drive  
Armonk, NY 10504-1785 

For license inquiries regarding double-byte character set (DBCS) information, contact 
the IBM Intellectual Property Department in your country or send written inquiries to: 

IBM World Trade Asia Corporation  
Licensing  
2-31 Roppongi 3-chome, Minato-ku  
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any other country 
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS 
MACHINES CORPORATION PROVIDES THIS PUBLICATION “AS IS” 
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied 
warranties in certain transactions. Therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes 
are periodically made to the information herein; these changes will be incorporated in 
new editions of the publication. IBM may make improvements and/or changes in the 
product(s) and/or the program(s) described in this publication at any time without 

28   Rational Insight and Rational System Architect Ingetration Guide 



Notices 

notice. 

Any references in this information to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The 
materials at those Web sites are not part of the materials for this IBM product and use of 
those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes 
appropriate without incurring any obligation to you.  

Licensees of this program who wish to have information about it for the purpose of 
enabling: (i) the exchange of information between independently created programs and 
other programs (including this one) and (ii) the mutual use of the information which has 
been exchanged, should contact: 

Intellectual Property Dept. for Rational Software  
IBM Corporation  
1 Rogers Street  
Cambridge, MA 02142 
U.S.A 

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee.  

The licensed program described in this document and all licensed material available for it 
are provided by IBM under terms of the IBM Customer Agreement, IBM International 
Program License Agreement or any equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. 
Therefore, the results obtained in other operating environments may vary significantly. 
Some measurements may have been made on development-level systems and there is no 
guarantee that these measurements will be the same on generally available systems. 
Furthermore, some measurements may have been estimated through extrapolation. 
Actual results may vary. Users of this document should verify the applicable data for 
their specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those 
products, their published announcements or other publicly available sources. IBM has 
not tested those products and cannot confirm the accuracy of performance, 
compatibility or any other claims related to non-IBM products. Questions on the 
capabilities of non-IBM products should be addressed to the suppliers of those 
products. 

This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the names 
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of individuals, companies, brands, and products. All of these names are fictitious and any 
similarity to the names and addresses used by an actual business enterprise is entirely 
coincidental. 

Copyright license 

This information contains sample application programs in source language, which 
illustrate programming techniques on various operating platforms. You may copy, 
modify, and distribute these sample programs in any form without payment to IBM, for 
the purposes of developing, using, marketing or distributing application programs 
conforming to the application programming interface for the operating platform for 
which the sample programs are written. These examples have not been thoroughly tested 
under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, 
or function of these programs. 

Each copy or any portion of these sample programs or any derivative work, must 
include a copyright notice as follows:  

© (your company name) (year). Portions of this code are derived from IBM Corp. 
Sample Programs. © Copyright IBM Corp. 2000 2010.  

If you are viewing this information softcopy, the photographs and color illustrations may 
not appear. 

Trademarks 

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions worldwide. 
Other product and service names might be trademarks of IBM or other companies. A 
current list of IBM trademarks is available on the Web at “Copyright and trademark 
information” at www.ibm.com/legal/copytrade.html. 

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, 
other countries, or both. 

Other company, product or service names mentioned may be trademarks or service 
marks of others. 

http://www.ibm.com/legal/copytrade.shtml
http://www.ibm.com/legal/copytrade.shtml
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