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Content

 This deployment guide supports the IBM® Rational® Focal Point IT Portfolio 
Management Configuration Add On 1.1.

 The IT Portfolio Management Configuration Add On is a pre-configured Rational Focal 
Point workspace that you can use to manage your IT portfolio. You can use the add-on 
as a starting point to manage projects with Rational Focal Point. You can customize the 
add-on to meet your needs.

 The deployment guide contains information that you can use to maintain and customize 
the workspace.

 

After you import the IT portfolio management configuration add-on workspace into 
Rational Focal Point, you can use it without making changes. However, you might want 
to customize the workspace to suit your the needs. You can configure Rational Focal 
Point so that your workspace will best fit within the way you want approach IT portfolio 
management. This deployment guide contains instructions to complete both required and 
optional configuration activities. It also contains details about the workspace so that you 
can understand how it works. 
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Objectives for the IT Portfolio Management 
Configuration Add On 
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Objectives for the IT Portfolio Management Configuration Add On

 Align your project portfolio with your strategic objectives.

 Analyze and monitor project portfolio health.

 Make informed decisions about your portfolio.

 Analyze the value of projects by using actual data and pairwise comparisons.

 Create relationships between portfolios, projects, risks, business needs etc.

 Display data in analytical views; e.g capacity analysis, risk assessment, application gap analysis

 Create project business cases and pre-plans.

 Capture and edit projects, risks, issues, change requests, business needs, etc.

 Do high-level project resource planning, scheduling and scoping.

 Monitor progress of project implementation.

 Transfer a project to IBM® Rational® Project Conductor and retrieve updates.

 Do application value realization.
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Prerequisites

 To follow this deployment guide, you must be a Rational Focal Point administrator.

 To import the IT portfolio management configuration add-on workspace to Rational Focal 
Point, you must have version 6.4.1 (or later) installed. To install Rational Focal Point 
6.4.1, follow the instructions on the IBM Rational Support Site.

 

IBM Rational Support Site 
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Section 1 – Installing the Configuration Add On 
Workspace 
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Section 1 – Installing the Configuration Add On Workspace

1. After you install Rational Focal Point, log in as an administrator.

2. Click General > Workspaces.

3. In the bottom frame, click the Import Workspace button.

4. Browse to the IT Portfolio Management Configuration Add On v1.1 file 
(.fpz).

5. In the bottom frame, click OK.

6. Make sure that your administrator account is mapped to the Admin user.

7. In the bottom frame, click Import. Wait until the import has finished; it might take a few 
minutes.

8. Open the workspace by clicking IT Portfolio Management Configuration Add On.
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IBM Software Group | Rational softwareIBM Software Group | Rational softwareIBM Software Group | Rational software

Section 2 – Preparing Rational Focal Point 

 To prepare to use Rational Focal Point, complete these tasks:
 General preparations

 Rearranging home page windows

 Updating the business rules

 Optional: Setting up the integration with Rational Project Conductor

 Environment-specific preparations

 Specifying application settings

 Updating configuration data

 Activating notifications

 Adding data

 Adding users

 Sending user names and passwords to users

 Archiving data
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Section 2 – Preparing Rational Focal Point 

 General preparations – Rearranging homepage windows
 After the workspace is imported, the original order of the homepage windows for the different roles 

is not kept intact.

 Click Members > Members.

 For each role, make sure that the Welcome to IT Portfolio Management in Focal Point window is on 
the upper left side among the My Home windows.

 General preparations – Updating the business rules
 The workspace contains many pre-defined business rules, some of which must be updated to work 

in your environment because they use database IDs to run.

 Find the database IDs for your environment. For the instructions to find the IDs, in the help system, 
search for ”How to find the ID number.”

 Follow the instructions in the notes of this slide.

 

LinkInfo is in the Projects module in the Issue Info, Change Requests Info and Risk 
Details attributes: 

1. Click Configure > Attributes > Projects > Issue Info. 

2. In the Default Value field, update the business rule: Replace the parameter 13 
with the ID of the Admin member in your environment. 

3. Click Copy Default Value To All Elements. 

4. Update the Change Requests Info and Risk Details attributes by clicking 
Configure > Attributes > Projects > Change Requests Info and Configure > 
Attributes > Risk Details and following steps 2-3. 

SetChoice is in the Risks module in SetChoice – Priority attribute.  

To update the attribute: 

1. Click Configure > Attributes > Risks > SetChoice – Priority 

2. In the Default Value field, update the business rule. The business rule currently 
contains this information: 
=SetChoice("438","303","true","303_1","304_2","305_3",'SetChoice Helper'). 
Replace the following parameters with the database IDs of your own 
environment: 
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ID Explanation 

438 The attribute ID of the Priority attribute in the Risks module 

303 The Choice item ID for 1 – High in the Priority attribute in the Risks 
module 

304 The Choice item ID for 2 – Medium in the Priority attribute in the Risks 
module 

305 The Choice item ID for 3 – Low in the Priority attribute in the Risks 
module 

 

3. After the IDs are updated, click the Copy Default Value To All Elements button 
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Section 2 – Preparing Rational Focal Point  
 Environment-specific preparations – Specifying 

application settings
 For Rational Focal Point to send account information, e-mails, 

notifications, and exceptions, the e-mail settings must be correct. 
Your IT staff might need to determine the proper settings.

1. Click Application > Mail. Double-click the following information to 
edit it: 

 Set the SMTP Host and SMTP Port attributes according to your 
environment.

 Set the Rational Focal Point Server Mail Name to the name that 
is in the From field in e-mails sent from Rational Focal Point.

 Set the Rational Focal Point Server Mail Address to the inbox 
that is established for handling system-related e-mails.

 Set the Default Mail Footer, to provide, for example, a support 
number to call.

 Set the Mail Format (HTML, Plain Text, or Mixed).

2. Click Application > Support/Contact and set the Support and 
Contact Information attributes.

3. Click Application > Login Page and set the Login or Balancer 
URL to the appropriate string. Set the URL to be the same URL that 
is used to log in to Rational Focal Point; for example, 
http(s)://focalpoint.example.com/fp/servlet/Login.
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Section 2 – Preparing Rational Focal Point 

 Environment specific preparations – Updating configuration data
 The IT Portfolio Management Configuration Add On workspace is configured in a way that it 

includes references to for example strategic objectives and images. You need to update those to 
your own data.

 Update the following information (see instructions in the notes of this slide):

 Strategic objectives

 Images

 Project Types

 Project Cost Estimate

 Application – Department & Location

 Resource Profiles

 Internal Rate 

 Criteria for Gap Analysis

 

Strategic objectives 

1. Click Modules > Criteria > Strategic Objectives. 

2. Update the Title of the strategic objectives to reflect your own strategic 
objectives. To reach the number of strategic objectives that you want, add or 
delete objectives. 

3. For each strategic objective, also enter the Weight attribute. Enter the number in 
integers as percent, because the weight is the importance that the objective has 
relative the other strategic objectives. For example: Objective 1 – 13, Objective 2 
– 26, Objective 3 – 20, Objective 4 – 8, Objective 5 – 32. 

4. Select the Strategic Objectives folder and edit the Importance attribute. 

5. Enter the weight for the strategic objectives. 

Images 

1. Click Modules > Images. 

2. Click the IBM element. To change the logo image, double-click the Title row and 
browse to your own logo image file. 

3. Optional: Click the Process element. To change process image, double-click the 
row below Process and then browse to your own process image file.  

4. Click Configure > Views > Images > Logo. 

5. Edit the View Definition and update the rule to contain the name of file. 
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Project Type 

1. Click Configure > Projects > Type. 

2. Update the project types that you prefer to capture. 

Project Cost Estimate 

1. Click Configure > Projects > Total Project Cost. 

2. Update the cost levels to what is reasonable for you. 

Application – Department & Location 

1. Click Configure > Applications > Department. 

2. Update the department names to those of your own. 

3. Click Configure > Applications > Location. 

4. Update the location names to those of your own. 

Resource Profiles 

1. Click Modules > Resource Profiles. 

2. Add the resource profiles that you have in your organization and their current 
rates. You can use the resource profiles that are used in the project management 
tool (for example, Rational Project Conductor). Examples: Senior Developer, 
Process Owner, DBA, Junior Developer, Tester, Project Manager, Program 
Manager. 

Internal Rate 

The internal rate is used to calculate the Net Present Value (NPV) for the projects. The 
default internal rate is 15%. Only users with the role Executive Stakeholder, Finance, or 
Steering Committee can change this by using the Edit Internal Rate view. Because the 
internal rate exists in the hidden Supporting Module, the administrator must make that 
module visible to change the internal rate. Alternatively, to change the rate, the 
administrator can temporarily change roles to either of the above mentioned roles. To 
change roles and move your admin user to the corresponding folder or role, use the 
Display > Change Roles view. Wait until the browser is refreshed. When you are finished 
making changes, remember to change back to the Administrator role. 

Criteria for Gap Analysis 

1. Click Modules > Criteria. 

2. Open Application Criteria > Gap Analysis folder. Six criteria are in this folder: 
three User Need criteria and three User Satisfaction criteria. Set up these criteria 
to be used by users that have the Application Gap Analyst secondary role. Details 
on roles are described in Section 4: Roles and Homepages. 

3. Assume that the user John Smith is added as a member to the workspace and is 
assigned the role Business Stakeholder and the secondary role Application Gap 
Analyst. To provide John with the required criteria to complete gap analyses, you 
must select John as the Gap Analyst for a User Need criterion and a User 
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Satisfaction criterion. Mark the criteria, edit the Gap Analyst attribute, and select 
John Smith. You can use the remaining criteria in the Gap Analysis folder for 
other users who are Application Gap Analysts.  

4. Because only six criteria for Gap Analysis are created by default, you must create 
one pair (User Need and User Satisfaction) for each application gap analyst that 
you set. To create a criterion, click the Add Criterion button. The Title should 
be: 

="User Need: " + 'Gap Analyst’ for the User Need criterion 

And 

="User Satisfaction: " + 'Gap Analyst’ for the User Satisfaction criterion. 

5. Select the user in Gap Analyst. 
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Section 2 – Preparing Rational Focal Point 

 Environment specific preparations – Activating notifications
 You can activate a notification that is sent to PMO members in when projects are stopped or 

placed on hold:

1. Click Configure >  Notifications.

2. Click the Active icon for the Project Stopped or On Hold notification. When the icon is green, it is 
active.

 

It is possible to create additional notifications for other notification needs in your 
organization. 
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Section 2 – Preparing Rational Focal Point 

 Environment specific preparations – Adding data
 To import projects, business needs, or any other type of elements to Rational Focal Point, the 

elements must first be in a Microsoft® Excel file. The required columns are Id and Title, but you 
can import information to any attribute in the module. 

 Organize your imports in a certain order so that links between elements can be set. For example, if 
you have a link from your business needs to your projects, import the projects first. When you then 
import the business needs, you can include a link column in your Excel file with links to the 
projects, and these links will be automatically created during the import. The module that contains 
the incoming links should have its elements imported first.

 To Import data:

1. Click Modules and select the module in which to import your elements. 

2. In the bottom frame, click the Import <Module Name> button. 

3. Browse to the Excel file. 

4. Click OK. 

5. Make sure that the columns in the Excel file match the attributes in Rational Focal Point. 

6. In the bottom frame, click Import. Do not use the browser until the import is finished.
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Section 2 – Preparing Rational Focal Point
 Environment specific preparations – Adding users
 To add users, you first add the users to the database and then add them to the workspace.

 Adding users to the database:
1. Outside of the workspace, click Users > Manage Users. 

2. Click Add User. 

3. In the corresponding fields, enter the user’s full name, user name, 

and e-mail address. 

4. Click OK.

 Adding users to the workspace:
1. Open the IT Portfolio Management Configuration Add On workspace.

2. Click Members > Members. 

3. Click the folder to add the users to. Each folder represents a role. 

For details about roles, see Section 4 .

4. Click Add Member. 

5. Search for the user to add to the workspace. To list all users, press Enter. 

6. Select the user to add by selecting the user’s check box. 

7. Optional: Search for the next user to add and select that user’s check box. Continue until you have selected all 
of the users that you want to add. If you are adding many users to a workspace simultaneously, add 50-100 
users at a time for best performance. 

8. Click Next. Wait until the next page has finished loading. Depending on how many users you added, the page 
might load slowly. 

9. Click Finish. Wait until the users are added. Depending on how many users you added, the page might load 
slowly. 

10. Verify that the user inherits access to views from the role by selecting a user that you added. Edit the Inherit 
From attribute and select Parent Folder.

 

Add multiple users 

You can also add multiple users in the database. To do so, all of your users must be listed 
in an Excel file. The Full Name and User Name columns are required, and you might also 
use the E-mail and Access columns.  

1. Outside the workspace, click Users > Manage Users.  

2. Click Import Users.  

3. Browse to the Excel file in which you keep your users.  

4. Click OK.  

5. Make sure that your columns in the Excel file match the attributes.  

6. Click Import. Do not use the browser until the import is finished. 
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Section 2 – Preparing Rational Focal Point 

 Environment specific preparations – Sending user names and passwords to users
1. Click Users > Manage Users. 

2. Select the users to whom you want to send user names and passwords. The users must have  
valid e-mail addresses. 

3. Click Send Account Information. 

4. Write a message to the users. The user name, password, and the login URL are included 
automatically. 

5. To send the message by e-mail, click OK.
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Section 2 – Preparing Rational Focal Point 

 Environment specific preparations – Archiving data
 Make sure that you have a plan for archiving data. 

 Depending on the amount of data that is to be stored in Rational Focal Point, you might also need 
to rethink the configuration with regards to modules, views, and attributes. 

 For example, you might have a state for archived elements. Elements in this state are not included 
in views. If the module becomes oversized, you can create a separate module or workspace to 
which old data is moved.
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Section 3 – Modules

 The IT Portfolio Management Configuration Add On workspace contains 18 modules. 

 You can find the modules by clicking Configure > Modules. For details about each 
module, see the general descriptions on the next slide. 

 If you do not want to use a particular module, you can delete it. If you delete a module, 
make sure that you handle any dependencies to the module (see Section 9 –
Dependencies and groups).
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Section 3 – Modules

 Portfolios
 Includes groups of projects

 Provides portfolio overview and stores project 
aggregates

 Projects
 Includes all projects; this module is the central 

entity in the workspace

 Workflow support

 Applications
 Includes internal and external IT applications

 Includes the “products” that you raise business 
needs against

 Can be analyzed for business value, strategic 
alignment, gap analysis, and value realization

 Business Units
 Includes the business units in the organization

 Risks
 Includes risks on portfolio, project and application 

level

Regular modules  Business Needs
 Defines the scope of projects

 In Rational Project Conductor, business needs 
become summary tasks

 Issues
 Shows issues on portfolio and project level

 Workflow support

 Change Requests
 Used for ongoing projects

 Workflow support

 Resource Profiles
 Includes resource profiles in projects

 Resources
 Includes instances of resource profiles for a 

project

 Meeting Minutes
 Used for projects and change requests

 Supports approval decisions

 

The icons for each module are also visible as the icon in front of each view that is based 
on that module. You can use the icons to easily find the modules. Users can sort their 
views in these module groups by following these steps: 

1. Click Preferences > Miscellaneous Settings. 

2. Under View Sort, select By Attribute > View Definition. 
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Section 3 – Modules

 Criteria
 Contains the strategic 

objectives

 Contains criteria for 
prioritizing 
applications and 
projects

 Images
 Includes images in the 

workspace

 How to…
 Includes tips for the 

administrator

 Supporting Module 
(Hidden)
 Contains the internal 

rate that is used to 
calculate NPV

Supporting modules

 Use Cases
 Contains brief 

descriptions of the 
use cases in the 
workspace and the 
views to use

 In this module, you 
can filter on role to 
see use cases for 
your role

 Attributes
 Contains the 

attributes in the 
workspace that have 
dependencies on 
other attributes, 
criteria, or views

 Attribute Groups
 Contains groups of 

attributes with 
dependencies
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Section 3 – Modules

 Information model

 

This information model shows how the modules in the IT portfolio management 
configuration add-on workspace are related to each other through links. 

Note: This model does not include the following information: 

 Relationships with the Members module (for example, for links to the IT analyst, 
risk owner, or application owner) 

 Modules that support the configuration, such as Images, Use Cases, How to..., 
Supporting Module (hidden), Attributes and Attribute Groups 

 The Criteria module, which contains the Strategic Objectives 
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Section 3 – Modules

 Adding modules in the workspace:
When you add a module, create the necessary views and assign them to the appropriate roles.

 Deleting modules in the workspace:
 Before you delete a module, consider whether any other modules have dependencies on that 

module. For more information, see Section 9: Dependencies and groups.

 Adding attributes in a module:
When you add more attributes to an existing module:

 Make sure that you include the new attribute in the correct views (not visible, visible, or editable). 
View any similar attributes and the views that they are included in, and copy those attributes as 
appropriate.

 If you add attributes in the Projects, Issues, or Change Requests modules, consider the 
workflow definition. After you create the attribute, click Configure > Workflow > [Module] and 
update the settings for the states and the transitions so that those settings fit your purpose with 
the attribute.

 Deleting attributes in a module:
 Before you delete an attribute, consider whether any other attributes have dependencies on that 

attribute. For more information, see  Section 9: Dependencies and groups .
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Section 4 – Roles and Homepages

 Main roles

 Administrator

 Business Stakeholder

 Executive Stakeholder

 Finance

 IT analyst 

 PMO

 Steering Committee

 Secondary roles
 Application Gap Analyst

 Issue Resolver

 Proposal Owner 

 

Main Roles: The IT Portfolio Management workspace includes a set of pre-defined 
roles. All members of the workspace should have a main role. In the Members > 
Members view, place users in the folders of their main role. The pre-defined roles in the 
Members > Members view are described below. 

All users can complete the following tasks: 

 Add and display project proposals and business needs  

 Handle change requests 

 Own risks 

 Investigate business needs 

 Read all delivered and rejected proposals, all change requests, and the process 
diagram 

 View use cases to help users understand which Rational Focal Point view to use 
for what tasks 

A list of all administrators is provided to all users in case they need help or access. 

Secondary Roles: Sometimes a person needs to be selected to complete a task; for 
example, to create the business case for a project proposal. To complete a task, any 
person can be assigned a secondary role in addition to their main role. There are three 
pre-defined secondary roles: proposal owner, issue resolver, and application gap analyst.  

© Copyright IBM Corp. 1997, 2010     
IBM® Rational® Focal Point™ IT Portfolio Management Configuration Add On 1.1     Deployment Guide  24 of 69 



 

 

Assign at least one person as the proposal owner and at least one person as the issue 
resolver. The application gap analyst role is necessary if you want to allow certain people 
vote on the need and satisfaction level for applications to support the application gap 
analysis. To manage secondary roles, click Members > Members > [Select member] > 
Secondary Roles. 

Main roles: 

 Administrator – Administers Rational Focal Point and updates and maintains the 
configuration of the IT portfolio management workspace 

 Business Stakeholder – This role is primarily read-only. It is for users in the 
organization who are interested in information stored in Rational Focal Point. As 
all other main roles, the business stakeholder can add project proposals and 
business needs. The business stakeholder can also be assigned to handle change 
requests, own risks, or investigate business needs. 

 Executive Stakeholder – This role is an executive with interest in the project 
portfolio and the overall portfolio situation, but who does not have access to make 
approval decisions or prioritize projects. 

 Finance – This role is primarily read-only. People in the finance role can edit 
internal rate and financial data; for example, financials (budget, planned, actual) 
for projects and applications. 

 IT Analyst – This role is part of the IT organization in the business. The IT 
analyst does first and second assessment of projects proposals. The first 
assessment is to determine whether a proposal is a project or something else. The 
second assessment is to do the initial estimation of the project proposal. 

 PMO – Creates the pre-plan for a project after it has been approved. The pre-plan 
includes defining the resource demand, the scope, and the target dates. The PMO 
also transfers projects approved for implementation to Rational Project Conductor 
and then monitors their progress by retrieving regular updates in Rational Focal 
Point. In addition, the PMO manages business needs, change requests, and issues. 

 Steering Committee - Makes approval decisions about the project portfolio. 
Approves business cases, prioritizes project proposals (value analysis), reviews 
the project road map, does capacity analysis and project implementation 
approvals, and approves change requests. The steering committee also monitors 
the portfolio health, analyzes project balance, reviews strategic alignment of 
projects, and analyzes the portfolio risk scorecard. 

Secondary roles: 

 Application Gap Analyst - Can vote on how much they need a certain 
application and how much they are satisfied with the same application. The 
results of the application gap analysts’ votes forms the application gap analysis 
chart. 
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 Issue Resolver – Reviews and handles issues related to ongoing projects. New 
issues are reviewed by users with this role. The issue resolver assigns the new 
issue. When the issue is resolved, the issue proposer accepts the solution. 

 Proposal Owner – Provides the project proposal with a business case. The 
proposal owner can also be responsible for creating the pre-plan for the project 
with the PMO. 
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Section 4 – Roles and Homepages

 Each role has a homepage. A homepage consists of one or more windows of information 
that is relevant to a role or user.

 Users with both main and secondary roles inherit the homepage windows for both roles.

 All roles have these windows in their homepages:
Welcome to IT Portfolio Management

in Focal Point

 My Project Proposals to Clarify

 My Change Requests to Handle

 My Owned Open Risks

 

 Welcome to IT Portfolio Management in Focal Point – Contains the IBM logo 
and values. Replace the logo and values with your own logo and text. 

 My Project Proposals to Clarify – Contains projects to be clarified by the user (the 
user is also the submitter of the project). 

 My Change Requests to Handle – Contains change requests to be handled by the 
user. 

 My Owned Open Risks – Contains risks that the user owns and that are in the 
open state. 
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Section 4 – Roles and Homepages
 Role-specific homepage windows:
 Administrator

 Configuration Tips 

 IT Analyst

 Project Distribution

 My Project Proposals To Assess

 Create Business Need 

 Steering Committee

 Portfolio Financials

 Portfolio Health

 Deviation Expected vs Actuals

 Projects with Overrun Planned

 Expenses, Strategic Objectives

 Size of Ongoing Projects (Total NPV) for 
Strategic Objectives

 Open High Priority Portfolio Risks

 Project Distribution: State

 PMO

 New High Priority Change Requests

 Issue State Distribution - Ongoing Projects

 My Change Requests to Analyze and Assign 

 Executive Stakeholder

 Portfolio Financials

 Portfolio Health

 Deviation Expected vs Actuals

 Projects with Overrun Planned

 Expenses, Strategic Objectives

 Size of Ongoing Projects (Total NPV) for 
Strategic Objectives

 Open High Priority Portfolio Risks

 Project Distribution: State 

 Finance

 Portfolio Financials 

 Business Stakeholder

 None
 Proposal Owner

 Create Business Case for Projects

 Issue Resolver

 My Issues to Resolve

 New High Priority Issues

 Application Gap Analyst

 None

 

Administrator 

 Configuration Tips – Contains a list of configuration tips that might interest the 
administrator. 

IT Analyst 

 Project Distribution – Contains a statistical view of the projects distributed by 
state. 

 My Project Proposals To Assess – Contains the project proposals that the user 
must assess. 

 Create Business Need – Contains the proposals that are marked as business needs. 
The IT analyst must create a business need for each of these proposals. 

Steering Committee 

 Portfolio Financials – Contains financial details on the portfolio level. 

 Portfolio Health – Contains portfolio traffic lights. 

 Deviation Expected vs Actuals – Contains graphs that show deviation between 
expected and actual cost and benefits on the portfolio level. 

 Projects with Overrun Planned Expenses– Contains ongoing projects for which 
actual expenses have overrun planned expenses by more than 20%. 
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 Strategic Objectives – Contains a graph that shows the importance of each 
strategic objective. 

 Size of Ongoing Projects (Total NPV) for Strategic Objectives – Contains the 
total NPV of the ongoing projects, distributed by strategic objective. 

 Open High Priority Portfolio Risks – Contains a list of portfolio level risks in the 
open state that are marked as high priority. 

 Project Distribution: State – Contains a statistical view of the projects, distributed 
by state. 

Project Management Office (PMO) 

 New High Priority Change Requests – Contains a list of change requests in the 
new state that are marked as high priority. 

 Issue State Distribution - Ongoing Projects – Contains a statistical view of issues 
for ongoing projects, distributed by the state of the issue. 

 My Change Requests to Analyze and Assign – Contains a list of change requests 
for which the user is the analyst. 

Executive Stakeholder 

 Portfolio Financials – Contains financial details on the portfolio level. 

 Portfolio Health – Contains portfolio traffic lights. 

 Deviation Expected vs Actuals – Contains graphs that show deviation between 
expected and actual cost and benefits on portfolio level. 

 Projects with Overrun Planned Expenses– Contains ongoing projects in which 
actual expenses have overrun planned expenses by more than 20%. 

 Strategic Objectives – Contains a graph that shows the importance of each 
strategic objective. 

 Size of Ongoing Projects (Total NPV) for Strategic Objectives – Contains the 
total NPV of the ongoing projects, distributed by strategic objective. 

 Open High Priority Portfolio Risks – Contains a list of portfolio level risks in the 
open state that are marked as high priority. 

 Project Distribution: State – Contains a statistical view of the projects, distributed 
by state. 

Finance 

 Portfolio Financials - Contains financial details on the portfolio level. 

Proposal Owner 

 Create Business Case for Projects – Contains a list of projects for which the user 
is the proposal owner and must create the business case. 

 

© Copyright IBM Corp. 1997, 2010     
IBM® Rational® Focal Point™ IT Portfolio Management Configuration Add On 1.1     Deployment Guide  28 of 69 



 

 

Issue Resolver 

 My Issues to Resolve – Contains a list of issues for which the user the issue 
resolver. 

 New High Priority Issues – Contains a list of issues in the new state that are 
marked as high priority. 
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Section 4 – Roles and Homepages
 To add additional roles:

1. Click Members > Members.

2. Create a new folder. Name the folder with the title of the new role.

3. Add the users that will have the new role to the folder.

4. Click Configure > Views > Role Specific Views.

5. Create a folder with the same name as the new role.

6. In the role folder, create the following sub-folder structure:
 General Access Views

 Home page Views

 Add Views

 Display Views

 Prioritize/Visualize Views

 Prioritize Only Views

 Visualize Only Views

 Criteria Views [Optional]
7. Create the views for the role. 

8. Verify that the new role can access the correct information by logging in as a user of that role. 
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Section 5 – Views
 Role-based structure of views
 For each role, there are five subfolders:
 General Access Views

– Not visible from the menu, but needed to open links
 Homepage Views

– Views that are used to create the homepage for the role
 Add Views

– Views through which you can add elements
 Display Views

– Views through which you can display elements
 Prioritize/Visualize Views

– Views through which you can prioritize or visualize elements
 Views for all roles in All Members/System Views folder
 Report Views

– Views that are used for reports
 For Link Attributes

– Views that are used to limit elements to pick in Link attributes
 Notification Watch/Recipient Views

– Views to support the notification mechanism
 Criteria Views

– Views used to select certain criteria to use in the prioritize/visualize views
 Integration Views

– Views used to integrate with other tools, e.g. Rational System Architect

 

Note: Because each role has its own set of views, do not give a user another main role as 
the secondary role. For example, do not give an IT analyst the PMO role as a secondary 
role. If a user has a main role as a secondary role, they will have duplicate views.  
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Section 5 – Views

 To add more views:
 Determine which roles will access the view.

 If only one role will access the view, create the view in the subfolder for that role. 

 If more than one role will access the view, create a view for each role and place the views in the 
right subfolders. 

 If all members will access the view, create the view in the appropriate subfolder in the All 
Members/System Views folder.

 If only certain users will access the view, create a new folder in the View structure in which you 
place all views that are assigned to individuals.

 After you create the view, assign it to the roles or users by using the Share View button. 
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Section 6 – Processes

 

The process implemented in the IT portfolio management configuration add-on covers 
project proposal capture, estimations, business cases, reviews, high level planning, and 
capacity analysis before the project moves into Rational Project Conductor. The project 
proposal must pass through several approval gates as it moves through the process.  

 All users can submit a project proposal. Submitters can later on in the process be 
assigned as the proposal owner of the project proposal by the IT analyst. If so, the 
submitter is also responsible for creating the project business case. A project can 
also be added through integration with IBM® Rational® System Architect. More 
on this in Section 8. 

 The IT analyst determines whether the submitted proposal is actually a project or 
before he or she completes the initial investigation and estimations.  

 Proposals that are not accepted as projects can be transformed into business needs 
(for example, an enhancement request against an existing application) or be 
moved into a backlog (for example, if the proposal is rather a defect in an existing 
application). What ends up in the backlog could be moved into other systems. 
Business needs can be included as scope items in the business case of the project.  

 After the IT analyst has finished the initial investigation of the proposal, which 
can include high-level estimations of cost, scope, duration, and time of delivery, 
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the IT analyst can determine whether the proposal needs a business case. For 
example, a project that is expected to have a low cost and short duration might not 
require a business case. Such proposals are moved directly to the prioritization 
phase. However, the majority of projects need business cases, and for a business 
case, the IT analyst selects a proposal owner. The proposal owner can be the same 
person as the project proposal submitter. The business case might include the 
budget for the project, a risk assessment and initial scope definition. The scope is 
refined during the pre-plan phase. 

 The steering committee makes an approval decision for project proposals with 
business cases. If a proposal is approved, it moves into the list of project 
proposals to be prioritized. If it is not approved, it can either be rejected or be 
returned to the proposal owner for further elaboration on the business case. 
Prioritization is done on regular basis; for example, quarterly. The steering 
committee gathers and votes on the proposals to understand their alignment with 
the strategic objectives, their value to the business, their cost, risk, and so forth. 
The result of the prioritization is a ranked list of projects in which the projects that 
score the highest considering all criteria are those that the business will focus on. 
Before approving those highest scoring proposals, the proposals are reviewed 
against ongoing projects to balance the portfolio. 

 The PMO creates a pre-plan (a high level plan), for projects that the steering 
committee has voted as top priority. The pre-plan includes defining the scope in 
detail by associating business needs with the project, studying the budget and 
creating a financial plan, and determining the resource demand. The proposal 
owner can also help to create the pre-plan. 

 Before it approves the projects for implementation, the steering committee 
reviews the pre-plan and studies the resource capacity. If capacity does not exist, 
it is considered in the next portfolio review when new projects are approved for 
implementation. If capacity exists, the project is approved and the PMO moves 
the project from Rational Focal Point into Rational Project Conductor. From that 
point, the project implementation is monitored from Rational Focal Point. It is 
measured to see if the schedule targets are met, if the business needs are 
implemented in time, and if the cost is within plan. It is also possible to raise 
issues and change requests against the ongoing projects. 

 When the project is complete in Rational Project Conductor, it is set as delivered 
in Rational Focal Point. 

Note: This process is implemented through the workflow engine in Rational Focal Point.  
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Section 6 – Processes

Project Process
 Page 1 of 3

 

This screen capture is the first of three detailed process illustrations of the project flow in 
the workspace. This illustration shows the project flow from Draft to Finalize business 
case. 

The next pages contain a list of use cases for the states in part 1 of the project process. 
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Section 6 – Processes

Project 
Process
 Use cases 

for page 1 
of 3

 

The Display > Use Cases view contains information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. This information is continued on the next page. 
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Section 6 – Processes
Project Process
 Use cases for page 1 of 3

 

The Display > Use Cases view contains information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Project Process
 Use cases for page 1 of 3

 

The Display > Use Cases view contains information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Project Process
 Page 2 of 3

 

This screen capture is the second of three detailed process illustrations of the project flow 
in the workspace. This illustration shows the project in the process from Finalize business 
case to Ready for implementation approval. 

The next page contains a list of use cases for the states in part 2 of the project process. 
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Section 6 – Processes

Project Process
 Use cases for page 2 of 3

 

The Display > Use Cases view shows information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Project Process
 Page 3 of 3

 

This screen capture shows the third of three detailed process illustrations of the project 
flow in the workspace. The illustration shows the project in the process from Ready for 
implementation approval to Delivered. 

The next page contains a list of use cases for the states in part 3 of the project process. 
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Section 6 – Processes

Project Process
 Use cases for page 3 of 3

 

The Display > Use Cases view shows information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Issue Process

 

The next page contains a list of the use cases for the states in the issue process. 
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Section 6 – Processes

Use cases for issue process

 

The Display > Use Cases view shows information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Use cases for issue process

 

The Display > Use Cases view shows information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 6 – Processes

Change Request Process

 

The next page contains a list of use cases for the states in the change request process. 
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Section 6 – Processes

Use cases for 
change 
request 
process

 

The Display > Use Cases view shows information about the views to use for each use 
case, the state transitions that are involved, and the roles that act in the use case. This 
view is available for all users. 
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Section 7 - Workflows 
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Section 7- Workflows

 Workflows are 
based on the 
State attribute 
in each 
module.

 Workflows 
enforce the 
processes. 

 To view 
workflows, 
click 
Configure > 
Workflows.

 The workflows 
for Projects, 
Issues, and 
Change 
Requests are 
shown.

 

The workflow is set up for three modules: Projects, Issues, and Change Requests. The 
workflow is based on the State attribute in each module.  

The workflow has two purposes: 

1. Enforce the process of moving a project, issue, or change request from one state 
to another where only certain defined transitions are allowed. 

2. Control which attributes are editable, visible but not editable, or hidden for each 
state, and which attributes are editable or visible during a transition from one state 
to another.  

The workflow feature is related to the views and roles in the workspace. By applying a 
workflow to a view and assigning it to a certain role, you can control what users with a 
certain role are allowed to do in regard to state transfer. Some, but not all of the views 
that are based on the Projects, Issues, or Change Requests modules use workflow. Views 
that do not use the workflow work normally: attributes can be editable, visible, or hidden 
according to the access level that is defined for that view. For views that use the 
workflow both the access level for the view and the access level of the workflow affect 
what the user can see and do. 
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In the IT portfolio management configuration add-on workspace, the following principles 
apply: 

 In views that are not used for transitions, the State attribute is set to Visible (that 
is, read-only). The workflow is not applied on such views. 

 In views that are used for transitions, all attributes are editable or visible. The 
descriptions of these views contain the note “Workflow applied”. The access 
rights on each attribute are defined in the workflow definition. Some exceptions 
exist.  

Adding new attributes: When you add a new attribute to the Projects, Issues, or Change 
Requests modules, you must first update all views based on these modules to set up the 
attribute access. Because several views, especially for projects, have a workflow applied, 
you also must update the attribute access rights in workflow definition.  

By default, a new attribute is set to be editable, so you must edit each state in the 
workflow, set the access rights for the new attribute, and save your changes. However, 
you do not need to update the transitions. 
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Section 7- Workflows

Projects workflow for the State attribute

 The left column contains all of the 
states for a project. You can edit the 
states to choose which attributes are 
visible or editable for that state. 

 The right column contains all of the 
transitions for each state. You can 
edit the transitions to choose which 
attributes are visible or editable for 
that transition. 

 

Although the Ready for prio state is not an end state, transitions are not defined for that 
state because the transition to Pre-plan project is done in a Visualize view (after the 
projects are prioritized), and workflow transitions can only be done in Display views. 
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Section 7- Workflows

 View which attributes are hidden, 
read-only, or visible for a state.

 View which attributes are hidden, 
read-only, or visible for a transition.

 

In the image on the left, you can see the workflow setup on the attribute level for the 
Draft state for a project. For a project that is in Draft state, the settings are as follows: 

 If As View is set for an attribute, the attribute is visible and editable for views that 
have the workflow applied.  

 If Read-Only is set for an attribute, the attribute is visible but not editable for 
views that have the workflow applied.  

 If Hidden is set for an attribute, the attribute is not visible for views that have the 
workflow applied. 

In the image on the right, you can see the workflow setup on a Submit transition for the 
Draft state for a project. For a project in the Submit transition, the settings are as follows: 

 If As View is set for an attribute, the attribute is visible and editable for views that 
have the workflow applied.  

 If Read-Only is set for an attribute, the attribute is visible but not editable for 
views that have the workflow applied.  

 If Hidden is set for an attribute, the attribute is not visible for views that have the 
workflow applied. 
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Section 7- Workflows

 The View Assignments 
area is below the project 
states and transitions.

 This area contains a list of 
all views based on the 
Projects module.

 The views in which the 
workflow is applied are 
selected.

 

You can also assign a workflow to a view from Configure > Views > View Definition. At 
the bottom of the final view definition set up page, select the workflow from the drop-
down list.  
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Section 7- Workflows

 Issue workflow  Change request workflow

 

These screen captures show the workflow definitions for the issue and change request 
State attributes.  
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Section 8 - Integrations 
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Section 8 - Integrations

 The IT portfolio management configuration add-on supports integration with Rational 
Project Conductor.
 As part of the project process, you can create projects in Rational Project Conductor.

 You can also get updates from Rational Project Conductor.

 Attributes in the Projects and Business Needs module are used for the integration.

 The add-on also supports integration with IBM® Rational® System Architect.
 You can transfer projects and strategic objectives from Rational System Architect to Rational Focal 

Point.

 Attributes in the Projects and Criteria modules are used for the integration. It is possible to create 
additional integration relationships.

 Rational Focal Point 6.4.1 includes a technical preview of Financier. 
 If you use Financier to do the financial analysis of projects, you must make the hidden attributes 

with ’Financier’ in their names in the Projects module visible.

 The Rational Focal Point Web services API integrates with estimation vendors. 
 The IT portfolio management configuration add-on includes a hidden attribute in the Projects 

module that, when made visible, can be populated from the estimation tools.

 

The following pages provide more information about each of the integration possibilities. 

 

© Copyright IBM Corp. 1997, 2010     
IBM® Rational® Focal Point™ IT Portfolio Management Configuration Add On 1.1     Deployment Guide  52 of 69 



 

 

IBM Software Group | Rational softwareIBM Software Group | Rational softwareIBM Software Group | Rational software

Section 8 - Integrations

Set up the 
integration with 
Rational Project 
Conductor:
 Click Configure 

> Integrations.

 To set up the 
server for 
Rational Project 
Conductor, 
follow steps 1-6, 
as shown in the 
screen capture.

11

22

33
44

Select the Create 
Project in Project 

Conductor view

Select the Create 
Project in Project 

Conductor view

Enter URL and 
name of the server

Enter URL and 
name of the server

55

66

 

1. Click Configure. 

2. Click Integrations. 

3. Click Add connector. 

4. Select the Create Project in Project Conductor view. 

5. Enter URL and name of the server. 

6. Click Save. 

Set up a connector for each Rational Project Conductor server that you want to integrate 
with. When users create projects, they can select which server the project is created on.  
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Section 8 - Integrations

Integrating with Rational Project Conductor

 When you create a project, the following Rational Focal Point 
attributes move to Rational Project Conductor:

EffortEstimated Man 
Hours

Business Need

Proposed FinishTarget End DateBusiness Need

Proposed StartTarget Start DateBusiness Need

NameTitleBusiness Need

Summary tasksBusiness needsProject

Proposed FinishTarget End DateProject

Proposed StartTarget Start DateProject

DescriptionDescriptionProject

NameTitleProject

Rational Project 
Conductor

Rational Focal 
Point

Module  Also, links to the project in Rational 
Project Conductor are created:
 For users, the Link to Project in Project 

Conductor attribute for a project in 
Rational Focal Point contains the 
visible and clickable link to the project.

 A similar link is in the Link to Business 
Need in Project Conductor attribute for 
a business need in Rational Focal 
Point, but this link is for business 
needs.

 The Implementation Project URI 
attribute in the Projects module 
contains the integration connector link, 
which is mandatory for the integration.
This attribute is hidden from users, and 
the link does not direct you to the 
project in Rational Project Conductor.

 

The IT portfolio management configuration add-on uses most of the supported attributes 
in the integration. To read more about the integration, go to 
http://jazz.net/library/article/351. 

Note: After a project is created, you cannot update these values in Rational Project 
Conductor from Rational Focal Point. 
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Section 8 - Integrations

Integrating with Rational Project Conductor

 When you update a project, the following Rational Focal Point attributes are updated 
with data from Rational Project Conductor:

Percent 
Complete

Completeness 
(%)

Business Need

Actual FinishActual End DateBusiness Need

Planned FinishPlanned End 
Date

Business Need

Actual Start Actual Start DateBusiness Need

Planned StartPlanned Start 
Date

Business Need

Actual WorkActual Man 
Hours

Business Need

Planned EffortPlanned Man 
Hours

Business Need

Rational Project 
Conductor

Focal PointModule

Percent 
Complete

Completeness 
(%)

Project

StateImplementation 
State

Project

Actual FinishActual End DateProject

Planned FinishPlanned End 
Date

Project

Actual Start Actual Start DateProject

Planned StartPlanned Start 
Date

Project

Actual WorkTotal Actual Man 
Hours

Project

Planned EffortTotal Planned 
Man Hours

Project

Rational Project 
Conductor

Focal PointModule

 

In the Projects module, the Total Planned Man Hours and Total Actual Man Hours 
attributes contain the following default business rules:  

 =LinkListAttributeSum("Business Needs","Planned Man 
Hours","listen_to=Planned Man Hours",'Business Needs')  

 =LinkListAttributeSum("Business Needs","Actual Man Hours","listen_to=Actual 
Man Hours",'Business Needs')  

These business rules sum the Planned Man Hours and Actual Man Hours for the business 
needs up to the project level. When updates are made from Rational Project Conductor, 
these values are overwritten with the corresponding project level values in Rational 
Project Conductor. The values are overwritten because the effort for a project in Rational 
Project Conductor can be more than the sum of its summary tasks that were transferred 
from Rational Focal Point in the form of business needs. Other tasks, defects, or issues 
might be included in the project effort calculation in Rational Project Conductor.  

If you want to keep the business rules when you use the integration, in the Projects 
module, remove the alias for these two attributes so that these values are not updated 
from Rational Project Conductor, but calculated in Rational Focal Point. 
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Section 8 - Integrations

Integrating with Rational System Architect
 The integration with Rational System Architect is set up in Rational System Architect.

 To move data, use three attributes in Rational Focal Point: Title, Description, and GUID.

 The IT Portfolio Management Configuration Add On comes with the following attributes that are set 
up to support the Rational System Architect integration:
 Projects module

– Title

– Description

– GUID (hidden)

 Criteria module

– Title

– Description

– GUID (hidden)

 Applications module

– Title

– Description

– GUID (hidden)

 To integrate entities other than projects, add a GUID attribute (Type Text) in the module.

 Specify which views to use for the integration. There are three pre-defined views in Configure > 
Views > All Members/System Views > Integration Views that can be used for this purpose: 
 Create Projects in FP from SA

 Create Criteria in FP from SA 

 Create Applications in FP from SA 

 

 

 

© Copyright IBM Corp. 1997, 2010     
IBM® Rational® Focal Point™ IT Portfolio Management Configuration Add On 1.1     Deployment Guide  56 of 69 



 

 

IBM Software Group | Rational softwareIBM Software Group | Rational softwareIBM Software Group | Rational software

Section 8 - Integrations

Integration setup is defined in Rational System Architect (Tools > Focal Point).

Select a workspace,
criteria view, and data view for 

Rational Focal Point

Select a workspace,
criteria view, and data view for 

Rational Focal Point

11

22

Select the report files 
in Rational 

System Architect

Select the report files 
in Rational 

System Architect

33

Map the criteriaMap the criteria Map the dataMap the data

44

 

1. Select a workspace, criteria view, and data view for Rational Focal Point. 

2. Select the report files in Rational System Architect. 

3. Map the criteria. 

4. Map the data. 

After you set up the integration, you can move any information from Rational System 
Architect to analyze in Rational Focal Point; for example, compare projects against 
strategic objectives. 
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Section 8 - Integrations

 Rational Focal Point 6.4.1 comes with a technical preview of the Financier feature.

 If a customer wants to use Financier to do financial analysis, the following hidden 
attributes in the IT portfolio management configuration add-on must be made visible. The 
attributes are in the Financial Information section of the Projects module. 
 Revenue/Cost – Financier (Time Grid)

 NPV probability – Financier (Matrix)

 IRR – Financier (Float)

 ROI – Financier (Integer)

 Payback Period – Financier (Integer)

 To start using Financier and the attributes:
 Include the attributes in project views and workflows.

 Use the same setup for views and workflow as for the existing financial attributes.

 The appropriate Web services aliases are already set. 

 Remove duplicate financial attributes that are no longer needed; for example, NPV, IRR, and ROI.

 For documentation about Financier, see the IBM Rational Focal Point Information Center.

 

The Web services aliases are: 

 NPV probability – Financier: FINANCIER__NPV 

 IRR – Financier: FINANCIER__IRR 

 ROI – Financier: FINANCIER__ROI 

 Payback Period – Financier: FINANCIER__ paybackPeriod 

IBM Rational Focal Point Information Center 
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Section 8 - Integrations

Integrating with the estimation vendor tools

 If a customer wants to use the estimation vendor tools for their project estimations, the 
hidden attributes in the IT portfolio management configuration add-on must be made 
visible. The attributes are in the Initial Estimations section of the Projects module. 

 Probability of Duration (months) (Matrix)

 Probability of Labor Cost (Matrix)

 Probability of Peak Staffing (Matrix)

 Estimate Detail (URL)

 Needed Certainty (Integer)

 For a list of vendors with validated integrations to Rational Focal Point, see Ready for 
IBM Rational Plug-in Central 

 To start using the extra estimation attributes:
 Include the attributes in project views and workflow.

 Use the same setup for views and workflow as for the existing estimation attributes.

 Set the appropriate aliases for the attributes and use them when you integrate through the Rational 
Focal Point Web Services API. For documentation about the API, see the Rational Focal Point 
information Center.

 

You can also set up integration for other attributes in the workspace. For example, you 
might want to estimate business needs. 

To assess whether a project should be created, it is important to understand the amount of 
time and effort required (with the assumption that the effort hours of the team is the 
major factor in how much will it cost). You can use the estimation tools to consider these 
factors. The estimation tools provide more than a number; they provide a probability 
distribution. For example, there is a 20% chance that the project will take 14 months or 
less, but there is a 90% chance that it will be done within 32 months.  

The estimation tools can also provide multiple estimates based on peak team size. For 
example, if X many people work on the project, how long it will take to complete? If Y 
more people are added, how will the schedule change?  

By using the estimation tools, the steering committee can better understand the cost of the 
project and the uncertainty associated with the cost. The relationship between team size 
and duration is not simple; doubling the team size does not halve the duration.  

You can use the estimation tools to make multiple estimates that are difficult to compute 
manually. The estimation tools transfer multiple estimates for a given project into the 
Probability matrixes in the workspace, with each estimate being a probability distribution 
of duration, labor cost, and peak staffing. 

IBM Rational Plug-in Central 

IBM Rational Focal Point Information Center 
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Section 8 – Integrations

Integrating with the estimation vendor tools

 The estimation suite that integrates with the Rational Focal Point configuration for IT 
Portfolio Management might be used by various roles: 
 The Proposal Owner, when they create business cases

 The Steering Committee, when it makes prioritizations and approves proposals 

 The PMO, when it pre-plans the project

 With the estimation suite integration, you can complete these tasks:
 Create a detailed estimate as part of a business plan by using the following input from Rational 

Focal Point:

 Constraints on schedule and cost from the Initial Estimate attributes

 Business needs, which can indicate the scope and size of the project

 Include multiple estimates in business cases, which the Steering Committee can use to assess the 
feasibility of the project for prioritization and approval.  These estimates can be used to assess 
tradeoffs of schedule, cost, and quality levels, and the risk and uncertainty associated with those 
tradeoffs.

When the PMO completes the pre-plan for an approved project, depending on the estimate, you 
can view schedule information and the number of the resources needed by type.

 For details, see the documentation for your estimation suite.  
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Section 9 – Dependencies and Groups

 Attribute management and maintenance
 To scale down the IT portfolio management configuration add-on workspace by removing configuration 

areas or to tailor the workspace to your needs, you must understand the dependencies between 
attributes and their relationships to criteria and views.

 To customize the workspace, use two supporting modules: Attributes and Attribute Groups. 
 The Attributes module contains a list of the attributes in the workspace that have dependencies to other 

attributes, criteria, or views. Those dependencies are shown for each attribute. The attributes are listed 
in the same order as they are in the module.

 The Attribute Groups module contains a list of the groups of attributes. Use this list to understand how 
certain attributes have direct dependencies and belong to chains of dependencies. The groups 
represent these chains.

 Whenever you add, change, or remove attributes that have dependencies, update the information 
in these modules.

 The Administrator can access the views that display the content of the modules:
 Display > Attributes (r/w)

 Display > Attribute Groups (r/w)
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Section 9 – Dependencies and Groups

 You must be an administrator to view attributes. To view attributes, click Display > Attributes 
(r/w).

 Note: Only the attributes that have dependencies are listed.

 For each attribute, you can see the following information (see example on next slide):
 Title – The name of the attribute

 Description – The description of the attribute, as defined in Configure > Attributes > [Module]

 Default Value – The default value for the attribute, if any, as defined in Configure > Attributes > 
[Module]

 Module – The module in which the attribute exists

 Attribute Type – The type of the attribute

 Depends on Attribute – A list of attributes that the attribute depends on to show its value

 Used By Attribute – A list of attributes that uses the attribute to show its value

 Used by Criteria – A list of criteria that uses the attribute as the estimate. Only for Integer attributes.

 Uses Views – A list of views that the attribute uses to show its value. Only for Link, List Link or 
Incoming Links attributes.

 Belongs to Groups – A list of attribute groups that the attribute belongs to
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Section 9 – Dependencies and Groups

 To view attributes, 
click Display > 
Attributes (r/w).

 The screen capture 
shows an attribute, 
Total Problem Index, 
in the workspace.

 The attribute has an 
expression as its 
default value, exists 
in the Products 
module, and is of the 
type Integer. It 
depends on six 
attributes, is referred 
to in one attribute, 
and it is used as the 
estimate for one 
criterion. It belongs 
to the Portfolio and 
Project Health 
group.
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Section 9 – Dependencies and Groups
 To see the chain of 

dependencies for 
attributes:

1. Right-click the tree.

2. Click Display Links. 

 A relational graph 
opens.

3. Click Text Depth – All.

 The dependencies of 
the attributes are 
shown.

4. To see the details of an 
attribute, click the attribute.

5. To see the direct 
dependencies of an 
attribute, hover the cursor 
over the attribute.

 Use this information to 
understand what you 
might need to change 
when you update 
attributes.

 

You can display all of the attributes and their dependencies, but displaying all of that 
information might result in a cluttered chart. To display all of the attributes and their 
dependencies, use the Relational Graph mode instead of the Tree. Use filters to display 
specific information. 
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Section 9 – Dependencies and Groups

 To view attribute 
groups, click Display > 
Attribute Groups 
(r/w).

 Each group contains a 
list of attributes that are 
included in the group.

 To update or remove 
an attribute or a set of 
attributes in the 
workspace, ensure that 
the group in which the 
attributes is included is 
updated correctly.
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More information 

Contacting IBM Rational Software Support 
If the self-help resources have not provided a resolution to your problem, you can 
contact IBM® Rational® Software Support for assistance in resolving product issues. 

Note If you are a heritage Telelogic customer, a single reference site for all support 
resources is located at http://www.ibm.com/software/rational/support/telelogic/ 

Prerequisites  

To submit your problem to IBM Rational Software Support, you must have an active 
Passport Advantage® software maintenance agreement. Passport Advantage is the 
IBM comprehensive software licensing and software maintenance (product upgrades 
and technical support) offering. You can enroll online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html 

•To learn more about Passport Advantage, visit the Passport Advantage FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.h
tml. 

•For further assistance, contact your IBM representative. 

To submit your problem online (from the IBM Web site) to IBM Rational Software 
Support, you must additionally: 

•Be a registered user on the IBM Rational Software Support Web site. For details 
about registering, go to http://www.ibm.com/software/support/. 

•Be listed as an authorized caller in the service request tool. 

Submitting problems 
To submit your problem to IBM Rational Software Support: 

1. Determine the business impact of your problem. When you report a problem to 
IBM, you are asked to supply a severity level. Therefore, you need to understand and 
assess the business impact of the problem that you are reporting.  

Use the following table to determine the severity level: 

 

© Copyright IBM Corp. 1997, 2010     

Severity Description 
1 The problem has a critical business impact: You 

are unable to use the program, resulting in a critical 
impact on operations. This condition requires an 
immediate solution. 

2 This problem has a significant business impact: 
The program is usable, but it is severely limited. 

3 The problem has some business impact: The 
program is usable, but less significant features (not 
critical to operations) are unavailable.  

4 The problem has minimal business impact: The 
problem causes little impact on operations or a 
reasonable circumvention to the problem was 
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implemented. 

 

2. Describe your problem and gather background information, When describing a 
problem to IBM, be as specific as possible. Include all relevant background 
information so that IBM Rational Software Support specialists can help you solve the 
problem efficiently. To save time, know the answers to these questions: 

•What software versions were you running when the problem occurred? 

To determine the exact product name and version, use the option applicable to you:  

•Start the IBM Installation Manager and select File > View Installed Packages. 
Expand a package group and select a package to see the package name and version 
number.  

•Start your product, and click Help > About to see the offering name and version 
number.  

•What is your operating system and version number (including any service packs or 
patches)?  

•Do you have logs, traces, and messages that are related to the problem symptoms?  

•Can you recreate the problem? If so, what steps do you perform to recreate the 
problem?  

•Did you make any changes to the system? For example, did you make changes to the 
hardware, operating system, networking software, or other system components?  

•Are you currently using a workaround for the problem? If so, be prepared to describe 
the workaround when you report the problem. 

3. Submit your problem to IBM Rational Software Support. You can submit your 
problem to IBM Rational Software Support in the following ways: 

•Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/ and in the Rational support task 
navigator, click Open Service Request. Select the electronic problem reporting tool, 
and open a Problem Management Record (PMR), describing the problem accurately 
in your own words. 

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html 

You can also open an online service request using the IBM Support Assistant. For 
more information, go to http://www.ibm.com/software/support/isa/faq.html. 

•By phone: For the phone number to call in your country or region, go to the IBM 
directory of worldwide contacts at http://www.ibm.com/planetwide/ and click the 
name of your country or geographic region.  

Through your IBM Representative: If you cannot access IBM Rational Software Support 
online or by phone, contact your IBM Representative. If necessary, your IBM Representative can 
open a service request for you. You can find complete contact information for each country at 
http://www.ibm.com/planetwide/. 
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Notices 
This information was developed for products and services offered in the U.S.A. IBM 
may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and 
services currently available in your area. Any reference to an IBM product, program, 
or service is not intended to state or imply that only that IBM product, program, or 
service may be used. Any functionally equivalent product, program, or service that 
does not infringe any IBM intellectual property right may be used instead. However, 
it is the user's responsibility to evaluate and verify the operation of any non-IBM 
product, program, or service. IBM may have patents or pending patent applications 
covering subject matter described in this document. The furnishing of this document 
does not grant you any license to these patents. You can send license inquiries, in 
writing, to: 

IBM Director of Licensing 

IBM Corporation 

North Castle Drive 

Armonk, NY 10504-1785 

U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, contact 
the IBM Intellectual Property Department in your country or send written inquiries to: 

Intellectual Property Licensing  

Legal and Intellectual Property Law  

IBM Japan, Ltd.  

1623-14, Shimotsuruma, Yamato-shi 

Kanagawa 242-8502 Japan 

The following paragraph does not apply to the United Kingdom or any other 
country where such provisions are inconsistent with local law: 

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE.  Some states to not allow disclaimers of express 
or implied warranties in certain transaction, therefore, this statement may not apply to 
you. 

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements and/or 
changes in the product(s) and/or the program(s) described in this publication at any 
time without notice. 

Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those Web 
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sites. The materials at those Web sites are not part of the materials for this IBM 
product and use of those Web sites is at your own risk. 

Licensees of this program who wish to have information about it for the purpose of 
enabling (i) the exchange of information between independently created programs and 
other programs (including this one) and (ii) the mutual use of the information which 
has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software 
IBM Corporation 
20 Maguire Road 
Lexington, MA 02421-3112 
U.S.A 

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 

The licensed program described in this document and all licensed material available 
for it are provided by IBM under the terms of the  IBM Customer Agreement, IBM 
International Program License Agreement or any equivalent agreement between us.  

Any performance data contained herein was determined in a controlled environment. 
Therefore, the results obtained in other operating environments may vary 
significantly. Some measurements may have been made on development-level 
systems and there is no guarantee that these measurements will be the same on 
generally available systems. Furthermore, some measurements may have been 
estimated through extrapolation. Actual results may vary. Users of this document 
should verify the applicable data for their specific environment.  

Information concerning non-IBM products was obtained from the suppliers of those 
products, their published announcements or other publicly available sources. IBM has 
not tested those products and cannot confirm the accuracy of performance, 
compatibility or any other claims related to non-IBM products. Questions on the 
capabilities of non-IBM products should be addressed to the supplier of those 
products. 

All statements regarding IBM’s future directions or intent are subject to change or 
withdrawal without notice, and represent goals and objectives only. 

This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual business 
enterprise is entirely coincidental. 

If you are viewing this information softcopy, the photographs and color illustrations 
may not appear. 

Trademarks 
IBM, the IBM logo, ibm.com are trademarks or registered trademarks of International 
Business Machines Corp., registered in many jurisdictions worldwide. Other product 
and service names might be trademarks of IBM or other companies. Other company, 
product or service names may be trademarks or service marks of others. 
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The following terms are trademarks of International Business Machines Corporation 
in the United States, other countries, or both: 

 IBM 

 Rational 

 Focal Point 

 Project Conductor 

Linux is a registered trademark of Linus Torvalds in the United States, other 
countries, or both. 

Other company, product, or service names may be trademarks or service marks of 
others. 
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